Results 1 to 2 of 2

Thread: Belkin F5D7000 (version 20) - Driver needed.

  1. #1
    Join Date
    Jun 2008
    Beans
    6

    Belkin F5D7000 (version 20) - Driver needed.

    I'm trying to get my Belkin F5D7000 wireless G card operating. I followed a couple solutions on here using the ndiswrapper and and few suggested drivers (rtl8185, bcmwl5/bcmwl5a).

    It turns out that for the specific version of the card I have (version 20) it requires a driver, blkwgdv7, that is only available from the installation CD.

    I no longer have the installation CD. Is it possible to get this driver somewhere (or from someone) or is there an alternate driver?

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,567
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Belkin F5D7000 (version 20) - Driver needed.

    Can you get it here? http://www.belkin.com/support/articl...=6001&scid=221 I downloaded version 2xxx. Although the file is an .exe, I did, in a terminal:
    Code:
    cabextract f5d7000_v2_uk.exe
    The needed .inf and .sys were extracted. You card, by the way, is not a version 2xxx. The file I grabbed is for a Realtek chipset.
    Extracting cabinet: f5d7000_v2_uk.exe
    extracting _SETUP~2.EXE
    extracting rt2500.cat
    extracting Rt2500.sys
    extracting Rt25009x.sys
    extracting setup.exe
    Last edited by chili555; June 19th, 2008 at 12:04 PM.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •