I'm running Ubuntu x64 8.04.

Some Flash sites work, some don't. I'd like to uninstall/reinstall newer version of Flash.

In Firefox plugins screen, I see "Shockwave Flash 9.0 r100". There is a button to enable/disable, but no button to uninstall.

In Synaptic, I see Flash 9.0.124.0ubuntu2. That was originally uninstalled. I've installed, but this doesn't seem to affect Firefox. Firefox still shows the same 9.0 r100 version in the plugins dialog. And the same sites still work and don't work like they did before.

How do I update this and get this working?