Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: SSH Login

  1. #1
    Join Date
    Apr 2005
    Beans
    8
    Distro
    Ubuntu 8.04 Hardy Heron

    Unhappy SSH Login

    Trying to log in remotely through SSH.

    I will get an 'operation timed out' msg, when I do, except if a user
    is already logged in on the ubuntu box. This is weird, 'cause another
    ubuntu box (same version, 8.04), which is located within the network, works
    fine through SSH log in, without the need for a user to be already
    logged in.

    Where should I be looking?

  2. #2
    Join Date
    Apr 2005
    Beans
    8
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: SSH Login

    Could this be related to the fact that the machine that SSH login works (without requiring an account to be logged in already), is connected through Ethernet, while the other in Wireless?

    I am setting up the wireless through Gnome Network Manager, in roaming mode. Maybe I have no net connection till Gnome NM is started up?

  3. #3
    Join Date
    Jan 2008
    Location
    Santa Cruz, CA
    Beans
    147
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SSH Login

    I don't think Ubuntu installs an sshd by default. Is one installed? That would explain your time out.. (there's nothing listening on that port..)

    Code:
    sudo apt-get install openssh-server
    Also, are you trying to ssh by hostname or ip? If by ip and you're sure about the IP it shouldn't matter what the connection is..

  4. #4
    Join Date
    Apr 2005
    Beans
    8
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: SSH Login

    I've got OpenSSH server installed and it's running.

    I am SSHing by IP (local network IP).

    The weird thing is, that it allows me to SSH if I go to the physical box and log in there with a user. That's why i am thinking if it's a NM issue. I would try with an ethernet cable, but I would have to move *alot* of stuff around (it's on another floor), so I am looking it to be a last resort.

    Pattern #1:

    SSH from my laptop to the ubuntu desktop: TIMEOUT

    Pattern #2:

    Go the ubuntu desktop, log in with a user account.
    Go back to the laptop and SSH to the ubuntu desktop: WORKS
    Last edited by panosl; June 16th, 2008 at 07:16 PM. Reason: Clarification!

  5. #5
    Join Date
    Jan 2008
    Location
    Santa Cruz, CA
    Beans
    147
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SSH Login

    Ah, sorry for asking obvious questions

    To get this straight could you expclitly say what each is connected by (I didn't understand what you said regarding which is connected via wireless and which by ethernet).

    It does sound like a NM issue. Try doing ifconfig from a tty before you login and then from a terminal after and see if your ip changes (or if you even have one before logging in)

  6. #6
    Join Date
    Dec 2006
    Beans
    1,133
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: SSH Login

    I think you hit the nail on the head with NetworkManager. This is a real problem IMHO. I'm not certain of the exact commands you'll need, but something like this added to /etc/rc.local might get it going, substitute your wireless interface for wlan0:

    ifconfig wlan0 up
    iwconfig wlan0 mode managed essid your-esssid-name
    dhclient wlan0

    This assumes you have a wireless router operating in managed mode with a dhcp server running, more or less the usual case.

    This will probably need some tuning and there may be adverse consequences when NetworkManager starts up later! Good luck!
    There are no dumb questions, just dumb answers.

  7. #7
    Join Date
    Apr 2005
    Beans
    8
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: SSH Login

    I should've mentioned them earlier

    So, here's the setup:

    1. laptop: OS X Leopard, WIRELESS
    2. desktop 1: Ubuntu 8.04, WIRELESS
    3. desktop 2: Ubuntu 8.04, ETHERNET


    • laptop -> desktop 2: WORKS
    • laptop -> desktop 1: DOES NOT WORK*


    * Works only if I go over to the physical box, and log in with a user account first.

    running ifconfig in recovery mode (root shell), only has lo set up, no wireless. Of course that's not enough as desktop 1 is not connected through ethernet, it's wireless.

  8. #8
    Join Date
    Apr 2005
    Beans
    8
    Distro
    Ubuntu 8.04 Hardy Heron

    Angry Re: SSH Login

    Quote Originally Posted by lswb View Post
    I think you hit the nail on the head with NetworkManager. This is a real problem IMHO. I'm not certain of the exact commands you'll need, but something like this added to /etc/rc.local might get it going, substitute your wireless interface for wlan0:

    ifconfig wlan0 up
    iwconfig wlan0 mode managed essid your-esssid-name
    dhclient wlan0

    This assumes you have a wireless router operating in managed mode with a dhcp server running, more or less the usual case.

    This will probably need some tuning and there may be adverse consequences when NetworkManager starts up later! Good luck!
    Great, at least we know now, what this is all about!

    NM is a great app, but this is really sucky

    I think it'll be better if I completely drop NM and do a manual configuration. I haven't done it before for wireless, but I guess it won't be *that* hard, will it?

    /me has faith in linux!

  9. #9
    Join Date
    Jan 2008
    Location
    Santa Cruz, CA
    Beans
    147
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SSH Login

    No it's not too hard at all if you only want to connect to one network.. I've done it a couple times. If you wanted some sort of roaming.. it'd be less fun

  10. #10
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: SSH Login

    Quote Originally Posted by panosl View Post
    Great, at least we know now, what this is all about!

    NM is a great app, but this is really sucky

    I think it'll be better if I completely drop NM and do a manual configuration. I haven't done it before for wireless, but I guess it won't be *that* hard, will it?

    /me has faith in linux!
    NetworkManager is indeed the culprit here.

    disable NM according to these directions: https://help.ubuntu.com/community/Ne...b71c810878b0eb

    reboot

    then configure your wireless network by going to:
    system > administration > networking

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •