I found a solution. It is crude but it works, which makes me extremely happy

http://ubuntuforums.org/showthread.php?t=840686

Removing network-manager and then by hand setting eth0 interface did the trick for me. Though I don't have any network-manager any more, which was so handy I must admit