Results 1 to 4 of 4

Thread: XP and Ubuntu dual boot on PATA/SATA

  1. #1
    Join Date
    Jun 2008
    Beans
    1

    Question XP and Ubuntu dual boot on PATA/SATA

    Hi,

    I have installed Ubuntu 8.04 on my PATA disk and XP on my SATA disk. Only after doing this, I got to know that i can't have my PATA disk as the first boot device. I am now stuck as I can't boot Ubuntu.

    Is there anyway I can modify boot.sys (or the boot.ini file or some Windows file) such that windows bootloader shows the two OSes.

    I do not want to install GRUB on my SATA(Windows) disk.

    Regards,
    Vijay.

  2. #2
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: XP and Ubuntu dual boot on PATA/SATA

    Get Supergrub (see my signature) and follow this howto:

    http://www.supergrubdisk.org/wiki/Ho...b_from_windows

    Use the classical solution, also when it says:

    sudo su
    grub

    use "sudo grub" instead.


    If you need additional help, boot from the Ubuntu Live CD, open a terminal
    (Applications->Accessories->Termianl) and post the output of

    Code:
    sudo fdisk -l
    ( l is a lower case L)

    But I would recommend to install Grub (the Ubuntu boot loader) to the MBR of the SATA drive, and then add Windows to the Grub Menu.

    That is easier than adding Ubuntu to boot.ini and also is more reliable.
    Last edited by meierfra.; June 17th, 2008 at 04:54 PM. Reason: change "su" to "sudo su"

  3. #3
    Join Date
    Jan 2006
    Location
    Iberian Peninsula
    Beans
    352

    Question Re: XP and Ubuntu dual boot on PATA/SATA

    Quote Originally Posted by meierfra. View Post
    Use the classical solution, also when it says:

    su
    grub

    use "sudo grub" instead.
    In the wiki it is written sudo su instead of su.

    Any problem about it? How can we improve it?

    adrian15

  4. #4
    Join Date
    Apr 2008
    Beans
    3,317
    Distro
    Kubuntu 9.10 Karmic Koala

    Re: XP and Ubuntu dual boot on PATA/SATA

    In the wiki it is written sudo su instead of su.
    Oops, I edited my post.


    Any problem about it?
    "sudo su" only works when the root password is enable. But in Ubuntu the root password is disabled by default. Also Ubuntu strongly discourages from enabling the root password.


    How can we improve it?
    One could write:

    Code:
    su
    grub
    (in Ubuntu use "sudo grub" instead)
    That only works well if only one command requires "sudo".

    So maybe in general this is better:

    Code:
    su  (use "sudo -i" in Ubuntu)
    grub
    Last edited by meierfra.; June 17th, 2008 at 05:44 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •