Results 1 to 3 of 3

Thread: [SOLVED] Keyboard layout

  1. #1
    Join Date
    Oct 2007
    Beans
    151

    [SOLVED] Keyboard layout

    When I boot, the keyboard layout is wrong. I am in the UK with a UK keyboard. The characters are all OK but other keys are wrong. For example "/" comes out as "-"

    If I open Keyboard Preferences/layout the UK keyboard is the only one there, but if I click "Reset defaults", "Spain" appears and UK disappears. I then manually add UK, remove Spain, and close. The UK keyboard now works. But when I shut down and reboot the setup has not saved. I am back to where I started.

    EDIT

    Now resolved after Googling. I had earlier had to import a different xorg.conf to get the video driver working properly. The xorg.conf I imported had Option "XkbLayout" "es".


    I fixed this by editing /etc/X11/xorg.conf and changing

    Option "XkbLayout" "es"

    to

    Option "XkbLayout" "uk"
    Last edited by RobHK; June 14th, 2008 at 05:05 PM. Reason: Solution found

  2. #2
    Join Date
    Mar 2008
    Location
    /home/Nairobi
    Beans
    19
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Keyboard layout

    I had a very similar problem here - http://ubuntuforums.org/showthread.php?t=810372 - and while I received no reply, I did figure it out and the problem was indeed the original xorg.conf file which was created when that OS was installed. As I have multiple installations, I was able to track down the problem by finding one of the OS's that worked the way I wanted it and then compare files. In order to get my keyboard to stick where I wanted it, I had to change the following lines:

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"

    to:

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbVariant" "intl"
    Option "XkbOptions" "lv3:ralt_switch"

    It's been perfect ever since. I don't know the specific code for the keyboard setup you want, but I'm pretty sure that your problem lies here.

    Hope this helps.

  3. #3
    Join Date
    Oct 2007
    Beans
    151

    Re: Keyboard layout

    Quote Originally Posted by anthropoidster View Post
    I had a very similar problem here - http://ubuntuforums.org/showthread.php?t=810372 - and while I received no reply, I did figure it out and the problem was indeed the original xorg.conf file which was created when that OS was installed. As I have multiple installations, I was able to track down the problem by finding one of the OS's that worked the way I wanted it and then compare files. In order to get my keyboard to stick where I wanted it, I had to change the following lines:

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"

    to:

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    Option "XkbVariant" "intl"
    Option "XkbOptions" "lv3:ralt_switch"

    It's been perfect ever since. I don't know the specific code for the keyboard setup you want, but I'm pretty sure that your problem lies here.

    Hope this helps.
    Thanks very much. As you'll see from the edit in my post I found the same solution as you.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •