Results 1 to 8 of 8

Thread: Can't Set Correct Resolution In Virtual Windows

  1. #1
    Join Date
    Jun 2007
    Beans
    217
    Distro
    Ubuntu 9.10 Karmic Koala

    Can't Set Correct Resolution In Virtual Windows

    I'm running Windows XP in VirtualBox, on Kubuntu 8.

    My screen resolution is 1440x900 and is working correctly in Linux.

    Virtual Windows, though, only gives me 2 resolution choices: 800x600 and 1024x768. So the virtual machine runs in a small window.

    How do I force Windows to use 1440x900 whether it wants to or not?

  2. #2
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't Set Correct Resolution In Virtual Windows

    Do you have guest additions installed? You need it before you can get high screen resolutions in Windows guests. There should be an option to install guest additions under one of the file menus of the window showing your virtual machine.

  3. #3
    Join Date
    Jun 2007
    Beans
    217
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't Set Correct Resolution In Virtual Windows

    Quote Originally Posted by pytheas22 View Post
    Do you have guest additions installed? You need it before you can get high screen resolutions in Windows guests. There should be an option to install guest additions under one of the file menus of the window showing your virtual machine.
    Guest Additions are working- the icon shows up in the windows system tray, and mouse integration is functioning correctly...

  4. #4
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't Set Correct Resolution In Virtual Windows

    In that case I would look at the settings of the Windows virtual machine. Make sure Windows is using the right driver for your virtual video card. It might be defaulting to the generic driver for some reason. Go into Device Manager and see if you can update the driver. Also what's the name of the virtual graphics device according the Device Manager?

  5. #5
    Join Date
    Jun 2007
    Beans
    217
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't Set Correct Resolution In Virtual Windows

    Quote Originally Posted by pytheas22 View Post
    In that case I would look at the settings of the Windows virtual machine. Make sure Windows is using the right driver for your virtual video card. It might be defaulting to the generic driver for some reason. Go into Device Manager and see if you can update the driver. Also what's the name of the virtual graphics device according the Device Manager?
    in Device Manager-> Display Adapters: "VirtualBox Graphics Adapter"

    Under monitors, it says "Default Monitor". If i try to update the monitor driver, it goes back to "default monitor"

  6. #6
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't Set Correct Resolution In Virtual Windows

    Try putting the virtual Window in fullscreen mode (right control-f) and then tell it to automatically resize (right control-g). Does it help?

  7. #7
    Join Date
    Jun 2007
    Beans
    217
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Can't Set Correct Resolution In Virtual Windows

    Quote Originally Posted by pytheas22 View Post
    Try putting the virtual Window in fullscreen mode (right control-f) and then tell it to automatically resize (right control-g). Does it help?
    Yes, as soon as i hit ctrl-G, the windows resolution choices changed to include 1440x900. strange....

  8. #8
    Join Date
    Aug 2007
    Location
    Paris
    Beans
    5,538
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Can't Set Correct Resolution In Virtual Windows

    Yeah, I remembered that I needed to do that once to get it to go into full screen mode properly. At least it works now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •