Results 1 to 4 of 4

Thread: strange samba mount behaviour

  1. #1
    Join Date
    Oct 2007
    Beans
    98

    strange samba mount behaviour

    Hi,

    I have a win2k server on my network hosting samba shares. I can only access them through IP, yet I can ping the hostname, any idea what might be happening here?

  2. #2
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: strange samba mount behaviour

    please post the contents of /etc/nsswitch.conf and /etc/resolv.conf

  3. #3
    Join Date
    Oct 2007
    Beans
    98

    Re: strange samba mount behaviour

    /etc/resolv.conf ...

    search ncci.campus
    nameserver 192.168.1.1
    nameserver 192.168.100.100


    /etc/nsswitch.conf

    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.

    passwd: compat
    group: compat
    shadow: compat

    hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4
    networks: files

    protocols: db files
    services: db files
    ethers: db files
    rpc: db files

    netgroup: nis

  4. #4
    Join Date
    Mar 2006
    Location
    Kitakyushu Japan
    Beans
    9,361
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: strange samba mount behaviour

    in order to mount by host name with cifs, you'll have to enable netbios name resolution.

    change the "hosts" line in your /etc/nsswitch.conf file so it looks like this:
    Code:
    hosts: files mdns4_minimal [NOTFOUND=return] wins dns mdns4
    then install winbind:
    Code:
    sudo aptitude install winbind
    then you should be able to mount by host name.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •