Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41

Thread: How-To: UFW

  1. #11
    Join Date
    May 2007
    Location
    California, USA
    Beans
    246

    Re: How-To: UFW

    If you are trying to print to a Windows printer shared over samba, you have to make the following changes:

    1) Edit /etc/default/ufw and change the last line from:

    Code:
    IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc"
    To:

    Code:
    IPT_MODULES="nf_conntrack_ftp nf_nat_ftp nf_conntrack_irc nf_nat_irc nf_conntrack_netbios_ns"
    2) Create the following rules:

    Code:
    sudo ufw allow proto udp from 192.168.0.0/16 to any port 137
    sudo ufw allow proto udp from 192.168.0.0/16 to any port 631

  2. #12
    Join Date
    Mar 2007
    Location
    Vault 101
    Beans
    127

    Re: How-To: UFW

    just want to say thanks for this, gufw has failed me and I had to go back to the always reliable cli




  3. #13
    Join Date
    Sep 2006
    Beans
    41
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: How-To: UFW

    I know the last post in this thread, before me, was in 2007 but I just want to point something out encase anyone ever finds this on google like I did while searching for ufw.

    If you want ufw to load on start up do the following:

    System > Preferences > Sessions > Startup Programs > Click Add.

    Then just type in ufw for the name and the command. (or gufw if you use that)

    Then click "Okay" and then click "Close"

    There, your finished, its on the startup.

  4. #14
    Join Date
    Mar 2009
    Location
    London
    Beans
    24
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: How-To: UFW

    so if ufw (or any other firewall configuration tool) is not loaded you have no firewall?

  5. #15
    Join Date
    Apr 2006
    Location
    UK
    Beans
    6,646
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How-To: UFW

    Quote Originally Posted by hostilejosh View Post
    so if ufw (or any other firewall configuration tool) is not loaded you have no firewall?
    No.

    iptables is enabled as default. ufw is an optional simplified front-end for iptables.

    If you use:`
    Code:
    sudo ufw enable
    A reboot will leave ufw enabled.

  6. #16
    Join Date
    Apr 2009
    Beans
    28

    Re: How-To: UFW

    Hi, i'm confused about configuring ufw i'm using kubuntu jaunty, i got ssh deny rule on ufw, if i connect on ssh at localhost will the firewall drop my connection or will it still push thru?
    Never attribute to malice that which can adequately be explained by stupidity...

  7. #17
    Join Date
    Oct 2008
    Beans
    24

    Re: How-To: UFW

    I need some help.
    I'm trying to open ports for deluge for upload(it say "no incomming connection")
    How can i do that?can you explain me step by step?
    Thanks!

  8. #18
    Join Date
    Mar 2006
    Location
    Cleveland, Ohio
    Beans
    70

    Re: How-To: UFW

    iptables is enabled as default. ufw is an optional simplified front-end for iptables.
    I just installed Ubuntu 8.04.3 LTS desktop version and ran:

    Code:
    sudo iptables -L
    which lists all rules in all chains in the default filter table ( source ). This was returned:

    Code:
    Chain INPUT (policy ACCEPT)
    target  prot opt source  destination
    
    Chain FORWARD (policy ACCEPT)
    target  prot opt source  destination
    
    Chain OUTPUT (policy ACCEPT)
    target  prot opt source  destination
    It appears that iptables is enabled by default, however, it appears the default firewall rules are allowing all inbound, forwarding, and outbound traffic.

    If that is the case, the operating system is wide open to vulnerabilities, especially when first plugging into a public network and proceeding to patch the operating system via
    Code:
    apt-get update
    and then
    Code:
    apt-get upgrade
    .

    But please educate me if I am incorrect.

    Thanks,
    *Nick*

    "Be the change you wish to see in the world"
    --Gandhi

  9. #19
    Join Date
    Mar 2007
    Location
    Wenatchee, WA
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: How-To: UFW

    Whether the system is 'wide open' probably depends on what all you have running (and listening to ports).

    I believe the default firewall policy tends towards 'mostly allow'. To change it to 'mostly deny', you probably would want to run something like:

    Code:
    sudo ufw default deny
    (with the caveat that I'm not sitting in front of my Ubuntu box right now, so you would be well advised to double check the above via the man page)

  10. #20
    Join Date
    Mar 2006
    Location
    Oxford, OH, USA
    Beans
    1,002
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How-To: UFW

    Do I need to configure a specific port on ufw to enable last.fm using rhthymbox?
    ________________________________
    DELL e6420 Laptop
    Ubuntu Pagolin Precise 12.04 LTS
    Linux Registered User #434330

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •