Results 1 to 5 of 5

Thread: Need help with preferred Apps

  1. #1
    Join Date
    Mar 2008
    Beans
    152

    Need help with preferred Apps

    I just installed MPlayer Movie Player and it works well. So I want to make
    it the default DVD player. I opened Preferred Applications and it shows two
    players under the Multimedia tab: Rhythmbox Music Player and Totem Movie
    Player.
    There's one more choice called CUSTOM and has a place to type a command
    but I have no idea how it would be used. Any help is appreciated. Thanks
    <>< among flowers, the cherry blossom; among penguins, the Samurai ><>

  2. #2
    Join Date
    May 2008
    Location
    San Antonio, Texas
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Need help with preferred Apps

    Ok, I think this will work but Im not on a machine running Linux right now so I cant test it myself.

    open terminal

    Code:
    gksudo gedit /etc/gnome/defaults.list
    ctrl-f and search option x-content/video

    you should see some enteries that say totem.desktop or vlc.desktop. It will be whatever the currect default player is. Change all of them to MPlayer Movie Player.desktop
    True freedom requires sacrifice and pain. Most human beings only think they want freedom. In truth they yearn for the bondage of social order, rigid laws, materialism, the only freedom man really wants, is the freedom to become comfortable.

  3. #3
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Need help with preferred Apps

    The executable should be in /usr/bin. Verify that with <which mplayer> command. You may need to run <sudo updatedb> first.

  4. #4
    Join Date
    Mar 2008
    Beans
    152

    Re: Need help with preferred Apps

    tried all the above, didn't work. Totem still opened when
    I load a DVD movie
    Last edited by Samurai Penguin; June 8th, 2008 at 07:42 PM.
    <>< among flowers, the cherry blossom; among penguins, the Samurai ><>

  5. #5
    Join Date
    Nov 2005
    Location
    New York, USA
    Beans
    1,219
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Need help with preferred Apps

    Open your home folder Places > Home Folder

    On the top click on Edit > Preferences and go to the Media tab. Select what you want from there. You could try "Do Nothing" and then just start vlc or mplayer and have them play the disc.

    In hardy, I had to change the path for the optical drives for both vlc and mplayer to find the DVD because optical drives are not really handled by /etc/fstab anymore.

    In mplayer, right click the player to get the context menus and go to Preferences > Mis.

    Near the bottom is the path to the DVD drive. Mine used to say "/dev/hda". I had to change it to "/dev/scd0" (without the quotes).

    Now, after running mplayer, just right click and select DVD > Open Disc and it should play.


    For vlc, Click the Open button to the left of the Play button and select the Disc tab. In the Device name entry, change it to /dev/scd0 or whatever you need.

    I have found that the settings change is persistent in mplayer, but not in vlc. You have to change it every time.

    I realize this isn't an ideal solution. I liked the way it worked in Gutsy and earlier better, where you could put in the command line for any player and it would run that one when you put in the disc.

    Read this for more info:

    http://ubuntuforums.org/showthread.p...red+apps+hardy
    Last edited by mgmiller; June 9th, 2008 at 02:11 AM.
    Using Ubuntu since Warty Warthog (4.10)
    32 bit Ubuntu upgraded from 5.04>5.10>6.06>6.10>7.04>7.10>8.04>8.10>9.04>9.10
    Started over 64 bit 9.10 upgraded to 10.04>10.10>11.04>11.10>12.04

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •