Results 1 to 7 of 7

Thread: Can't download packages anymore

  1. #1
    Join Date
    Jul 2007
    Beans
    44

    Angry Can't download packages anymore

    When I try to download something via Add/Remove or the Synaptic Package Manager it says this:

    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    E: _cache->open() failed, please report.

    And when I try to run
    Code:
    dpkg --configure -a
    it says: dpkg: requested operation requires superuser privilege

    When I type sudo and the code it says: sudo: dpkg:: command not found

    I hope somebody can help, thanks

  2. #2
    Join Date
    Jan 2008
    Location
    /dev/null
    Beans
    2,793
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't download packages anymore

    Quote Originally Posted by HaemoLacria View Post
    When I try to download something via Add/Remove or the Synaptic Package Manager it says this:

    E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
    E: _cache->open() failed, please report.

    And when I try to run
    Code:
    dpkg --configure -a
    it says: dpkg: requested operation requires superuser privilege

    When I type sudo and the code it says: sudo: dpkg:: command not found

    I hope somebody can help, thanks
    edit misread the complete post

    please run the following command and post its results

    id <insert_your_username_here>

  3. #3
    Join Date
    Jun 2007
    Location
    USA
    Beans
    69
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Can't download packages anymore

    I don't mean to offend, but just to make sure, you did type it out as:

    sudo dpkg --configure -a

    correct? Like I said, no offense, but it's always best to check the simple things that are easy to overlook at first
    Why are uploads slower than downloads? That's easy. When you upload, the computer has to push the bits upward. When you download, the bits just fall by gravity, so it's much faster.

    ~/ ~/ on the range...

  4. #4
    Join Date
    Jan 2008
    Location
    /dev/null
    Beans
    2,793
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't download packages anymore

    Quote Originally Posted by darth_indy View Post
    I don't mean to offend, but just to make sure, you did type it out as:

    sudo dpkg --configure -a

    correct? Like I said, no offense, but it's always best to check the simple things that are easy to overlook at first
    based on his error messages (assuming he pasted them instead of manually typing them into his post) It looks like either he has managed to uninstall dpkg or doesn't have the proper permissions set. There are also some other explanations (including typoed commands) so we'll have to work through the possibilities and rule them out before we can fix the root of the problem with the package manager

  5. #5
    Join Date
    Jan 2008
    Location
    /dev/null
    Beans
    2,793
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Can't download packages anymore

    to the OP,
    please see if dpkg is installed,and its version

    apt-cache policy dpkg

  6. #6
    Join Date
    Jul 2007
    Beans
    44

    Re: Can't download packages anymore

    It says: Setting up libc6 (2.6.1-1ubuntu9) ...

    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place

    when I type it manually. Nothing seems to happen actually

  7. #7
    Join Date
    Jan 2008
    Location
    United Kingdom
    Beans
    195
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Can't download packages anymore

    *invalid post*

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •