Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 47

Thread: HOWTO: Grub Menu Kernel Display Options

  1. #31
    Join Date
    Feb 2011
    Beans
    12

    Re: HOWTO: Grub Menu Kernel Display Options

    I'm trying to hide bootloader menu, so I've found this tutorial that speaks about "Start-Up" manager which should have exactly what I'm looking for, the Show bootloader menu option. But in my case, I don't have that option, theres only Show boot splash and Show text during boot

    I'm running U10.10, freshly installed. How to fix this?

  2. #32
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Menu Kernel Display Options

    Startup Manager isn't as good at working with Grub 2. You could try to hide the menu by editing the /etc/default/grub file. The instructions are in the following link. At the bottom of Section 1 there is a paragraph about hiding the menu.

    Grub 2 - 5 Common Tasks

    If that doesn't work, it's possible the 'recordfail' check isn't working. If the above doesn't work, let me know if the menu is still displaying but has a counter and eventually boots, or if there is no countdown and you always have to press ENTER to get the computer to boot.

    I'm about to leave on a few weeks vacation and won't be on the forums as often as normal. I'll be checking in from time to time and will see your post - it might just take a day or two.
    GRUB2

    Retired.

  3. #33
    Join Date
    Feb 2011
    Beans
    12

    Re: HOWTO: Grub Menu Kernel Display Options

    drs305, thanks for repy!
    I've tryed to configure Grub 2 as described on that link you gave me, but it didn't work:
    I've remowed # before the GRUB_HIDDEN_TIMEOUT and set the same time for both TIMEOUT sections (3 sec). Then I've saved the change and updated the menu via "sudo update-grub" but after a restart, the only change was that menu was lasting 3 seconds, but visible...

    Someone mentioned before that if I have dual boot (in my case win7 and ubuntu10.10) then I can't hide the bootloader menu just with GRUB_HIDDEN_TIMEOUT, but that I would have to use somekind of a script (but which one and how to use it wasn't mentioned)
    Last edited by gesaugen; April 24th, 2011 at 06:17 PM.

  4. #34
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Menu Kernel Display Options

    Quote Originally Posted by gesaugen View Post
    I've remowed # before the GRUB_HIDDEN_TIMEOUT and set the same time for both TIMEOUT sections (3 sec).
    That should set a blank screen for 3 seconds, then the menu should display for 3 seconds and automatically boot.

    So if you want Grub to just boot without seeing the menu, change GRUB_TIMEOUT=0 and it should boot immediately after 3 seconds of blank screen.
    GRUB2

    Retired.

  5. #35
    Join Date
    Feb 2011
    Beans
    12

    Re: HOWTO: Grub Menu Kernel Display Options

    Quote Originally Posted by drs305 View Post
    That should set a blank screen for 3 seconds, then the menu should display for 3 seconds and automatically boot.

    So if you want Grub to just boot without seeing the menu, change GRUB_TIMEOUT=0 and it should boot immediately after 3 seconds of blank screen.
    I've set GRUB_TIMEOUT=0 and GRUB_HIDDEN_TIMEOUT=10 - it didn't work! The menu was visible
    NOTICE: I have multiOS dual boot (win7 & ubuntu 10.10) - as I've read in your tutorials, hidden menu with multiOS system requires a bit more of adjustment...

    So I've tried to add commands from yours tutorial:

    Quote Originally Posted by drs305 View Post
    11. HIDING THE MENU ON MULTI-OS SYSTEMS
    By design, Grub 2 allows hiding the menu only on single-OS systems. This is established in the /etc/grub.d/30_os-prober file. For users with multiple OS's on their machines, hiding the menu can be accomplished by altering the scripts. There are two ways to accomplish the task. The first edits only one file and eliminates a conditional; the second edits two files and adds a conditional, but is a bit more 'elegant'.

    Shown are the applicable sections. Changes are highlighted in bold red. The lines between the altered lines have been omitted.Method 1. Remove a conditional from /etc/grub.d/30_os-prober.
    For both Grub 1.97~beta (Karmic) and 1.98 (Lucid & later), the first line to edit is the same. It appears at approximately line 25-30 of /etc/grub.d/30_os-prober in both versions.
    # if [ "x${found_other_os}" = "x" ] ; then
    The second change is to place a # symbol at the end of the conditional. There are many if statements, and it's important to find the correct nested fi.

    Lucid & later (Grub 1.98+):
    Quote:
    #
    fi
    }

    adjust_timeout () {
    result is that now menu IS hidden BUT I can't call it via SHIFT or ESC key

    UPDATE EDIT:
    1. I've reinstalled ubuntu because I haven't make backup files of grub.cfg and 30_os-prober files
    2. I wiser now so I've made backup files
    3. Now I've decided to use method #2 from your tutorial:
    Quote Originally Posted by drs305 View Post
    Method 2. Add a conditional.
    This procedure modifies both /etc/grub.d/30_os-prober and /etc/default/grub. Open both with:
    gksu gedit /etc/default/grub /etc/grub.d/30_os-prober
    Add this line to /etc/default/grub:
    GRUB_FORCE_HIDDEN_MENU="true"
    export GRUB_FORCE_HIDDEN_MENU
    Change this line in /etc/grub.d/30_os-prober, approximately line 25-30,
    From this:
    if [ "x${GRUB_DISABLE_OS_PROBER}" = "xtrue" ]; then
    To this:
    if [ "x${found_other_os}" = "x" ] || [ "x${GRUB_FORCE_HIDDEN_MENU}" = "xtrue" ] ; then
    Also I've set the default OS for loading to be Ubuntu - and it worked: the bootloader menu wasn't showing up and I could call it by holding down left SHIFT key after BIOS load up. Also hidden loading took about 10 sec, so I can conclude that that works...
    BUT!
    When I've changed in the grub that the default OS to load will be Win7, then the set up broke down! - holding shift resulted with command showing "GRUB loading" but then windows started to load normaly like theres no bootmenu at all!
    So as I can figure it out, the problem is in windows OS loader which doesn't respond for hidden timeout function.
    help?
    Last edited by gesaugen; April 25th, 2011 at 12:25 PM.

  6. #36
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Menu Kernel Display Options

    I'll take a look at it at the hotel this evening. The Grub 1.98 scripts have been modified quite a bit and perhaps it's affected my workaround.

    If I understand your post, you now have Windows as the default but you can't interrupt the boot and display the menu using SHIFT? If you haven't been able to get back into Ubuntu, try pressing the ESC key repeatedly during boot.
    GRUB2

    Retired.

  7. #37
    Join Date
    Feb 2011
    Beans
    12

    Re: HOWTO: Grub Menu Kernel Display Options

    Quote Originally Posted by drs305 View Post
    If I understand your post, you now have Windows as the default but you can't interrupt the boot and display the menu using SHIFT? If you haven't been able to get back into Ubuntu, try pressing the ESC key repeatedly during boot.
    yes, that's exactly what is the problem!
    ann I've tryed to press ESC key but that reboots the PC in both cases (when default os is ubuntu and also with windows)

  8. #38
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Menu Kernel Display Options

    Assuming you still cannot boot Ubuntu normally, try accessing Ubuntu in one of these ways.

    First, a second or two after your BIOS screen blanks (if you have one), CTRL-ALT-DEL twice to recycle the boot (or cycle the power off, although that's not generally a nice way to treat the computer). This may disrupt Grub, in which case it may start with a 'recordfail' marker the next time and display the menu. Boot into Ubuntu.

    If you don't want to disrupt power during boot (understandable) boot the LiveCD and mount your Ubuntu partition. For this post, I'll assume it's sda5.

    We will put the 'keystatus' check in /etc/grub.d/40_custom so it is always incorporated into the menu regardless of what OSs Grub finds.

    Code:
    sudo mount /dev/sda5 /mnt
    gksu gedit /mnt/etc/default/grub /mnt/boot/grub/grub.cfg /mnt/etc/grub.d/40_custom
    In /etc/default/grub:
    GRUB_HIDDEN_TIMEOUT=5 # Just to give you a chance to stop the boot
    GRUB_HIDDEN_TIMEOUT_QUIET=false # This is supposed to provide a countdown timer, but it's currently broken in G2. But try it anyway in case it's fixed.
    In /mnt/boot/grub/grub.cfg, add this to the bottom so it's there for the next boot:
    if keystatus; then
    if keystatus --shift; then
    set timeout=-1
    else
    set timeout=0
    fi
    else
    if sleep$verbose --interruptible 3 ; then
    set timeout=0
    fi
    fi
    Copy the same thing to /mnt/etc/grub.d/40_custom. Add it below the existing lines to ensure the keystatus check is performed.

    Save all the files, reboot (without the CD). If things work, "sudo update-grub". The 40_custom file should be executable by default, and after you run the update the keystatus check code should still be near the bottom of the grub.cfg file. (After updating, it will be in the 40_custom section of grub.cfg. If it isn't, check to make sure /etc/grub.d/40_custom is an executable file).
    GRUB2

    Retired.

  9. #39
    Join Date
    Apr 2011
    Location
    Canton, MI
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Grub Menu Kernel Display Options

    I wanted to say many thanks to you for this wonderful tutorial. I applied the knowledge applied therein, and my machine works a lot better now.

    Thank you again.

  10. #40
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Grub Menu Kernel Display Options

    charliemagiera,

    Welcome to the Ubuntu Forums.

    Glad you enjoyed this thread. There is a lot of useful information throughout these forums.

    Just for the record, the tips in this thread may keep the menu more manageable but shouldn't noticeably affect the actual performance of the system. But mind over matter can be just as important.

    Happy Ubuntu-ing !
    GRUB2

    Retired.

Page 4 of 5 FirstFirst ... 2345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •