I think your gnome-terminal shortcut isn't launching the terminal with the tterm profile for some reason. Make sure it's started with that profile by checking the syntax of the "--window-with-profile" option. Also try using a higher value with the "sleep" command in the launcher script.