Results 1 to 5 of 5

Thread: Kile problem: Toolbars and menus gone after upgrade to hardy

  1. #1
    Join Date
    Mar 2006
    Beans
    8
    Distro
    Kubuntu 7.04 Feisty Fawn

    Kile problem: Toolbars and menus gone after upgrade to hardy

    Hi!

    I'm having a strange problem with kile (installed from source, version 2.0.1) after upgrading to hardy from feisty. Most of the toolbars in kile are missing, I can only see the left edge of the build, tools, edit, error and math toolbars (while the main toolbar is still there). The keyboard shortcuts work for the missing toolbars (at least the few of them that I still remember). In addition to this there is no "Help" menu. I have reconfigured and recompiled the source package and done a make install again after the upgrade, but theese problems are still there. I have also tried to install the version of kile in the hardy repositories, with exactly the same result.

    Another problem I had was with kbib (also from source and recompiled after upgrade, version 0.6.4). On startup kbib complained about two missing files, entryDefs.xml and kbibuirc. Both were installed to /usr/local/kde/share/apps/kbib/. I found that KDEDIRS was blank, and kde-config --path data did not include this directory. After adding the path /usr/local/kde to KDEDIRS in my .bashrc, I tried logging out and in again, but the problem was still there. Copying (or symlinking) the files to the corresponding directory under $HOME/.kde resolved the problem. Could this be related to my Kile problem (i.e., could the kile problems be caused by kile not finding some installed datafiles)?

    Any help would be much appreciated -- I think I might have to downgrade Kubuntu to feisty again if I can't solve this.

    Jostein.

  2. #2
    Join Date
    Mar 2006
    Beans
    8
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Kile problem: Toolbars and menus gone after upgrade to hardy

    SOLVED:

    The cause was that /usr/local/kde was missing from $KDEDIRS. Setting $KDEDIRS in .bashrc doesn't work -- see http://lists.debian.org/debian-kde/2.../msg00002.html for details. The correct method of setting the enviroment variable is described there.

    Jostein.

  3. #3
    Join Date
    Nov 2011
    Beans
    1

    Re: Kile problem: Toolbars and menus gone after upgrade to hardy

    I stumbled across this problem lately and this thread was the only hint to a solution that I could find. A very simple fix is to restore Kile to its default settings by removing your own settings (this does not affect your user defined shortcuts). Close Kile, open a terminal and type
    Code:
    rm $HOME/.kde/share/config/kilerc
    Restart Kile. Done.

  4. #4
    Join Date
    Jul 2010
    Location
    Germany
    Beans
    130
    Distro
    Ubuntu Development Release

    Re: Kile problem: Toolbars and menus gone after upgrade to hardy

    Thanks buddy, this one helped me out

  5. #5
    Join Date
    Feb 2007
    Beans
    22,984
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Kile problem: Toolbars and menus gone after upgrade to hardy


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •