View Poll Results: Did this how-to work for you?

Voters
204. You may not vote on this poll
  • Yes

    184 90.20%
  • No

    20 9.80%
Page 1 of 24 12311 ... LastLast
Results 1 to 10 of 231

Thread: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

  1. #1
    Join Date
    Apr 2006
    Location
    Alberta,Canada
    Beans
    1,135
    Distro
    Ubuntu Development Release

    How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Updated April 18,2009 10:43:08 A.M. MST

    * Please read this how-to in it's entirety before proceeding


    Oh man this made me sooo happy when I found this!I just have to share

    I can't take any credit for this how to but I have tried it out and it works great...no more ndiswrapper for this puppy
    You can see all the details regarding the lack of support for Atheros on 64bit linux here http://madwifi.org/ticket/1679 and here http://madwifi.org/ticket/1192

    You will need an internet connection so get wired up if need be.

    Lets give it a go.

    1: First off be sure the build-essential package is installed
    Code:
    sudo apt-get install build-essential
    2: You will need the linux-restricted-modules package installed to be able to compile the driver
    Code:
    sudo apt-get install linux-restricted-modules-$(uname -r)
    3: Also install subversion
    Code:
    sudo apt-get install subversion
    NOTE:If you have been using ndiswrapper like I was you need to disable/remove it

    I recommend doing what I did and run the first command in section 4 before removing ndiswrapper that way you can avoid hooking up to a wired network if your wireless is functional using ndiswrapper
    Code:
    sudo ndiswrapper -e net5211
    sudo modprobe -r ndiswrapper
    sudo apt-get remove --purge ndiswrapper-common ndiswrapper-utils ndisgtk
    Also run
    Code:
    gksudo gedit /etc/modprobe.d/blacklist
    Remove any references to ath_pci and ath_hal

    * Before the next steps go to System ->Administration ->Hardware Drivers and make sure both Atheros drivers are disabled and reboot the system if they were not.

    4: Get the files and install the driver
    Code:
    svn co http://svn.madwifi-project.org/madwifi/branches/madwifi-hal-0.10.5.6
    cd ~/madwifi-hal-0.10.5.6
    make
    sudo make install
    sudo depmod -ae
    sudo modprobe ath_pci
    echo ath_hal | sudo tee -a /etc/modules
    echo ath_pci | sudo tee -a /etc/modules
    5: Finally go to System ->Administration ->Hardware Drivers and reenable the Atheros drivers and reboot the system.

    One thing I should add is you will need to repeat this procedure whenever you get a kernel update.I have just kept the downloaded packages on my system and after booting into a new kernel I do:

    Code:
    cd ~/madwifi-hal-0.10.5.6
    make clean
    sudo make install
    Reboot and I am up and running again.
    Hopefully this makes your day like it did mine!

    Note:
    If everything installs and loads properly but you cannot connect to any networks you probably need to configure your network properly.Try browsing through here http://madwifi.org/wiki/UserDocs/FirstTimeHowTo for assistance.

    Addendum:

    Wifi light not working?Try ZeroXtreme's fix.

    In a terminal type:

    Code:
    1. sudo sysctl -w dev.wifi0.ledpin=3
    2. sudo sysctl -w dev.wifi0.softled=1
    If this works, add the following to your /etc/sysctl.conf file to make the changes persistent:

    Code:
    sudo geditit /etc/sysctl.conf and add
    Code:
    # Enable WiFi LED
    dev.wifi0.ledpin=3
    dev.wifi0.softled=1
    I won't guarantee this will work for everyone but it works on ZeroExtreme's and my Acer Aspire.
    Last edited by Anduu; April 18th, 2009 at 05:53 PM.
    What color do Smurfs turn when you choke em?
    ____________________________

  2. #2
    Join Date
    Jan 2007
    Location
    /India/Auroville/home
    Beans
    367
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Is that a solution for 32 bit as well? So far nothing worked for me fixing this issue.
    Don't forget to thank; more points when you want to go to heaven or less karma if you decide for reincarnation. Mark threads solved when they are ...

  3. #3
    Join Date
    Apr 2006
    Location
    Alberta,Canada
    Beans
    1,135
    Distro
    Ubuntu Development Release

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Quote Originally Posted by be4truth View Post
    Is that a solution for 32 bit as well? So far nothing worked for me fixing this issue.
    This is strictly 64bit...try this if you haven't yet http://ubuntuforums.org/showthread.php?p=4999962
    What color do Smurfs turn when you choke em?
    ____________________________

  4. #4
    Join Date
    Apr 2005
    Location
    Arecibo, Puerto Rico
    Beans
    213
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Talking Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    IT WORKS PERFECT!!!

    Oh my God!!! Dude I feel like crying of so much joy. You have no idea how much I needed this so bad. I can't believe how simple it was to get it all working by just copy pasting the codes. I been fighting for the last week with Atheros. I manage to get the drivers install before with ndiswrapper and was able to see my wireless networks but couldn't connect no matter what I try. I installed Wicd and Wi-Fi Radar and still didn't work. But with this new method is beautiful and flawless , I did a clean Ubuntu install again for my laptop and kept the default network manager . Thank you so much for sharing with us. Did you forget to mention in your guide to unchecked the drivers before starting this method? I had both unchecked before starting to do this and it work on the first try. I love you man, I love you.!!! w00t!!

    Last edited by braveerudite; June 26th, 2008 at 03:25 PM.
    Ubuntu 8.04 Hardy Heron (AMD64)
    Compaq Presario F756NR

  5. #5
    Join Date
    Jun 2008
    Beans
    22

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Anduu,

    You cant imagine how grateful I am to you. In fact I registered to the forum just to thank you.

    Ive been trying to make my wifi work for two weeks so far, no even ndiswrapper would work for me. Followed dozens of howtos, got nothing. Indeed, yours was the only one that worked. Added to favorites, saved the page to my hard drive.

    You are my hero!

  6. #6
    Join Date
    Apr 2006
    Location
    Alberta,Canada
    Beans
    1,135
    Distro
    Ubuntu Development Release

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Glad I could help

    Like I said I'm just passing the info along...It's the guys at Madwifi who deserve all the credit

    One thing I should add is you will need to repeat this procedure whenever you get a kernel update.I have just kept the downloaded packages on my system and after booting into a new kernel I do:

    Code:
    cd madwifi
    make clean
    sudo make install BINDIR=/usr/bin MANDIR=/usr/share/man
    Reboot and I am up and running again.
    What color do Smurfs turn when you choke em?
    ____________________________

  7. #7
    Join Date
    Sep 2005
    Location
    Portland, OR USA
    Beans
    537
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Thank you so much for this. I'd been struggling with getting it working for the past week!


  8. #8
    Join Date
    May 2008
    Location
    Curauma-Valparaiso-Chile
    Beans
    31
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Hi Anduu,

    following your instructions, I am getting the following error, which seems to be related with the uname path:

    enrique@acer:~/madwifi$ sudo make install BINDIR=/usr/bin MANDIR=/usr/share/man
    cd: 1: can't cd to /lib/modules/2.6.24-19-rt/build
    Makefile.inc:66: *** /lib/modules/2.6.24-19-rt/build is missing, please set KERNELPATH. Alto.

    May you give me a hint?

    Thanks in advance,

  9. #9
    Join Date
    Apr 2006
    Location
    Alberta,Canada
    Beans
    1,135
    Distro
    Ubuntu Development Release

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Quote Originally Posted by uwe.koch.k View Post
    Hi Anduu,

    following your instructions, I am getting the following error, which seems to be related with the uname path:

    enrique@acer:~/madwifi$ sudo make install BINDIR=/usr/bin MANDIR=/usr/share/man
    cd: 1: can't cd to /lib/modules/2.6.24-19-rt/build
    Makefile.inc:66: *** /lib/modules/2.6.24-19-rt/build is missing, please set KERNELPATH. Alto.

    May you give me a hint?

    Thanks in advance,
    You need to have the linux-restricted-modules package installed,in your case the real time ones.

    Code:
    sudo apt-get install linux-restricted-modules-rt
    I guess I should append that to the how-to
    Last edited by Anduu; June 10th, 2008 at 01:06 AM.
    What color do Smurfs turn when you choke em?
    ____________________________

  10. #10
    Join Date
    Jun 2008
    Beans
    14

    Re: How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!!

    Quote Originally Posted by Anduu View Post
    Glad I could help

    Like I said I'm just passing the info along...It's the guys at Madwifi who deserve all the credit

    One thing I should add is you will need to repeat this procedure whenever you get a kernel update.I have just kept the downloaded packages on my system and after booting into a new kernel I do:

    Code:
    cd madwifi
    make clean
    sudo make install BINDIR=/usr/bin MANDIR=/usr/share/man
    Reboot and I am up and running again.
    Hi, Anduu,

    I recently installed Ubuntu using the Wubi installer under Windows Vista, and I must say I am impressed with the speed on my 64-bit AMD Athlon X2 processor. However, I too am having problems with my Atheros AR5007EG wireless card. I performed all the steps listed in the previous posts, and it connected for a brief time; yet now, I cannot connect using wifi at all, and my wifi connection is listed as "ath0:avahi". I do not understand what that means, except that I cannot connect with that interface. And when I attempt to configure it, I am told the "interface name does not exist." (The same holds true for my Gig-E Ethernet connection, though, which makes me think there's something wrong with the networking module instead.)

    Also, I cannot turn on my wireless card using my "enable wireless" button - it simply does not seem to function. This may be related to the problem.

    Do you have any other insight into why this is happening? My computer is an Acer 4520-5458, AMD Athlon 64 X2 (TK-57), Atheros AR5000EG 802.11b/g wireless, nVidia GeForce 7000M graphics, 120gb HDD, 1gb RAM.

    Thanks in advance for your help.

Page 1 of 24 12311 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •