I finally got around to upgrading to hardy this weekend and after the upgrade I can no longer maintain the refresh rate I want xorg to use. I want a 1600x1200@75 mode. Though I tinker and tinker with my xorg.conf, and I am able to set the correct refresh rate using nvidia-settings (but not the useless gnome utility), I am completely unable to find a way to keep that mode through a restart of the xserver. In other words, I have to reset the fresh rate to 75 each time I log in to gnome by using nvidia-settings.

Any ideas on how to force the refresh rate to 75?

Here is my current xorg.conf:

Code:
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
    RgbPath         "/usr/X11R6/lib/X11/rgb"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "ViewSonicP810-3"
    HorizSync       30.0 - 95.0
    VertRefresh     50.0 - 180.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce FX 5900XT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Videocard0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1600x1200_75 +0+0; nvidia-auto-select +0+0; 1600x1200 +0+0"
    SubSection     "Display"
        Depth       24
		#Modes		"1600x1200@75"	"1280x1024@60"	"1024x768@60"	"800x600@60"	"800x600@56"
    EndSubSection
EndSection