Page 1 of 7 123 ... LastLast
Results 1 to 10 of 67

Thread: Nvidia Restricted drivers PROBLEM!!!!

  1. #1
    Join Date
    May 2008
    Beans
    9

    Nvidia Restricted drivers PROBLEM!!!!

    Well the problem is as it follows:

    I am a virgin with the ubuntu and recently I have installed ubuntu 8.04 and it is really great OS and it got me pined downI wanted to try those amazing effects so i installed nvidia driver via synaptic ,and everything went fine.Ubuntu connected to internet and installed this driver and asked me to reboot and now the problem starts.I couldnt boot into ubuntu,I just see black screen and it says: signal out of range!!!
    So I booted into recovery and I tried to fix x-server and it works.So when I finnaly got into ubuntu I have this message in upper panel that drivers are installed but not supported!!!
    I also tried installing driver via NvyNG applet(which is fully automated) and I tried all the 3 versions of the nvidia drivers(173.14.05/71.86.04/96.43.05)but none of them works and when I install them I have the same problem!!!!
    By the way my configuration is:

    CPUentium 4 s478 2.0GHz Northwood
    GPU:Asus GeForce FX5200 128MB
    MBO:Asus P4S333-M

    I also have windows xp pro sp2 installed along with the ubuntu in dual boot conf.
    So if anyone has the solution please HELP!!!!
    I was searching for help in my country but did not yet find the solution.
    My ubuntu knowledge is very basic so simplify as much as possible!!!
    THANX!!!

  2. #2
    Join Date
    Aug 2007
    Beans
    197

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Why did you use synaptic to install the drivers? Ubuntu has a restricted drivers manager. You should have used that instead. Uninstall the drivers you installed.

    Now go to System > Administration > Hardware Drivers

  3. #3
    Join Date
    May 2008
    Beans
    9

    Re: Nvidia Restricted drivers PROBLEM!!!!

    I am sorry I did not use synaptic I used restricted driver manager!!!I tried everything, I wrote that,I uninstalled drivers and I tried with NvyNG but same thing!!!!

  4. #4
    Join Date
    Oct 2006
    Beans
    4,619
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Try this
    Making this change will have no impact on your installed system and is to be considered safe. If you reboot your system this change will disappear. It is temporary.

    Start your computer normally and after a few seconds you will see the GRUB boot loader menu.

    • With the use of the arrow keys, highlight the title of your choice you want to edit (the first Ubuntu entry should be ok) and press "e" to go to the entry editor interface. You will now see the boot entries for the title you selected.
    • Highlight, again with the use of the arrow keys, the line that say "kernel" and press "e" to edit that line.
    • Add, without the quotes " vga=normal" and press the enter key to go out of edit mode.
    • Press the "b" key to boot your system.


    Note: To cancel your changes press the Escape key until the main menu appear.
    https://wiki.ubuntu.com/FrameBuffer
    Blog | Ubuntu User #15350 | Zsh FTW | Ubuntu Security | Nothing to hide?
    AMD Phenom II X6 1075T @ 3GHz, Nvidia GTX 650, 8GB DDR3 RAM, 2 X 1TB, 1 X 3TB HDD
    Please don't request support via PM


  5. #5
    Join Date
    May 2008
    Beans
    9

    Re: Nvidia Restricted drivers PROBLEM!!!!

    But where am I going with editing this line in grub menu???I fixed the booting problem didnt you read my post?I just want to use effects but it seems to me that u think that I can no longer boot in ubuntu or what!?Or editing this kernel line will possibly fix further driver installation problem?I am confused now!???

  6. #6
    starcannon is offline Chocolate Ubuntu Mocha Blend
    Join Date
    Feb 2007
    Location
    U.S.A.
    Beans
    1,835
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Heres how I set up every one of my nvidia cards, don't skip steps even if you have already done them in the past.
    Code:
    Print out this guide, you will be in pure CLI for part of the install.
    
    1)  Download the driver for your Nvidia Card from http://www.nvidia.com/Download/index.aspx?lang=en-us
        1.a) Make sure its in your home directory, this will make it so we don't have to change directories later when were in terminal.
    
    2) Open a terminal: Applications--> Accessories--> Terminal
    
    3) sudo apt-get install build-essential
    
    4) gksudo gedit /etc/modules
        4.a) Add "nvidia" without quotes to the list.
        4.b) Save and Exit
    
    5) gksudo gedit /etc/default/linux-restricted-modules-common
        5.a) Add "nv" without quotes to the restricted list. It should look exactly like this: DISABLED_MODULES="nv"
        5.b) Save and Exit
    
    6) sudo cp /etc/X11/xorg.conf ./xorg.conf.backup
    
    7) sudo rm /etc/X11/xorg.conf
        7.a) Were just deleting your old xorg.conf file, we backed it up in step 6 just in case we ever need it back again.
        7.b) Getting rid of old drivers, use one or more of the sections that apply to you:
            -------------------------------------------------------------------------------------------------------
            If you used Envy to attempt a previous nvidia install please run this command now before you go on:
    
            sudo envy --uninstall-all 
            sudo dpkg -P envy 
            sudo envyng --uninstall-all
            sudo dpkg -P envyng
            In Depth Instructions on Envy and EnvyNG install/uninstall http://albertomilone.com/pmwiki/pmwiki.php?n=Main.EnvyNG-InstructionsForUbuntu
    
    
    
    
            -------------------------------------------------------------------------------------------------------
            If you have some old Ubuntu repository/restricted driver manager attempts installed please run this command before you go on:
    
            sudo apt-get remove --purge nvidia*
                    sudo rm /lib/restricted-modules/.nvidia*
    
            -------------------------------------------------------------------------------------------------------
            If you have a failed NVIDIA*.run (drivers from the nvidia.com site) run this command before you go on:
    
            sudo nvidia-installer --uninstall
    
            -------------------------------------------------------------------------------------------------------
    ####################################################################################
    ##................................................................................##
    ## Alright Now Assuming That You are starting with a clean slate lets move forward##
    ##................................................................................##
    ####################################################################################
    
    8) CTRL-ALT-F1
        8.a) Okay were in Command Line only now, we have a little left to do in here.
        8.b)login:
        8.c)Password:
    
    9) sudo /etc/init.d/gdm stop
        9.a) This step shuts down the x-server and gnome desktop manager
    
    10) sudo chmod a+x ./NVIDIA*.run
        10.a) We made the nvidia installer executable.
    
    11) sudo ./NVIDIA*.run
        11.a) Answer to the affirmative for all questions.
        11.b) Be sure to specifically say you DO WANT it to write a new xorg.conf
        11.c) If you somehow answered incorrectly on the last question in the installer then:
            c.I) sudo nvidia-xconfig #this will write a new or attempt repair of
                         an xorg.conf file for you.
    
    12) sudo /etc/init.d/gdm start
        12.a) You should see an Nvidia Logo, and then be put at your login screen, 
                  you should also be able to enable desktop effects.
    
    Optional But recommended:
    13) To get the driver to update itself when a new kernel is installed from the update
        manager be sure to follow the guide in this link:
         http://ubuntuforums.org/showpost.php?p=5227704&postcount=1
    Here's a click link for the guide mention in step 13
    http://ubuntuforums.org/showpost.php...04&postcount=1

    I will continue to update this guide as I find new things, but I am not really following this thread any longer as the OP seems to have moved on.

    If I refer you to this guide from another thread, then please continue posting in the thread we met on. GL and hope this guide helps you.

    ~Starcannon
    Last edited by starcannon; April 20th, 2009 at 01:03 AM.

  7. #7
    Join Date
    Oct 2006
    Beans
    4,619
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Quote Originally Posted by kemkokems View Post
    But where am I going with editing this line in grub menu???I fixed the booting problem didnt you read my post?I just want to use effects but it seems to me that u think that I can no longer boot in ubuntu or what!?Or editing this kernel line will possibly fix further driver installation problem?I am confused now!???
    You said you were getting a Signal Out Of Range error. By editing Grub it should get rid of that possibly, since for some reason something is telling your monitor to go into a mode it doesn't support. You can edit Grub when you see the Grub menu come up after your BIOS screen when you turn your computer on.
    Blog | Ubuntu User #15350 | Zsh FTW | Ubuntu Security | Nothing to hide?
    AMD Phenom II X6 1075T @ 3GHz, Nvidia GTX 650, 8GB DDR3 RAM, 2 X 1TB, 1 X 3TB HDD
    Please don't request support via PM


  8. #8
    Join Date
    Jun 2007
    Beans
    39
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nvidia Restricted drivers PROBLEM!!!!

    After I installed the nvidia.run drivers, everything works perfectly. However, when I restart the computer, X cannot start and I have to run the driver setup program again before it will work. Why can't it remember the drivers?

    btw, I'm installing with sh not ./ if it makes a difference

  9. #9
    Join Date
    Jun 2007
    Beans
    39
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Quote Originally Posted by starcannon View Post
    Heres how I set up every one of my nvidia cards, don't skip steps even if you have already done them in the past.
    Code:
    8) CTRL-ALT-F1
        8.a) Okay were in Command Line only now, we have a little left to do in here.
        8.b)login:
        8.c)Password:
    
    9) sudo /etc/init.d/gdm stop
        9.a) This step shuts down the x-server and gnome desktop manager
    
    10) sudo chmod a+x ./NVIDIA*.run
        10.a) We made the nvidia installer executable.
    
    11) sudo ./NVIDIA*.run
        11.a) Answer to the affirmative for all questions.
        11.b) Be sure to specifically say you DO WANT it to write a new xorg.conf
        11.c) If you somehow answered incorrectly on the last question in the installer then:
            c.I) sudo nvidia-xconfig #this will write a new or attempt repair of an xorg.conf file for you.
    
    12) sudo /etc/init.d/gdm start
        12.a) You should see an Nvidia Logo, and then be put at your login screen, you should also be able to enable desktop effects.

    After I installed the nvidia.run drivers, everything works perfectly. However, when I restart the computer, X cannot start and I have to run the driver setup program again before it will work. Why can't it remember the drivers?

    btw, I'm installing with sh not ./ if it makes a difference


    sorry for double posting..
    Last edited by dansued; May 31st, 2008 at 10:24 PM.

  10. #10
    Join Date
    May 2008
    Beans
    9

    Re: Nvidia Restricted drivers PROBLEM!!!!

    Well now I am really pissed of!!!I tried all of these steps above and none of them works and now I totally crushed x-server and it can not find any backup!!!And now I am going to DELETE UBUNTU!!!!!!!!!!!
    ****,its driving me crazy.
    THANX ANYWAY!!!!

Page 1 of 7 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •