Well the problem is as it follows:

I am a virgin with the ubuntu and recently I have installed ubuntu 8.04 and it is really great OS and it got me pined downI wanted to try those amazing effects so i installed nvidia driver via synaptic ,and everything went fine.Ubuntu connected to internet and installed this driver and asked me to reboot and now the problem starts.I couldnt boot into ubuntu,I just see black screen and it says: signal out of range!!!
So I booted into recovery and I tried to fix x-server and it works.So when I finnaly got into ubuntu I have this message in upper panel that drivers are installed but not supported!!!
I also tried installing driver via NvyNG applet(which is fully automated) and I tried all the 3 versions of the nvidia drivers(173.14.05/71.86.04/96.43.05)but none of them works and when I install them I have the same problem!!!!
By the way my configuration is:

CPUentium 4 s478 2.0GHz Northwood
GPU:Asus GeForce FX5200 128MB
MBO:Asus P4S333-M

I also have windows xp pro sp2 installed along with the ubuntu in dual boot conf.
So if anyone has the solution please HELP!!!!
I was searching for help in my country but did not yet find the solution.
My ubuntu knowledge is very basic so simplify as much as possible!!!
THANX!!!