Results 1 to 7 of 7

Thread: NTFS partition has weird name

  1. #1
    Join Date
    Jul 2005
    Location
    Finland
    Beans
    10

    NTFS partition has weird name

    Hi all, I just installed the latest ubuntu having the 7.10 running for about a year before that. I decided to do fresh install. Now one of my ntfs partitions has a funny name. look at the picture its named "/".

    BTW:I have two harddisks, one for windows and its partitions and one for ubuntu.

    How do I fix this. Originally after installation ubuntu didn't mount that partition at all. After I added it to fstab it worked ok. In windows I have named that partition "backup". All the other showing partitions got their names from their labels. Why doesn't that partition get it?

    I ran the ntfsfix but it didn't help.


    everything works fine but the name bothers me
    Attached Images Attached Images

  2. #2
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: NTFS partition has weird name

    Quote Originally Posted by tuokor View Post
    Hi all, I just installed the latest ubuntu having the 7.10 running for about a year before that. I decided to do fresh install. Now one of my ntfs partitions has a funny name. look at the picture its named "/".

    BTW:I have two harddisks, one for windows and its partitions and one for ubuntu.

    How do I fix this. Originally after installation ubuntu didn't mount that partition at all. After I added it to fstab it worked ok. In windows I have named that partition "backup". All the other showing partitions got their names from their labels. Why doesn't that partition get it?

    I ran the ntfsfix but it didn't help.


    everything works fine but the name bothers me
    Try editing the partition's entry in /etc/fstab. You should be able to change the label there.
    Keith
    Open.nfo

  3. #3
    Join Date
    Jul 2005
    Location
    Finland
    Beans
    10

    Re: NTFS partition has weird name

    Code:
    # /etc/fstab: static file system information.
    #
    #  -- This file has been automaticly generated by ntfs-config -- 
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc /proc proc defaults 0 0
    # Entry for /dev/sdb2 :
    UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd / ext3 relatime,errors=remount-ro 0 1
    # Entry for /dev/sdb3 :
    UUID=0a6b6aa8-1faa-4a85-a110-e40a83fc07ad /home ext3 relatime 0 2
    # Entry for /dev/sdb1 :
    UUID=03b02386-d580-47c2-92b5-68e801f81129 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/sda8 /media/backup ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda7 /media/downloads ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda6 /media/work ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda5 /media/winOhjelmat ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda1 /media/Windows ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    Here is the fstab. The /dev/sda8 is the weird named. What do I change in this file?

  4. #4
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: NTFS partition has weird name

    Sorry, can you please post one more file: /boot/grub/menu.lst ... Sometimes I think the label fstab uses is set there. Also, what is the label for the partition when you are on Windows?

    Quote Originally Posted by tuokor View Post
    Code:
    # /etc/fstab: static file system information.
    #
    #  -- This file has been automaticly generated by ntfs-config -- 
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc /proc proc defaults 0 0
    # Entry for /dev/sdb2 :
    UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd / ext3 relatime,errors=remount-ro 0 1
    # Entry for /dev/sdb3 :
    UUID=0a6b6aa8-1faa-4a85-a110-e40a83fc07ad /home ext3 relatime 0 2
    # Entry for /dev/sdb1 :
    UUID=03b02386-d580-47c2-92b5-68e801f81129 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    /dev/sda8 /media/backup ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda7 /media/downloads ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda6 /media/work ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda5 /media/winOhjelmat ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    /dev/sda1 /media/Windows ntfs-3g defaults,locale=fi_FI.UTF-8 0 0
    Here is the fstab. The /dev/sda8 is the weird named. What do I change in this file?
    Keith
    Open.nfo

  5. #5
    Join Date
    Jul 2005
    Location
    Finland
    Beans
    10

    Re: NTFS partition has weird name

    Sorry for the late reply.The label in windows is "backup".
    Here is the menu.lst
    Code:
    # menu.lst - See: grub(8), info grub, update-grub(8)
    #            grub-install(8), grub-floppy(8),
    #            grub-md5-crypt, /usr/share/doc/grub
    #            and /usr/share/doc/grub-doc/.
    
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    # You can specify 'saved' instead of a number. In this case, the default entry
    # is the entry saved with the command 'savedefault'.
    # WARNING: If you are using dmraid do not use 'savedefault' or your
    # array will desync and will not let you boot your system.
    default		0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout		10
    
    ## hiddenmenu
    # Hides the menu by default (press ESC to see the menu)
    #hiddenmenu
    
    # Pretty colours
    #color cyan/blue white/blue
    
    ## password ['--md5'] passwd
    # If used in the first section of a menu file, disable all interactive editing
    # control (menu entry editor and command-line)  and entries protected by the
    # command 'lock'
    # e.g. password topsecret
    #      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
    # password topsecret
    
    #
    # examples
    #
    # title		Windows 95/98/NT/2000
    # root		(hd0,0)
    # makeactive
    # chainloader	+1
    #
    # title		Linux
    # root		(hd0,1)
    # kernel	/vmlinuz root=/dev/hda2 ro
    #
    
    #
    # Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST
    
    ### BEGIN AUTOMAGIC KERNELS LIST
    ## lines between the AUTOMAGIC KERNELS LIST markers will be modified
    ## by the debian update-grub script except for the default options below
    
    ## DO NOT UNCOMMENT THEM, Just edit them to your needs
    
    ## ## Start Default Options ##
    ## default kernel options
    ## default kernel options for automagic boot options
    ## If you want special options for specific kernels use kopt_x_y_z
    ## where x.y.z is kernel version. Minor versions can be omitted.
    ## e.g. kopt=root=/dev/hda1 ro
    ##      kopt_2_6_8=root=/dev/hdc1 ro
    ##      kopt_2_6_8_2_686=root=/dev/hdc2 ro
    # kopt=root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro
    
    ## Setup crashdump menu entries
    ## e.g. crashdump=1
    # crashdump=0
    
    ## default grub root device
    ## e.g. groot=(hd0,0)
    # groot=(hd1,1)
    
    ## should update-grub create alternative automagic boot options
    ## e.g. alternative=true
    ##      alternative=false
    # alternative=true
    
    ## should update-grub lock alternative automagic boot options
    ## e.g. lockalternative=true
    ##      lockalternative=false
    # lockalternative=false
    
    ## additional options to use with the default boot option, but not with the
    ## alternatives
    ## e.g. defoptions=vga=791 resume=/dev/hda5
    # defoptions=quiet splash
    
    ## should update-grub lock old automagic boot options
    ## e.g. lockold=false
    ##      lockold=true
    # lockold=false
    
    ## Xen hypervisor options to use with the default Xen boot option
    # xenhopt=
    
    ## Xen Linux kernel options to use with the default Xen boot option
    # xenkopt=console=tty0
    
    ## altoption boot targets option
    ## multiple altoptions lines are allowed
    ## e.g. altoptions=(extra menu suffix) extra boot options
    ##      altoptions=(recovery) single
    # altoptions=(recovery mode) single
    
    ## controls how many kernels should be put into the menu.lst
    ## only counts the first occurence of a kernel, not the
    ## alternative kernel options
    ## e.g. howmany=all
    ##      howmany=7
    # howmany=all
    
    ## should update-grub create memtest86 boot option
    ## e.g. memtest86=true
    ##      memtest86=false
    # memtest86=true
    
    ## should update-grub adjust the value of the default booted system
    ## can be true or false
    # updatedefaultentry=false
    
    ## should update-grub add savedefault to the default options
    ## can be true or false
    # savedefault=false
    
    ## ## End Default Options ##
    
    title		Ubuntu 8.04.1, kernel 2.6.24-19-generic
    root		(hd1,1)
    kernel		/boot/vmlinuz-2.6.24-19-generic root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro quiet splash
    initrd		/boot/initrd.img-2.6.24-19-generic
    quiet
    
    title		Ubuntu 8.04.1, kernel 2.6.24-19-generic (recovery mode)
    root		(hd1,1)
    kernel		/boot/vmlinuz-2.6.24-19-generic root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro single
    initrd		/boot/initrd.img-2.6.24-19-generic
    
    title		Ubuntu 8.04.1, kernel 2.6.24-17-generic
    root		(hd1,1)
    kernel		/boot/vmlinuz-2.6.24-17-generic root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro quiet splash
    initrd		/boot/initrd.img-2.6.24-17-generic
    quiet
    
    title		Ubuntu 8.04.1, kernel 2.6.24-17-generic (recovery mode)
    root		(hd1,1)
    kernel		/boot/vmlinuz-2.6.24-17-generic root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro single
    initrd		/boot/initrd.img-2.6.24-17-generic
    
    title		Ubuntu 8.04.1, kernel 2.6.24-16-generic
    root		(hd1,1)
    kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro quiet splash
    initrd		/boot/initrd.img-2.6.24-16-generic
    quiet
    
    title		Ubuntu 8.04.1, kernel 2.6.24-16-generic (recovery mode)
    root		(hd1,1)
    kernel		/boot/vmlinuz-2.6.24-16-generic root=UUID=6ac0e964-7aed-4712-a681-30ffa0ad9afd ro single
    initrd		/boot/initrd.img-2.6.24-16-generic
    
    title		Ubuntu 8.04.1, memtest86+
    root		(hd1,1)
    kernel		/boot/memtest86+.bin
    quiet
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title		Other operating systems:
    root
    
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/sda1
    title		Microsoft Windows XP Professional
    root		(hd0,0)
    savedefault
    makeactive
    chainloader	+1

  6. #6
    Join Date
    Jul 2005
    Location
    Finland
    Beans
    10

    Re: NTFS partition has weird name

    does anyone have any idea? At the commandline I can see "backup" in the media folder where the partition is mounted. The name is als wrong in kde so the problem is somewhere between the graphical and the system.

  7. #7
    Join Date
    Dec 2006
    Location
    USA
    Beans
    348
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: NTFS partition has weird name

    What is the disk label set to when you boot into windows? Another thing you can try in Ubuntu is to download and run "gparted."

    Code:
    sudo aptitude install gparted
    gksudo gparted
    It is possible that gparted will allow you to view and change disk labels.

    Goodluck,
    Keith
    Open.nfo

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •