Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] Defective Java RTE with Openoffice base on 8.04

  1. #1
    Join Date
    Apr 2007
    Location
    Saddleworth, Oldham
    Beans
    43
    Distro
    Ubuntu 11.04 Natty Narwhal

    [SOLVED] Defective Java RTE with Openoffice base on 8.04

    After installing openoffice base I get the following error message when trying to open an existing database:

    'The selected JRE is defective.Please select another version or install a new version and select it under Tools - Options - Openoffice - Java. Please install the openoffice.org-java-common package for this functionality.'

    The next error dialoge box tells me that 'No Java Installation could be found.' A check with Synaptic shows that openoffice.org-java-common is installed. I have tried a complete removal and reinstallation with no effect.

    I'm at a loss to know what to try next. Any ideas anyone??

    Panorack

  2. #2
    Join Date
    Oct 2004
    Location
    Nissa la bella
    Beans
    216
    Distro
    Ubuntu

    Re: Defective Java RTE with Openoffice base on 8.04

    Not really sure but i guess that openoffice.org-java-common is using a JRE.

    So check if you have one installed, and which version is it. If you have different version use update-java-alternatives for the select the one OOo needs.

  3. #3
    Join Date
    Jan 2008
    Beans
    10

    Re: Defective Java RTE with Openoffice base on 8.04

    How can i check if there is a JRE installed?

  4. #4
    Join Date
    Oct 2004
    Location
    Nissa la bella
    Beans
    216
    Distro
    Ubuntu

    Re: Defective Java RTE with Openoffice base on 8.04

    Quote Originally Posted by roida View Post
    How can i check if there is a JRE installed?


    Try some Java related commands on a terminal.
    Like java, javac and you will see if you have any JRE installed.

  5. #5
    Join Date
    Oct 2004
    Location
    Nissa la bella
    Beans
    216
    Distro
    Ubuntu

    Re: Defective Java RTE with Openoffice base on 8.04

    You could also use the command update-java-alternatives the see which version are installed and choose the one you want to use.

  6. #6
    Join Date
    Apr 2007
    Location
    Saddleworth, Oldham
    Beans
    43
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Defective Java RTE with Openoffice base on 8.04

    Thanks for the help SyL. I assumed that the openoffice.org-java-common package would have included the JRE but apparently not.

    However, I downloaded java-6-sun from their site and it installed ok but I am still getting the same error messages from Openoffice-base. The JRE is installed and Openoffice is pointing to the directory where it is installed, so is this a bug or am I missing something????

    panorack

  7. #7
    Join Date
    Oct 2004
    Location
    Nissa la bella
    Beans
    216
    Distro
    Ubuntu

    Re: Defective Java RTE with Openoffice base on 8.04

    You are welcome
    But i'm not sure i'll be of a great help, for this problem.

    From your answer i understand that when you go into Tools - Options - Openoffice - Java
    you can see the sun JRE1.6 that you installed and this JRE is selected, correct?

    Are you still getting the error "No Java Installation could be found"?

  8. #8
    Join Date
    Apr 2007
    Location
    Saddleworth, Oldham
    Beans
    43
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Defective Java RTE with Openoffice base on 8.04

    Yes, I installed JRE1.6.0_06 and that is the one that is showing in Tools-Options-Java. It even shows the location of that file, which is correct. 1.6 is the correct version of JRE for Ubuntu 8.04 so I am assuming it is correct for OOo-Base, which is version 2.4.

    Very frustrating as it worked perfectly under Ubuntu 7.10. I really don't know what to try next.

    panorack

  9. #9
    Join Date
    Oct 2004
    Location
    Nissa la bella
    Beans
    216
    Distro
    Ubuntu

    Re: Defective Java RTE with Openoffice base on 8.04

    Are you still getting the error "No Java Installation could be found"?

    Do you get the same error with another DB?

    Could you try to load this DB within a 7.10 live CD, and see if this DB file could be corrupted?



    it just some hints, sorry that i cannot help more efficiently.

  10. #10
    Join Date
    Apr 2007
    Location
    Saddleworth, Oldham
    Beans
    43
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Defective Java RTE with Openoffice base on 8.04

    Thanks for your time and help SyL but I have found that there is a problem with OO.o-Base detecting Java when running under Ubuntu 8.04. I looked on the OpenOffice forum site and found the following solution:

    Close OOo then delete the file ~/.openoffice.org2/user/config/javasettings_Linux_x86.xml file.

    Details of the thread where I found the above can be found at:

    http://user.services.openoffice.org/...834cf1c80d218a

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •