Results 1 to 4 of 4

Thread: Aftermath of GRUB Reinstall

  1. #1
    Join Date
    Feb 2008
    Location
    united States of America
    Beans
    20
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Aftermath of GRUB Reinstall

    In continuation of http://ubuntuforums.org/showthread.php?p=4995813:

    So after reinstalling GRUB using the method I stated in my last reply to that thread, the GRUB loading screen with the Ubuntu logo finally shows up. Towards the very end of that loading bar, it brings me to one of the following sort of loading screens. Actually, I end up figuring out this is where it also stops or finishes loading, and that is also the next, new problem:


    What? I thought I was supposed to see an Ubuntu login screen...

  2. #2
    Join Date
    Apr 2008
    Location
    Germany - Berlin
    Beans
    340

    Re: Aftermath of GRUB Reinstall

    press ctrl+alt+F7 to see if you have a graphical server running (should show graphical login). If you see just black or little pixies running around or something then try ctrl+alt+F1 that should at least give you a text login.

  3. #3
    Join Date
    Apr 2007
    Location
    Munich, Germany
    Beans
    1,578

    Re: Aftermath of GRUB Reinstall

    that happened to me occasionally, and after i hit enter it loaded properly, and i checked my rc.local scripts, and found i had a startup script to run that no longer existed. See if that's the case.

  4. #4
    Join Date
    Feb 2008
    Location
    united States of America
    Beans
    20
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Aftermath of GRUB Reinstall

    CTRL+ALT+F7 did nothing.
    CTRL+ALT+F1 did nothing.
    ENTER did nothing.
    Booting into RECOVERY MODE (pressing ESC when GRUB is about to start) brang me to root@Qwerty:~# (console), and repeating the above did nothing.

    EDIT :: The first two lines here worked now, after restarting it and trying again. CTRL+ALT+F7 cleared the screen. CTRL+ALT+F1 brang me to a text-based login screen, where I logged in and it brought me to qwerty@Qwerty:~$

    rc.local scripts
    How, where, and what?

    EDIT :: /etc/rc.local -- but what am I supposed to look for? I'm a Windows user; I don't know anything about what is right or wrong in a place like this. *shrugs*


    Result of 'startx'



    Result of 'xorgconfig'
    -bash: xorgconfig: command not found


    Result of 'cat /etc/rc.local'


    Result of 'xorg-config'
    -bash: xorg-config: command not found


    Result of 'xorgxconfig'
    -bash: xorgxconfig: command not found


    sudo dpkg-reconfigure xserver-xorg apparently did the trick. This thread is complete.
    Last edited by BlueToast; June 1st, 2008 at 06:00 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •