Page 11 of 16 FirstFirst ... 910111213 ... LastLast
Results 101 to 110 of 151

Thread: SOLVED Headphone & Speaker Issue SOLVED

  1. #101
    Join Date
    Mar 2007
    Location
    Shapleigh, Maine US
    Beans
    246
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: SOLVED Headphone & Speaker Issue SOLVED

    Just reporting that this worked for me on an Acer Aspire 5050. Adding the line
    options snd-hda-intel model=acer-aspire
    Worked for me.
    The speakers do not turn off when you put the headphones in, but it was that way even in Windows.

  2. #102
    Join Date
    Apr 2009
    Location
    Philippines
    Beans
    12
    Distro
    Ubuntu 9.10 Karmic Koala

    Arrow Re: SOLVED Headphone & Speaker Issue SOLVED

    Quote Originally Posted by davidkyn View Post
    SOLVED...Headphone & Speaker Issues:
    Ussualy effect intel HDA sound cards...Sound comes out both fronts and headphones at same time!

    My Solution for Ubuntu8.04.............Basicaly you just want to add a switch to the volume controll!


    Tell alsa which driver to use for your hda intel sound card. You do this by first looking at the output of
    Code:
    head -n 1 /proc/asound/card0/codec*

    Mine was:
    Codec Realtek ALC888

    SO you then issue the command:
    Code:
    zless /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz

    Look for the subtitle "Module snd-hda-intel".
    In this subsection look for the name of codec “you” aquired from the output above...Mine was Realtek ALC888...so after locating the list for “Module snd-hda-intel” I scrolled down further to find:

    ALC883/888 then I looked at the options directly under and chose “3stack-6ch 3-jack 6
    channel” you may have to choose another option or experiment.

    Important!!!!Now that you have an option what do you do with it.........1st you only take the part of it...that is the part directly under the listed codec...for me that is “3stack-6ch” and add it to the following line to get:

    options snd-hda-intel model=3stack-6ch


    Without the underline of course, so that it looks like:

    options snd-hda-intel model=3stack-6ch

    This is the line that you need to add to /etc/modprobe.d/alsa-base by doing the following:

    For Ubuntu:
    sudo gedit /ect/modprobe.d/alsa-base

    When the new window opens, cut and paste the new line you have just made at the bottom of all the text, save and exit.

    Restart and hopefully if you have not buggered up with the spacing as I did you should now have a SWITCH option in your “Volume Contol” found in the desktop panel. Just deselect or select to switch between speakers of headphones as it should have been from the start.

    HOW RIDICULOUS FOR something SO ESSENTIAL...TOOK ME ALL DAY TALKING TO MYSELF AND SEARCHING THE NET TO FIX. Oh yea..a special thanks to the guys at the Suse Forum as well

    HOPEFULLY THIS WILL HELP SOMONE ELSE...I would say it was more a case with the module than it was ever with updating...but then again I dont know that much ecept what I have learnt today...........Persistance Pays I guess!
    how about for COMPAQ CQ40-340T.. Anyone who has an idea or bright solutions, please..

  3. #103
    Join Date
    Aug 2007
    Location
    Cape Town, South Africa
    Beans
    7
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: SOLVED Headphone & Speaker Issue SOLVED

    For my Fujitsu Amilo xi3650:

    Code:
    options snd-hda-intel model=haier-w66
    Headphone switch has to be OFF (unticked)

  4. #104
    Join Date
    May 2009
    Beans
    1

    Re: SOLVED Headphone & Speaker Issue SOLVED

    I had Upgraded to Jaunty and as a result internal speakers would not mute after my headphones were plugged.

    Added: options snd-hda-intel model=3stack-6ch as described (my codec was also Realtek ALC888) and this worked a treat, thanks for the useful guide

  5. #105
    Join Date
    Apr 2009
    Beans
    55
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: SOLVED Headphone & Speaker Issue SOLVED

    This fix worked in Jaunty with a Sony VAIO VGN-NR498E. Had to choose the sony-assmd option. Also, the file was "alsa-base.conf" not just alsa-base.

    Thanks a lot - don't know what I would have done without you!

  6. #106
    Join Date
    May 2009
    Beans
    2

    Re: SOLVED Headphone & Speaker Issue SOLVED

    Thanks... I have been looking for hours for this.

    Got NEC P570 working with 'jack-sensing' and all! using:

    options snd-hda-intel model=targa-dig

    Thanks again!

  7. #107
    Join Date
    Apr 2009
    Location
    Philippines
    Beans
    12
    Distro
    Ubuntu 9.10 Karmic Koala

    Lightbulb Re: SOLVED Headphone & Speaker Issue SOLVED

    I've got this problem solved for Compaq Presario CQ40 laptops. Stay or revert Ubuntu to Hardy Heron(8.04) if you're using Jaunty. That solves the problem for the meantime. Let's wait 9.04 will work on Compaq Laptops' sound chipsets.

  8. #108
    Join Date
    Apr 2009
    Beans
    7
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Exclamation Re: SOLVED Headphone & Speaker Issue SOLVED

    Frickin' awesome. Worked great after a few typos were corrected...

    For newbies, be aware of:
    /etc/modprobe.d/alsa-base.conf

    The "etc" appears as "ect" in the original fix post

    and

    The ".conf" does not appear in the original fix post.

    Other than that, should work great for you. Good luck!

  9. #109
    Join Date
    Oct 2008
    Beans
    2

    Re: SOLVED Headphone & Speaker Issue SOLVED

    thank you very much... that was very useful for me... i've been looking for this solution for about 1 year... thanks!!

  10. #110

    Lightbulb SOLVED Headphone & Speaker & Internal microphone issue, Acer Aspire 5050

    Acer Aspire 5050 owners, using Ubuntu 9.04 (Jaunty): the following will make your speakers, headphone and INTERNAL MICROPHONE work.
    • press ALT + F2
    • enter this command:
      gksudo gedit /etc/modprobe.d/alsa-base.conf
    • enter your password
    • in the text editor that opens, paste this line (replacing the previous content, if the file is not blank):
      options snd-hda-intel model=fujitsu-pi2515
      (This is "fujitsu-pi2515", not "acer-aspire", because the later would not allow the internal microphone to work.)
    • save and close
    • restart your computer
    • you'll have to edit your Volume Control settings to select the internal mic as a source. Some of the sliders settings won't be saved, but this is not a major problem.


    Hope it helps.

Page 11 of 16 FirstFirst ... 910111213 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •