Results 1 to 10 of 151

Thread: SOLVED Headphone & Speaker Issue SOLVED

Threaded View

  1. #1
    Join Date
    Feb 2007
    Beans
    90

    SOLVED Headphone & Speaker Issue SOLVED

    SOLVED...Headphone & Speaker Issues:
    Ussualy effect intel HDA sound cards...Sound comes out both fronts and headphones at same time!

    My Solution for Ubuntu8.04.............Basicaly you just want to add a switch to the volume controll!


    Tell alsa which driver to use for your hda intel sound card. You do this by first looking at the output of
    Code:
    head -n 1 /proc/asound/card0/codec*

    Mine was:
    Codec Realtek ALC888

    SO you then issue the command:
    Code:
    zless /usr/share/doc/alsa-base/driver/ALSA-Configuration.txt.gz

    Look for the subtitle "Module snd-hda-intel".
    In this subsection look for the name of codec “you” aquired from the output above...Mine was Realtek ALC888...so after locating the list for “Module snd-hda-intel” I scrolled down further to find:

    ALC883/888 then I looked at the options directly under and chose “3stack-6ch 3-jack 6
    channel” you may have to choose another option or experiment.

    Important!!!!Now that you have an option what do you do with it.........1st you only take the part of it...that is the part directly under the listed codec...for me that is “3stack-6ch” and add it to the following line to get:

    options snd-hda-intel model=3stack-6ch


    Without the underline of course, so that it looks like:

    options snd-hda-intel model=3stack-6ch

    This is the line that you need to add to /etc/modprobe.d/alsa-base by doing the following:

    For Ubuntu:
    sudo gedit /ect/modprobe.d/alsa-base

    When the new window opens, cut and paste the new line you have just made at the bottom of all the text, save and exit.

    Restart and hopefully if you have not buggered up with the spacing as I did you should now have a SWITCH option in your “Volume Contol” found in the desktop panel. Just deselect or select to switch between speakers of headphones as it should have been from the start.

    HOW RIDICULOUS FOR something SO ESSENTIAL...TOOK ME ALL DAY TALKING TO MYSELF AND SEARCHING THE NET TO FIX. Oh yea..a special thanks to the guys at the Suse Forum as well

    HOPEFULLY THIS WILL HELP SOMONE ELSE...I would say it was more a case with the module than it was ever with updating...but then again I dont know that much ecept what I have learnt today...........Persistance Pays I guess!
    Last edited by davidkyn; May 25th, 2008 at 11:40 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •