Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

  1. #1
    Join Date
    Apr 2008
    Beans
    18

    Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    With the release of Mythbuntu Hardy, I decided to put a new, bigger HD in my PVR machine, and install a fresh OS. There have been a few struggles with this, but by far the most serious and annoying has been trying to get stable video support for my GeForce FX 5200.

    I have tried the proprietary drivers installed by the Mythbuntu CD, the ones installed by EnvyNG, and both the 171.06 and 173.08 installers from NVIDIA. All show the same display artifacts. The image will freeze, or show random color "tearing" or pixelation, or things showing in the wrong location. (See the attached photo for an example.)

    I'm pretty sure at this point that it's a driver issue: installation, conflicts, settings... something. The hardware was working fine in earlier revs of Ubuntu; doesn't have any issues under Windows, or Ubuntu with the generic video driver (when I revert to failsafe xorg.conf); and I ran memtest on the machine for like 19 hours without any problems.

    At this point, I feel like I've tried every tweak I've been able to find trolling through the forums for advice. I'm about ready to just put the machine in a closet, or try to find a Windows-based alternative. This might be the most incredibly frustrating Linux struggle I've had.

    Help?
    Attached Images Attached Images

  2. #2
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,296
    Distro
    Ubuntu Development Release

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Try installing Mythbuntu 8.04, then fully updating, then installing the restricted driver.

    Is this an unmodded video card? Those types of artifacts could be from over heating.
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  3. #3
    Join Date
    Apr 2008
    Beans
    18

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Quote Originally Posted by tgm4883 View Post
    Try installing Mythbuntu 8.04, then fully updating, then installing the restricted driver.
    Any particular reason (like a package that's been updating since release), or just something to try?

    Is this an unmodded video card? Those types of artifacts could be from over heating.
    Came out of the box and went into the machine ~2 years ago, and I've never seen this kind of problem with it before. No overclocking or anything like that.

    I've been running things like Quake 3 timedemos on Windows to try to rule out heat/hardware failures, and haven't seen any of the same issues. At the moment, the machine is on a desk in my office, case totally open, so I'm pretty sure it's not overheating.

  4. #4
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,296
    Distro
    Ubuntu Development Release

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    It's just something to try. Also, i'm not sure where the cutoff is, but you could try nvidia-glx instead of nvidia-glx-new
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  5. #5
    Join Date
    Apr 2008
    Beans
    18

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Quote Originally Posted by tgm4883 View Post
    Also, i'm not sure where the cutoff is, but you could try nvidia-glx instead of nvidia-glx-new
    I have, actually, along with at least one of the legacy drivers that EnvyNG knows how to install. Now, I can't swear that both were clean change-only-one-variable experiments, 'cause I was so frustrated/desperate by that point, but they didn't work any better.

  6. #6
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,296
    Distro
    Ubuntu Development Release

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Did the live cd show this same problem? Have you tried a regular Ubuntu Hardy install?
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  7. #7
    Join Date
    Apr 2008
    Beans
    18

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Quote Originally Posted by tgm4883 View Post
    Did the live cd show this same problem?
    I wasn't sure whether the live CDs were able to load the restricted drivers; I guess I always assumed that they were pretty bare-bones in that respect.

    Have you tried a regular Ubuntu Hardy install?
    Nope.

    If the live CD can load the proprietary drivers, though, I might try the mainstream distro that way. This machine was running MythTV on regular Ubuntu before, and doing so again would work. Mythbuntu is just much more convenient for what I'm actually trying to accomplish.

  8. #8
    Join Date
    Nov 2006
    Location
    Oregon
    Beans
    4,296
    Distro
    Ubuntu Development Release

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Not sure what you are trying to accomplish, but you can install the package mythbuntu-desktop to get the mythbuntu look and feel. You can also install mythbuntu-control-centre and configure and install it so it will auto boot into mythbuntu and have the necessary software that you require.
    *Don't PM me directly for support, open a new thread
    *Looking for a MythTV quick start guide?

  9. #9
    Join Date
    Apr 2008
    Beans
    18

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Quote Originally Posted by tgm4883 View Post
    Did the live cd show this same problem? Have you tried a regular Ubuntu Hardy install?
    Well, you can add both of these to the fail list. The live CDs (both Mythbuntu and mainstream Hardy) appear to use generic graphics, with no option (that I could find) to load the proprietary drivers.

    And, after installing Hardy, updating fully, and then switching to nvidia-glx-new (via the restricted driver manager)... same kind of artifacts I was seeing in Mythbuntu. Purged that, installed EnvyNG, tried that way, and the issues are just as bad or worse.

    Having now exhausted the main "try this other install" options, can anyone offer any suggestions as to what might be causing these artifacts, or how I might correct them?
    Attached Images Attached Images

  10. #10
    Join Date
    Aug 2006
    Beans
    Hidden!

    Re: Can't get NVIDIA 5200 to behave on Mythbuntu 8.04

    Follow this exactly and your screen probs should be resolved.

    http://ubuntuforums.org/showthread.p...80#post5064980 msg #430

    I have just sorted my upgrade probs right now - first time.
    You do what? Are you crazy!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •