Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: [SOLVED] failed to mount sata disk manually

  1. #1
    Join Date
    Oct 2005
    Location
    Malaysia
    Beans
    148
    Distro
    Ubuntu

    [SOLVED] failed to mount sata disk manually

    Note: once i tried setting up LVM with this disk but i kinda gave up then it couldn't be booted up so i did fresh install. This disk is not the main i use for installation, simply want to use it to store data.

    I tried to mount it:
    Code:
    umarzuki@lalaland:~$ sudo mount /dev/sda1 simpan/
    mount: unknown filesystem type 'LVM2_member'
    i suspected it was caused by the partition table, so i try to wipe it
    Code:
    umarzuki@lalaland:~$ sudo dd if=/dev/zero of=/dev/sda bs=512 count=1
    1+0 records in
    1+0 records out
    512 bytes (512 B) copied, 0.00757354 s, 67.6 kB/s
    then the i got same error when i tried to mount it..what could cause this? How would i be able to mount this hardisk?

  2. #2
    Join Date
    Feb 2007
    Location
    Romania
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: failed to mount sata disk manually

    Quote Originally Posted by ikki_72 View Post
    Note: once i tried setting up LVM with this disk but i kinda gave up then it couldn't be booted up so i did fresh install. This disk is not the main i use for installation, simply want to use it to store data.

    I tried to mount it:
    Code:
    umarzuki@lalaland:~$ sudo mount /dev/sda1 simpan/
    mount: unknown filesystem type 'LVM2_member'
    i suspected it was caused by the partition table, so i try to wipe it
    Code:
    umarzuki@lalaland:~$ sudo dd if=/dev/zero of=/dev/sda bs=512 count=1
    1+0 records in
    1+0 records out
    512 bytes (512 B) copied, 0.00757354 s, 67.6 kB/s
    then the i got same error when i tried to mount it..what could cause this? How would i be able to mount this hardisk?
    Please post the output of:
    Code:
    sudo fdisk -l

  3. #3
    Join Date
    Oct 2005
    Location
    Malaysia
    Beans
    148
    Distro
    Ubuntu

    Re: failed to mount sata disk manually

    Quote Originally Posted by sisco311 View Post
    Please post the output of:
    Code:
    sudo fdisk -l
    here
    Code:
    umarzuki@lalaland:~/Desktop$ sudo fdisk -l
    
    Disk /dev/sda: 41.1 GB, 41110142976 bytes
    255 heads, 63 sectors/track, 4998 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x8f8000b1
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1        4787    38451546   83  Linux
    /dev/sda2            4788        4998     1694857+   5  Extended
    /dev/sda5            4788        4998     1694826   82  Linux swap / Solaris
    
    Disk /dev/sdb: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: 0x00000000
    
    Disk /dev/sdb doesn't contain a valid partition table

  4. #4
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,983
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: failed to mount sata disk manually

    With LVM:

    You don't mount an "LVM" partition the same way you mount a regular partition

    Code:
    pvs
    this will list your volume groups
    like this:
    /dev/hda2 VolGroup01
    /dev/hdb2 VolGroup00

    Code:
    lvdisplay /dev/VolGroup01
    this will show the lv name needed to mount

    mount /dev/VolGroup00/LogVol00 /tmp/mnt (or whatever your home mount point in that volume is)

    Hope this helps.....

  5. #5
    Join Date
    Oct 2005
    Location
    Malaysia
    Beans
    148
    Distro
    Ubuntu

    Re: failed to mount sata disk manually

    Code:
    umarzuki@lalaland:~/Desktop$ sudo lvdisplay /dev/VolGroup01
      Volume group "VolGroup01" not found
    umarzuki@lalaland:~/Desktop$ sudo lvdisplay
      No volume groups found
    what do i do then?

    oh my god! maybe it's in my main hardisk...looks like i have to wipe the partition table then, do a fresh install..
    Last edited by ikki_72; May 24th, 2008 at 04:03 PM.

  6. #6
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,983
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: failed to mount sata disk manually

    Are you still trying to setup the LVM?

    Did you type pvm?

  7. #7
    Join Date
    Oct 2005
    Location
    Malaysia
    Beans
    148
    Distro
    Ubuntu

    Re: failed to mount sata disk manually

    no...i'm not going to do lvm anymore (actually last incident freaked me out)

  8. #8
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,983
    Distro
    Ubuntu 11.04 Natty Narwhal

  9. #9
    Join Date
    Oct 2005
    Location
    Malaysia
    Beans
    148
    Distro
    Ubuntu

    Re: failed to mount sata disk manually

    but the problem is..even after i did what i said above, the error still produced.
    Code:
    umarzuki@lalaland:~$ sudo mount /dev/sda1 disk/
    mount: unknown filesystem type 'LVM2_member'
    how do i rid any info about lvm?

  10. #10
    Join Date
    Oct 2005
    Location
    Malaysia
    Beans
    148
    Distro
    Ubuntu

    Re: failed to mount sata disk manually

    i add another info
    Code:
    umarzuki@lalaland:~$ vgdisplay 
      No volume groups found
    umarzuki@lalaland:~$ lvdisplay 
      No volume groups found
    umarzuki@lalaland:~$ lvscan
      No volume groups found
    umarzuki@lalaland:~$ lvmdiskscan 
      0 disks
      0 partitions
      0 LVM physical volume whole disks
      0 LVM physical volumes
    what i want is to have sda1 mounted on /home/umarzuki/disk

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •