Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Loading UBUNTU on 2nd New hard drive?

  1. #1
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Cool Loading UBUNTU on 2nd New hard drive?

    Recently purchased a second Western Digital Hard drive 160Gb. I'm running Win XP on my main hard drive.

    I managed to install Ubuntu 7.04 on the new second drive but I am unable to get it to find a proper article that will give me the menu to dual boot btw the two..

    Sorry if this has been posted before.. but I'm very new to Linux and wish to explore it...

    Thank u in advance..

  2. #2
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,984
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Loading UBUNTU on 2nd New hard drive?

    Within Ubuntu, bring up a terminal and type:
    sudo grub

    This will give you the grub shell >

    To install the GRUB bootloader on the primary disk, type:
    setup (hd0)

    This will install the GRUB bootloader code within the MBR of the primary drive.

    Type quit to exit the GRUB shell.

    When you reboot you will be presented the GRUB bootloader.

  3. #3
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Loading UBUNTU on 2nd New hard drive?

    Thanksfor your prompt reply. I can't get ubunto to load up in the first place. Should I try loading it again via the Ubuntu CD and install GRUB from there?

  4. #4
    Join Date
    May 2008
    Beans
    49

    Re: Loading UBUNTU on 2nd New hard drive?

    yes

  5. #5
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Angry Re: Loading UBUNTU on 2nd New hard drive?

    Loaded up the Ubuntu Live CD

    Loaded Grub

    Got the error message ...

    grub> setup(hd0)

    Error 27: Unrecognized command

    grub>



  6. #6
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,984
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Loading UBUNTU on 2nd New hard drive?

    Quote Originally Posted by guntherfurlong View Post
    Loaded up the Ubuntu Live CD

    Loaded Grub

    Got the error message ...

    grub> setup(hd0)

    Error 27: Unrecognized command

    grub>


    You should have a space between "setup (hd0)"

  7. #7
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Loading UBUNTU on 2nd New hard drive?

    setup (hd0) gets me this... (a space is there)

    Error 12: Invalid device requested

  8. #8
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,984
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Loading UBUNTU on 2nd New hard drive?

    what do you get with:
    sudo fdisk -l

  9. #9
    Join Date
    May 2008
    Beans
    Hidden!
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Loading UBUNTU on 2nd New hard drive?

    Disk /dev/sda: 160.0 GB, 160000000000 bytes
    255 heads, 63 sectors/track, 19452 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 18719 150360336 83 Linux
    /dev/sda2 18720 19452 5887822+ 5 Extended
    /dev/sda5 18720 19452 5887791 82 Linux swap / Solaris

    Disk /dev/sdb: 160.0 GB, 160041885696 bytes
    255 heads, 63 sectors/track, 19457 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 7649 61440561 7 HPFS/NTFS
    /dev/sdb2 7650 19456 94839727+ f W95 Ext'd (LBA)
    /dev/sdb5 7650 13386 46082421 7 HPFS/NTFS
    /dev/sdb6 13387 19456 48757243+ 7 HPFS/NTFS

    Disk /dev/sdc: 60.0 GB, 60011642880 bytes
    255 heads, 63 sectors/track, 7296 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdc1 * 1 7295 58597056 7 HPFS/NTFS

  10. #10
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,984
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Loading UBUNTU on 2nd New hard drive?

    OK

    Boot into the live Ubuntu cd.

    When you get to the desktop open a terminal and enter.

    Code:
    sudo grub
    This will get you a "grub>" prompt (i.e. the grub shell). At grub>. enter these commands

    Code:
    grub >find /boot/grub/stage1
    Whatever was returned for the find command use it in the next step (you are still at grub>.

    Code:
    grub >root (hd?,?)
    Again use the value from the find command i.e. if find returned (hd0,1) then you would enter root (hd0,1)

    Next enter the command to install grub to the mbr

    Code:
    grub >setup (hd0)
    Then exit the grub shell

    Code:
    grub> quit
    I just think the root was not set properly.
    The hd0 is the proper device though....

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •