Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 48

Thread: Usb devices not mounted or recognised

  1. #11
    Join Date
    Mar 2008
    Location
    Rolla, MO, USA
    Beans
    74
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Usb devices not mounted or recognised

    Thanks for the quick response cdtech, yet in the rc2.d folder, I have S24hal and S12dbus. So I don't think this is my problem. I do know that when I run a fresh 8.04 live CD, my USB flash drive works great. Have any other ideas?

  2. #12
    Join Date
    Jan 2007
    Location
    ~/PA/USA
    Beans
    1,983
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Usb devices not mounted or recognised

    I've heard some had success uninstalling hal and reinstalling. It's worth a shot.

  3. #13
    Join Date
    Mar 2008
    Location
    Rolla, MO, USA
    Beans
    74
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Usb devices not mounted or recognised

    Yeah I tried that, too.

  4. #14
    Join Date
    Jun 2008
    Beans
    11

    Angry Re: Usb devices not mounted or recognised

    Hi,
    I have recently installed ubuntu 8.04 and I have came to the conclusion that ubuntu does not support my usb hardware at all.
    the hardware works fine with windows so it is a ubuntu driver issue.
    The bios is Phoenix award version 6.00PG and mainboard is a Jetway.

    I tried ubuntu on another machine and USB does seem to work ok.

    Hope someone could shed some light.

    Thanks

  5. #15
    Join Date
    Nov 2007
    Beans
    35

    Re: Usb devices not mounted or recognised

    this might be a band-aid fix, but it's worth a shot maybe...just try to restart the hardware abstraction layer...if it works on startup, just type into the terminal
    Code:
    sudo /etc/init.d/hal restart
    if this works you can make a launcher or script and just run it once you have the usb installed...sucks, but might be the only way to get access to the usb for the time being...hope it helps
    good luck
    Nil Gach Uile fhanai caillete - Not all who wander are lost

  6. #16
    Join Date
    Jun 2008
    Beans
    11

    Re: Usb devices not mounted or recognised

    Thanks Sammy,
    I have tried this but no luck.
    Wierd thing is that I have installed ubuntu on another computer (laptop) following exact same procedure as with the pc, works on one but doesnt on the other.
    Seems like Ubuntu is fussy on what hardware it decides to work with. Have no idea what it doesnt like about my PC usb.

    I also tried downloading linux openSUSE but USB keyboard doesnt work on that either.

    On a different note, my laptop keyboard has now stopped working properly, with the num lock LED not going off, and the keys around jkl spitting out numbers instead.
    Everything normal until ubuntu kicks in, so definitely a driver issue.

    Thanks again for your reply,

  7. #17
    Join Date
    Nov 2007
    Beans
    35

    Re: Usb devices not mounted or recognised

    wow...that is weird....have you tried another version of ubuntu? i know some people have had more success with gutsy...i have run out of ideas tho...sorry
    Nil Gach Uile fhanai caillete - Not all who wander are lost

  8. #18
    Join Date
    Nov 2006
    Beans
    7

    Re: Usb devices not mounted or recognised

    I have been having similar problems. Prior to hardy all my usb devices were automent. However following the upgrade it does seem to want to automount any of the devices.
    An 'lspci' results in:
    00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
    00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)

    and when i run 'sudo udevmonitor --environment'

    UDEV [1213046819.407552] add /block/sdc (block)
    UDEV_LOG=3
    ACTION=add
    DEVPATH=/block/sdc
    SUBSYSTEM=block
    MINOR=32
    MAJOR=8
    PHYSDEVPATH=/devices/pci0000:00/0000:00:02.0/usb1/1-8/1-8:1.0/host9/target9:0:0/9:0:0:0
    PHYSDEVBUS=scsi
    SEQNUM=4349
    UDEVD_EVENT=1
    DEVTYPE=disk
    ID_VENDOR=Memorex
    ID_MODEL=TD_Classic_003C
    ID_REVISION=6.16
    ID_SERIAL=Memorex_TD_Classic_003C_0A40A4613121D997-0:0
    ID_SERIAL_SHORT=0A40A4613121D997
    ID_TYPE=disk
    ID_INSTANCE=0:0
    ID_BUS=usb
    ID_PATH=pci-0000:00:02.0-usb-0:8:1.0-scsi-0:0:0:0
    DEVNAME=/dev/sdc
    DEVLINKS=/dev/disk/by-id/usb-Memorex_TD_Classic_003C_0A40A4613121D997-0:0 /dev/disk/by-path/pci-0000:00:02.0-usb-0:8:1.0-scsi-0:0:0:0

    it seems the computer is seeing and recognizing the devices but doesn't automount them. I have tried uninstalling hal which resulted in a large mess of packages that needed to be reinstalled, but i believe I got all of them.

    Making matters worse, when I boot off the livecd, hardy recognizes and automounts all my usb devices.

    I tried to solutions set forth in this thread already and nothing seems to work.

  9. #19
    Join Date
    May 2007
    Location
    England
    Beans
    198
    Distro
    Lubuntu

    Re: Usb devices not mounted or recognised

    BUMP!
    Having the same problem, suddenly none of my USB flash drives or memory cards are detected at all.

  10. #20
    Join Date
    Mar 2008
    Location
    Rolla, MO, USA
    Beans
    74
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Usb devices not mounted or recognised

    Yeah, I had to reinstall everything from the liveCD, and now everything works. Barbaric, yes, but at least it works.

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •