Results 1 to 4 of 4

Thread: Permission problems with a NAS

  1. #1
    Join Date
    May 2008
    Beans
    4

    Permission problems with a NAS

    Hi
    I switched to ubuntu a few weeks ago and so far everything is great.
    I have a maxtor shared storage II on my network. I can mount it with no problems, and i can copy FROM it, But i can't copy TO it. it gives me a "permission denied" error.

    What can i do to be able to put files on it?

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Permission problems with a NAS

    I haven't gotten to the "saving files to" stage yet, but another thread suggested adding your user to the usershare group in /etc/group. (That'd most likely be for files shared from your Ubuntu box). How is it mounted (What command did you use?)
    Last edited by Iowan; May 23rd, 2008 at 12:37 AM.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    May 2008
    Location
    Cowtown
    Beans
    573
    Distro
    Ubuntu 8.04 Hardy Heron
    Are you prompted for credentials to login the device? Are you a guest?

    I'd suggest mounting the drive from fstab. From the terminal (ALT-F2 > gnome-terminal)

    get your group number (probably 1000, but best to check, username is your username)

    Code:
    cat /etc/group|grep username:
    Code:
    nano -w ~/.smbpasswd
    enter two lines (the user and pass you need to access the share from windows
    Code:
    shareusername
    sharepassword
    CTRL-X to save and exit

    Code:
    chmod 600 ~/.smbpasswd
    to make it readable only to you (and root)

    Code:
    sudo nano -w /etc/fstab
    add a line:

    Code:
    //sambaserver/sharename /home/username/share smbfs credentials=/home/username/.smbpasswd,uid=1000,gid=1000	0	0
    in this example do
    Code:
    mkdir ~/share
    Code:
    sudo mount /home/username/share

  4. #4
    Join Date
    May 2008
    Beans
    4

    Re: Permission problems with a NAS

    followed your steps, but at the very last part i get an error "mount error 13= permission denied"

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •