Page 7 of 65 FirstFirst ... 567891757 ... LastLast
Results 61 to 70 of 650

Thread: General MoBlock thread

  1. #61
    Join Date
    Apr 2008
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: General MoBlock thread

    Hi,

    I'm having some trouble with mobloquer, installed from the moblock-deb repositories. It won't start; when started from the terminal, it drops the message "Segmentation fault." Any help is appreciated

  2. #62
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Huh, I'm not so savvy with mobloquer. Is there anything more than this message? Which version are you using (dpkg -l mobloquer)
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  3. #63
    Join Date
    Apr 2008
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: General MoBlock thread

    Thanks for the reply . It's mobloquer 0.5.1~hardy.

    Code:
    _@_:~$ mobloquer
    Segmentation fault
    
    _@_:~$ sudo mobloquer
    [sudo] password for _: 
    Segmentation fault
    Last edited by suprfish; August 14th, 2008 at 09:59 PM.

  4. #64
    Join Date
    Apr 2008
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: General MoBlock thread

    I notice that in the mobloquer readme it says it is dependent on moblock-nfq; from apt-get it says it is dependent on moblock. Could this be causing the problem?

  5. #65
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Quote Originally Posted by suprfish View Post
    I notice that in the mobloquer readme it says it is dependent on moblock-nfq; from apt-get it says it is dependent on moblock. Could this be causing the problem?
    It' depends on moblock (0.9~rc2). But this is only because there the /etc/default/moblock file is always there.
    Further I think moblock related errors would give other output.
    Anyway, is moblock running? Try "moblock-control status" and "moblock-control test".

    Have you tried a clean reinstall yet?
    Code:
    sudo aptitude purge mobloquer
    sudo aptitude install mobloquer
    The first command makes sure all config files, such as ~/.config/mobloquer are removed.

    Otherwise I'd guess that it is a problem related to other software, e.g. Qt which mobloquer depends on.
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  6. #66
    Join Date
    Aug 2008
    Beans
    1

    Re: General MoBlock thread

    I've been trying to uninstall moblock and get the following errors.
    Code:
    The following packages will be REMOVED:
      moblock
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    After this operation, 360kB disk space will be freed.
    Do you want to continue [Y/n]? Y
    (Reading database ... 96178 files and directories currently installed.)
    Removing moblock ...
     * Stopping MoBlock moblock                                              [fail] 
    invoke-rc.d: initscript moblock, action "stop" failed.
    dpkg: error processing moblock (--remove):
     subprocess pre-removal script returned error exit status 3
    Errors were encountered while processing:
     moblock
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Initial install crapped out on nonexistent blocklists from bluetack, so I replaced them with lists from iblocklist that appeared to allow installation to complete. But after playing with mobloquer, it appeared that moblock would not stop, start, or anything. Not an iptables conflict that I know of as this is the first time I've ever installed Ubuntu, or any Linux distro, and hadn't set up any rules at all.

    Anyway, any assistance is appreciated, please be as explicit as possible because I just finished installing Linux for the first time ever about 2 hours ago. 8)

  7. #67
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    There seems to be bug in the LSB init functions (lsb-base) in hardy :-/
    I'm having a look at it to make special packages for hardy.
    Until then please try the following:
    Start MoBlock before you uninstall it.
    Either try
    Code:
    sudo moblock-control start
    or if this doesn't work try
    Code:
    sudo /usr/bin/moblock -p /etc/moblock/guarding.p2p -q 0 -t -r 10 -a 20 /var/log/moblock.log
    . Note that the latter only starts the daemon but does not insert the iptables rules - this means it should be enough to make apt/aptitude/synaptic happy but it does not give you a functional MoBlock.

    jre
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  8. #68
    Join Date
    Apr 2008
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: General MoBlock thread

    Thanks for the help, jre . Fortunately, moblock works fine (it's just mobloquer that is bugged).

  9. #69
    Join Date
    Mar 2008
    Location
    UK
    Beans
    141
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: General MoBlock thread

    I have a current problem with Moblock which I need some advice on please - I have been trying to update (as my updater says there is one update available) but when I try I keep getting an error message. I tried to remove Moblock and then reistall it and now I keep getting the message below

    -----

    terry@terry-laptop:~$ sudo aptitude install moblock
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initialising package states... Done
    Building tag database... Done
    The following packages have been automatically kept back:
    acroread-escript
    The following NEW packages will be automatically installed:
    libnetfilter-queue1 libnfnetlink0
    The following packages have been kept back:
    acroread acroread-plugins mozilla-acroread
    The following NEW packages will be installed:
    libnetfilter-queue1 libnfnetlink0
    The following packages will be upgraded:
    moblock
    1 packages upgraded, 2 newly installed, 0 to remove and 4 not upgraded.
    Need to get 19.3kB/100kB of archives. After unpacking 139kB will be used.
    Do you want to continue? [Y/n/?] y
    Writing extended state information... Done
    Get:1 http://archive.ubuntu.com hardy/universe libnfnetlink0 0.0.30-2 [12.2kB]
    Get:2 http://archive.ubuntu.com hardy/universe libnetfilter-queue1 0.0.13-1 [7042B]
    Fetched 19.3kB in 0s (59.5kB/s)
    Preconfiguring packages ...
    Selecting previously deselected package libnfnetlink0.
    (Reading database ... 240183 files and directories currently installed.)
    Unpacking libnfnetlink0 (from .../libnfnetlink0_0.0.30-2_i386.deb) ...
    Selecting previously deselected package libnetfilter-queue1.
    Unpacking libnetfilter-queue1 (from .../libnetfilter-queue1_0.0.13-1_i386.deb) ...
    Selecting previously deselected package moblock.
    Preparing to replace moblock 0.9~rc2-13~hardy (using .../moblock_0.9~rc2-16~hardy_i386.deb) ...
    * Stopping MoBlock moblock [fail]
    invoke-rc.d: initscript moblock, action "stop" failed.
    dpkg: warning - old pre-removal script returned error exit status 3
    dpkg - trying script from the new package instead ...
    * Stopping MoBlock moblock [fail]
    invoke-rc.d: initscript moblock, action "stop" failed.
    dpkg: error processing /var/cache/apt/archives/moblock_0.9~rc2-16~hardy_i386.deb (--unpack):
    subprocess new pre-removal script returned error exit status 3
    Errors were encountered while processing:
    /var/cache/apt/archives/moblock_0.9~rc2-16~hardy_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    Setting up libnfnetlink0 (0.0.30-2) ...

    Setting up libnetfilter-queue1 (0.0.13-1) ...

    Processing triggers for libc6 ...
    ldconfig deferred processing now taking place
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initialising package states... Done
    Writing extended state information... Done
    Building tag database... Done
    terry@terry-laptop:~$

    ---



    Any help and advice to just get Moblock up and running again would be appreciated.

    Thanks.

  10. #70
    Join Date
    Mar 2008
    Location
    UK
    Beans
    141
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: General MoBlock thread

    This is the error message I get through synaptic installer -

    --
    E: /var/cache/apt/archives/moblock_0.9~rc2-16~hardy_i386.deb: subprocess new pre-removal script returned error exit status 3
    --

Page 7 of 65 FirstFirst ... 567891757 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •