Page 43 of 65 FirstFirst ... 33414243444553 ... LastLast
Results 421 to 430 of 650

Thread: General MoBlock thread

  1. #421
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Although I can't imagine what is going wrong, perhaps a "sudo blockcontrol force-update" helps. This will delete all currently downloaded blocklists and start from scratch again.
    Another possibility might be that you had too many downloads from iblocklist.com, and were therefore banned temporarily (although this never happened to me, even when I made many downloads while working on the blocklist download code).
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  2. #422
    Join Date
    Sep 2010
    Location
    England
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: General MoBlock thread

    it appears to be downloading the files as i've been to /var/spool/blockcontrol/Bluetack_level1/ had a look in the download folder and there is a file in there that just cannot be extracted - which would go with the CRC error that moblocker is giving me.

    The owner of the folder above is OWNER and changing the folder permissions to my user name have no effect.

    Ill give it another go on one of the machines at work tomorrow and see if i can get it to work there

  3. #423
    Join Date
    Sep 2010
    Location
    England
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: General MoBlock thread

    I've just tested it at work and for some reason it works just fine - I'm going to reload my pc at home tonight and see what's what.... still odd though.

  4. #424
    Join Date
    Sep 2010
    Location
    England
    Beans
    12
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: General MoBlock thread

    Re-installed Ubuntu and installed MoBlock then as if by magic it works - cheers jre

  5. #425
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Glad to hear. Although I think that was a bit overkill

    I guess you were just unlucky and somehow got a coorupted list. The maintainer of iblocklist.com thinks it might be, that you just downlaoded the list from the server, while a new one was uploaded. So probably the "blockcontrol force-update" would have worked.

    Have fun!
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  6. #426
    Join Date
    May 2008
    Beans
    7

    Re: General MoBlock thread

    My install of moblock 0.9rc2 (compiled OK from source, and installed OK; I can run 'moblock' from the terminal and get its usage options) and blockcontrol 1.6.12 is refusing to start on Ubuntu 10.04.1 (PPC).

    Looking at blockcontrol.log, I just see:


    Code:
    2010-09-11 21:49:05 IST End: blockcontrol force-update
    2010-09-11 21:50:01 IST Begin: blockcontrol start
    Building blocklist...    ...done.
     * Warning: Could not load kernel module xt_iprange, continuing anyway.
     * Whitelisting IP ranges with the allow list will not work.
     * The allow list is in /etc/blockcontrol/allow.p2p.
    Inserting iptables ...
    iptables: Chain already exists.
       ...fail!
       ...fail!

    And nothing else. Is there a way for me to see what's causing the "...fail!" messages? Syslog isn't showing anything.

  7. #427
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    The log says that blockcontrol can't insert the necessary iptables rules/chains because they were already inserted previously. You can remove them by issuing a "blockcontrol stop". Verify that they are removed with a "blockcontrol status" - in that output you should see no reference to "blockcontrol" at all. Then try a "blockcontrol start" again.

    After solving that problem I guess you will still experience another problem, which is the original reason for the error message you just got.

    Do you use a custom built kernel? (I guess so because of the warning message about xt_iprange. Please note that this is eally just a warning, but does not prevent moblock from working. But it still indicates something special about your system). Make sure that you enable (as modules) the necessary netfilter support. See the README for details.

    Why did you compile your own version? I recommend to just install from moblock-deb.sourceforge.net. See also the guide at https://help.ubuntu.com/community/MoBlock

    Where did you get your sources from? The original moblock source from berlios.de needs patching in order to work. Even if you want to compile on your own, I recommend to use the source from moblock-deb.sf.net
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  8. #428
    Join Date
    May 2008
    Beans
    7

    Re: General MoBlock thread

    I built the package using the instructions from moblock-deb (I'm running on PPC, and there doesn't seem to be a package available in apt), ran blockcontrol stop, then start, then status, and now it's fine. I didn't even get the warning about the missing kernel module. Odd, but it's running, and I'm seeing hits in the log.

  9. #429
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Indeed I don't offer PPC packages, but you just made everything right. So great to hear that it works on PPC. Just strange that you had those problems in the beginning.
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  10. #430
    Join Date
    Sep 2010
    Beans
    4

    Angry Moblock problem ??

    Hi guys I've just registered to ask for your help, I'm a newbie of Ubuntu 10.4 and after a few weeks finally got Moblock installed, It says its running but in the log panel I expected to see running lists of ip's it is blocking (like PG2).........So I enabled blocklist microsoft and restarted MB and went to MS website expecting to get blocked

    Not really sure whats going on and apologies if this has been posted already.....also when used to use PG2 my RSS for BBC news feed used to fail ! so I knew it was doing its job, this is just confusing me as it doesn't seem to be doing anything, I've had just one item on the log which was yahoo.....any advice VERY much appreciated

Page 43 of 65 FirstFirst ... 33414243444553 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •