Page 21 of 65 FirstFirst ... 11192021222331 ... LastLast
Results 201 to 210 of 650

Thread: General MoBlock thread

  1. #201
    Join Date
    Sep 2005
    Location
    Belgrade, Serbia
    Beans
    40

    Re: General MoBlock thread

    Mobloquer stop working on me!..
    Everything was OK... mobloquer was working perfectly but now I get
    Segmentation fault on console when I started it. Does anyone have the same problem?
    I cannot connect this Segmentation fault with anything I do recently... I only update packages regulary.
    Tried to remove .config/mobloquer dir from my HOMEDIR but that doesn`t do the trick.
    Any ideas?
    UBUNTU !

  2. #202
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Sorry, no. You already did what I would have suggested (remove ~/.config/mobloquer). Perhaps reboot. You are the first and only who has reported this problem currently.
    Can you post the complete console output?
    What's your Ubuntu version?
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  3. #203
    Join Date
    Sep 2005
    Location
    Belgrade, Serbia
    Beans
    40

    Arrow Re: General MoBlock thread

    OK... here is some details...
    I installed from repo...
    Code:
    deb http://moblock-deb.sourceforge.net/debian intrepid main
    so you see that I'm using Intrepid 8.10
    Console output is rather poor... maybe there is option to increase verbosity?
    Code:
    dan@GX610:~$ mobloquer
    ** Warning: Prefered file "/usr/bin/kdesu" could not be found, using "/usr/bin/gksu" instead
    Segmentation fault
    moblock and moblock-control for itselfs works like a charm but mobloquer even purged and reinstalled, don't.

    oh.. and here is line from dmesg output...
    Code:
    [25406.992283] mobloquer[14520]: segfault at 5b ip b7475c72 sp bfa3c610 error 6 in libQtCore.so.4.4.3[b73db000+225000]
    Last edited by freedom; March 7th, 2009 at 10:23 PM.
    UBUNTU !

  4. #204
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Unfortunately that's beyond my knowledge.

    I assume /usr/bin/gksu exists and is executable!?

    It also might be a bug in libqt-core. But I guess most mobloquer users do use Ubuntu intrepid, and I still haven't received other bug reports ...

    For future reference please post
    Code:
    dpkg -l "libqt*"
    . Do you remember if there was any update of libqt lately?
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  5. #205
    Join Date
    Sep 2005
    Location
    Belgrade, Serbia
    Beans
    40

    Re: General MoBlock thread

    Yes, gksu exist, kdesu doesn't but there is kdesudo. Maybe you should use kdesudo for administrative privileges.
    Here is the oputput of dpkg...
    Code:
    GX610:~$ dpkg -l "libqt*"
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name                          Version                       Description    
    +++-=============================-=============================-==========================================================================
    un  libqt-perl                    <none>                        (no description available)                                                
    un  libqt0-ruby1.8                <none>                        (no description available)                                                
    un  libqt3                        <none>                        (no description available)                                                
    un  libqt3-helper                 <none>                        (no description available)                                                
    ii  libqt3-mt                     3:3.3.8-b-5ubuntu1            Qt GUI Library (Threaded runtime version), Version 3                      
    un  libqt3-mt-mysql               <none>                        (no description available)                                                
    un  libqt3-mt-odbc                <none>                        (no description available)                                                
    un  libqt3-mt-psql                <none>                        (no description available)                                                
    un  libqt3c-mt                    <none>                        (no description available)                                                
    un  libqt3c102-mt                 <none>                        (no description available)                                                
    ii  libqt4-assistant              4.4.3-0ubuntu1.2              Qt 4 assistant module                                                     
    ii  libqt4-core                   4.4.3-0ubuntu1.2              transitional package for Qt 4 core non-GUI runtime libraries              
    ii  libqt4-dbus                   4.4.3-0ubuntu1.2              Qt 4 D-Bus module                                                         
    ii  libqt4-designer               4.4.3-0ubuntu1.2              Qt 4 designer module                                                      
    un  libqt4-dev                    <none>                        (no description available)                                                
    ii  libqt4-gui                    4.4.3-0ubuntu1.2              transitional package for Qt 4 GUI runtime libraries                       
    ii  libqt4-help                   4.4.3-0ubuntu1.2              Qt 4 help module                                                          
    ii  libqt4-network                4.4.3-0ubuntu1.2              Qt 4 network module
    ii  libqt4-opengl                 4.4.3-0ubuntu1.2              Qt 4 OpenGL module
    ii  libqt4-qt3support             4.4.3-0ubuntu1.2              Qt 3 compatibility library for Qt 4
    ii  libqt4-script                 4.4.3-0ubuntu1.2              Qt 4 script module
    ii  libqt4-sql                    4.4.3-0ubuntu1.2              Qt 4 SQL module
    un  libqt4-sql-ibase              <none>                        (no description available)
    ii  libqt4-sql-mysql              4.4.3-0ubuntu1.2              Qt 4 MySQL database driver
    un  libqt4-sql-odbc               <none>                        (no description available)
    un  libqt4-sql-psql               <none>                        (no description available)
    ii  libqt4-sql-sqlite             4.4.3-0ubuntu1.2              Qt 4 SQLite 3 database driver
    un  libqt4-sql-sqlite2            <none>                        (no description available)
    ii  libqt4-svg                    4.4.3-0ubuntu1.2              Qt 4 SVG module
    ii  libqt4-test                   4.4.3-0ubuntu1.2              Qt 4 test module
    ii  libqt4-webkit                 4.4.3-0ubuntu1.2              Qt 4 WebKit module
    ii  libqt4-xml                    4.4.3-0ubuntu1.2              Qt 4 XML module
    ii  libqt4-xmlpatterns            4.4.3-0ubuntu1.2              Qt 4 XML patterns module
    ii  libqtcore4                    4.4.3-0ubuntu1.2              Qt 4 core module
    ii  libqtgui4                     4.4.3-0ubuntu1.2              Qt 4 GUI module
    Well, maybe the problem is with latest libqt in KDE4 update... 4.2.1
    UBUNTU !

  6. #206
    Join Date
    Sep 2005
    Location
    Belgrade, Serbia
    Beans
    40

    Re: General MoBlock thread

    NO. It is not KDE 4.2.1 update...
    I have installed mobloquer on other machine and perform an update and everything worked fine... before and after update.
    Strange thing that both machines have pretty much the same things installed and KDE4 as desktop environment but still on the first one mobloquer stops to work (and it has been worked for some time).

    If anyone knows or maybe if developer of mobloquer read this...
    Is there an option to have verbose output on errors rather than just "Segmentation fault" ?
    UBUNTU !

  7. #207
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Quote Originally Posted by freedom View Post
    If anyone knows or maybe if developer of mobloquer read this...
    Is there an option to have verbose output on errors rather than just "Segmentation fault" ?
    With the next release I will (try to) provide a mobloquer-dbg package. Then it will be possible to make a backtrace with dbg. I hope to do this this weekend...
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  8. #208
    Join Date
    Mar 2009
    Beans
    3

    Re: General MoBlock thread

    Hi all. I'm having the same problem...

    I installed both moblock and mobloquer

    Code:
    sudo apt-get install moblock mobloquer
    I tried uninstalling and reinstalling, also tried deleting the configuration file but I still have the same problem

    Code:
    ~$ mobloquer
    ** Warning: Prefered file "/usr/bin/kdesu" could not be found, using "/usr/bin/gksu" instead 
    Segmentation fault
    dmesg output:

    Code:
    [12994.753398] mobloquer[22111]: segfault at 5b ip b74cfc72 sp bff922e0 error 6 in libQtCore.so.4.4.3[b7435000+225000]
    dpkg -l "libqt*" output:

    Code:
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name                       Version                    Description
    +++-==========================-==========================-====================================================================
    un  libqt-perl                 <none>                     (no description available)
    un  libqt3                     <none>                     (no description available)
    un  libqt3-helper              <none>                     (no description available)
    ii  libqt3-mt                  3:3.3.8-b-5ubuntu1         Qt GUI Library (Threaded runtime version), Version 3
    ii  libqt3-mt-mysql            3:3.3.8-b-5ubuntu1         MySQL database driver for Qt3 (Threaded)
    un  libqt3-mt-odbc             <none>                     (no description available)
    un  libqt3-mt-psql             <none>                     (no description available)
    un  libqt3-mysql               <none>                     (no description available)
    un  libqt3c-mt                 <none>                     (no description available)
    un  libqt3c-mt-mysql           <none>                     (no description available)
    un  libqt3c102-mt              <none>                     (no description available)
    un  libqt3c102-mt-mysql        <none>                     (no description available)
    un  libqt4-core                <none>                     (no description available)
    ii  libqt4-dbus                4.4.3-0ubuntu1.2           Qt 4 D-Bus module
    ii  libqt4-designer            4.4.3-0ubuntu1.2           Qt 4 designer module
    un  libqt4-dev                 <none>                     (no description available)
    un  libqt4-gui                 <none>                     (no description available)
    ii  libqt4-network             4.4.3-0ubuntu1.2           Qt 4 network module
    ii  libqt4-qt3support          4.4.3-0ubuntu1.2           Qt 3 compatibility library for Qt 4
    ii  libqt4-script              4.4.3-0ubuntu1.2           Qt 4 script module
    ii  libqt4-sql                 4.4.3-0ubuntu1.2           Qt 4 SQL module
    un  libqt4-sql-ibase           <none>                     (no description available)
    ii  libqt4-sql-mysql           4.4.3-0ubuntu1.2           Qt 4 MySQL database driver
    un  libqt4-sql-odbc            <none>                     (no description available)
    un  libqt4-sql-psql            <none>                     (no description available)
    un  libqt4-sql-sqlite          <none>                     (no description available)
    un  libqt4-sql-sqlite2         <none>                     (no description available)
    ii  libqt4-svg                 4.4.3-0ubuntu1.2           Qt 4 SVG module
    ii  libqt4-xml                 4.4.3-0ubuntu1.2           Qt 4 XML module
    ii  libqtcore4                 4.4.3-0ubuntu1.2           Qt 4 core module
    ii  libqtgui4                  4.4.3-0ubuntu1.2           Qt 4 GUI module
    Hope this information helps.

  9. #209
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Currently I have no clue what's going on.
    But with the next update there will definitely be a mobloquer-dbg package. I've already tested it locally.
    If your problems persist, you can make a backtrace with "gdb mobloquer", followed by "run" on the gdb prompt.

    EDIT 1: I guess you are on intrepid, too?

    EDIT 2: At least the dependencies of the new packages have changed:
    Code:
    mobloquer_0.6-1~pre3+intrepid_i386.deb:
    Depends: libc6 (>= 2.1.3), libgcc1 (>= 1:4.1.1), libqtcore4 (>= 4.4.3), libqtgui4 (>= 4.4.3), libstdc++6 (>= 4.1.1), moblock, blockcontrol
    
    mobloquer_0.5-2+intrepid_i386.deb 
    Depends: libc6 (>= 2.3.4), libgcc1 (>= 1:4.1.1), libqtcore4 (>= 4.4.1), libqtgui4 (>= 4.4.1), libstdc++6 (>= 4.1.1), moblock, moblock-control
    Last edited by jre; March 15th, 2009 at 06:30 PM.
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  10. #210
    Join Date
    Mar 2009
    Beans
    2

    Question Re: General MoBlock thread

    I am a linux newbie and have had issues installing moblock, I followed the howto but after rebooting when I do:

    simon@SERVER:~$ sudo moblock-control test
    [sudo] password for simon:
    Testing MoBlock:
    * MoBlock is not running.


    simon@SERVER:~$ sudo moblock-control status
    Current IPv4 iptables rules (this may take a while):

    Chain INPUT (policy ACCEPT 2848K packets, 708M bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 3374K packets, 2253M bytes)
    pkts bytes target prot opt in out source destination

    Chain moblock_fw (0 references)
    pkts bytes target prot opt in out source destination
    0 0 NFQUEUE all -- * * 0.0.0.0/0 0.0.0.0/0 NFQUEUE num 92

    Chain moblock_in (0 references)
    pkts bytes target prot opt in out source destination
    0 0 NFQUEUE all -- * * 0.0.0.0/0 0.0.0.0/0 NFQUEUE num 92

    Chain moblock_out (0 references)
    pkts bytes target prot opt in out source destination
    0 0 RETURN tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:443
    0 0 RETURN tcp -- * * 0.0.0.0/0 0.0.0.0/0 tcp dpt:80
    0 0 NFQUEUE all -- * * 0.0.0.0/0 0.0.0.0/0 NFQUEUE num 92

    Current IPv6 iptables rules (this may take a while):

    Chain INPUT (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Please check if the above printed iptables rules are correct!

    * moblock is not running.


    And having tried a number of times to start, stop, restart, etc I get this in my log:

    simon@SERVER:~$ cat /var/log/moblock-control.log
    2009-03-17 21:01:24 GMT Begin: moblock-control start
    Building blocklist... Updating TBG_Primary_Threats... done.
    Extracting TBG_Primary_Threats, detected gz...done.
    Updating TBG_General_Corporate_Ranges... done.
    Extracting TBG_General_Corporate_Ranges, detected gz...done.
    Updating TBG_Business_ISPs... done.
    Extracting TBG_Business_ISPs, detected gz...done.
    Updating TBG_Search_Engines... done.
    Extracting TBG_Search_Engines, detected gz...done.
    Updating TBG_Hijacked... done.
    Extracting TBG_Hijacked, detected gz...done.
    Updating TBG_Bogon... done.
    Extracting TBG_Bogon, detected gz...done.
    Updating Bluetack_proxy... done.
    Extracting Bluetack_proxy, detected gz...done.
    Updating Bluetack_dshield... done.
    Extracting Bluetack_dshield, detected gz...done.
    [ OK ]
    Inserting iptables ...iptables v1.3.8: invalid port/service `vnc' specified
    Try `iptables -h' or 'iptables --help' for more information.
    [fail]
    2009-03-17 21:09:43 GMT Begin: moblock-control start
    Inserting iptables ...iptables: Chain already exists
    [fail]
    2009-03-17 21:18:59 GMT Begin: moblock-control start
    Inserting iptables ...iptables: Chain already exists
    ...fail!
    2009-03-17 21:19:05 GMT Begin: moblock-control start
    Inserting iptables ...iptables: Chain already exists
    ...fail!
    2009-03-17 21:22:15 GMT Begin: moblock-control stop
    Deleting iptables ...iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    [fail]
    * There occured some errors during the deletion of the iptables rules.
    * The most common reason for this is that they did not exist, because MoBlock
    * was not running. In this case you don't have to worry.
    * But if MoBlock was running there is some problem. Most probably you have
    * installed another firewall application that did delete the iptables rules.
    * A "moblock-control restart" will then fix the situation.
    Executing /etc/moblock/iptables-custom-remove.sh ... [ OK ]
    Stopping MoBlock ... [ OK ]
    2009-03-17 21:22:15 GMT End: moblock-control stop
    2009-03-17 21:55:40 GMT Begin: moblock-control start
    Inserting iptables ...iptables v1.3.8: invalid port/service `vnc' specified
    Try `iptables -h' or 'iptables --help' for more information.
    [fail]
    2009-03-18 07:01:11 GMT Begin: moblock-control start
    Inserting iptables ...iptables: Chain already exists
    [fail]
    2009-03-18 07:03:31 GMT Begin: moblock-control restart
    Deleting iptables ...iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    iptables: No chain/target/match by that name
    [fail]
    * There occured some errors during the deletion of the iptables rules.
    * The most common reason for this is that they did not exist, because MoBlock
    * was not running. In this case you don't have to worry.
    * But if MoBlock was running there is some problem. Most probably you have
    * installed another firewall application that did delete the iptables rules.
    * A "moblock-control restart" will then fix the situation.
    Executing /etc/moblock/iptables-custom-remove.sh ... [ OK ]
    Stopping MoBlock ... [ OK ]
    Inserting iptables ...iptables v1.3.8: invalid port/service `vnc' specified
    Try `iptables -h' or 'iptables --help' for more information.
    [fail]
    2009-03-18 07:04:13 GMT Begin: moblock-control update
    Updating blocklists ...
    Updating TBG_Primary_Threats... done.
    Extracting TBG_Primary_Threats, detected gz...done.
    Updating TBG_General_Corporate_Ranges... done.
    Extracting TBG_General_Corporate_Ranges, detected gz...done.
    Updating TBG_Business_ISPs... done.
    Extracting TBG_Business_ISPs, detected gz...done.
    Updating TBG_Search_Engines... done.
    Extracting TBG_Search_Engines, detected gz...done.
    Updating TBG_Hijacked... done.
    Extracting TBG_Hijacked, detected gz...done.
    Updating TBG_Bogon... done.
    Extracting TBG_Bogon, detected gz...done.
    Updating Bluetack_proxy... done.
    Extracting Bluetack_proxy, detected gz...done.
    Updating Bluetack_dshield... done.
    Extracting Bluetack_dshield, detected gz...done.
    Blocklists updated.
    * MoBlock is not running, doing nothing.
    2009-03-18 07:06:10 GMT End: moblock-control update
    2009-03-18 07:12:15 GMT Begin: moblock-control start
    Building blocklist... [ OK ]
    Inserting iptables ...iptables: Chain already exists
    [fail]


    Is anyone able to help me?

    Thanks

Page 21 of 65 FirstFirst ... 11192021222331 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •