Page 16 of 65 FirstFirst ... 6141516171826 ... LastLast
Results 151 to 160 of 650

Thread: General MoBlock thread

  1. #151
    Join Date
    Nov 2007
    Location
    Germany, Stuttgart
    Beans
    3
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: General MoBlock thread

    Hey, I just wanted to know why Moblock and Mobloquer are not listed in the Synaptic Package Manager. I use Ubuntu 8.10 64 Bit Alternate Version (I need RAID support). The installation process would have been much painless ... I just can't get used with this terminal stuff. Windows screwed my head I guess...


    Btw Mobloquer seems to not work well with custom themes for Ubuntu. It's all black for me. I mean everything is black, though I can read the written stuff and see some borders...
    Last edited by nidya; December 6th, 2008 at 07:04 PM.

  2. #152
    Join Date
    Feb 2006
    Location
    Hatboro, PA
    Beans
    2,533
    Distro
    Ubuntu Development Release

    Re: General MoBlock thread

    Quote Originally Posted by jre View Post
    What do you have in your /etc/moblock/blocklists.list?

    The lists from bluetack are indeed partly down, atm. See http://www.bluetack.co.uk/forums/index.php

    I'm working on a release which allows php redirects. Then all lists by iblocklist will be supported and I'll change default lists to TBG instead of bluetack.
    In the meantime you can use the lists from http://tbg.iblocklist.com/Lists or just wait until the bluetack lists are updated again.
    thanks for the info... how exactly would i set-up moblock to use the tbq lists instead of bluetack? i tried simply replacing the bluetack with those from tbq in blocklists.list, but i get an error in mobloquer about not being able to find bluetack.
    Asus EeePC 1005HA: ElementaryOS Luna | Asus X501A: Windows 8.1 & Ubuntu 14.04 Trusty Tahr | Apple iMac G4: Ubuntu 14.04 Trusty Tahr | LG Optimus F3: Psycho Billy ROM | Nexus 10 Cyanogenmod 11

  3. #153
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Quote Originally Posted by nidya View Post
    Hey, I just wanted to know why Moblock and Mobloquer are not listed in the Synaptic Package Manager.
    I created the packages moblock, moblock-control and mobloquer personally. I'm no Ubuntu or Debian developer and have not tried to add my packages to the official repositories. If I would do so I would prefer the Debian repo, because this means they will get to Ubuntu automatically.

    Although I put no efforts to this topic, there's already a "request for packaging" here: https://bugs.launchpad.net/ubuntu/+bug/109822

    Further please remember that using this software will always be more then just installing it. You can run in serious network problems, if you don't remember that MoBlock might just be blocking big parts of your internet access.

    Quote Originally Posted by nidya View Post
    Btw Mobloquer seems to not work well with custom themes for Ubuntu. It's all black for me. I mean everything is black, though I can read the written stuff and see some borders...
    The creator of mobloquer unfortunately had to stop his development efforts, due to personal time restraints. I'll note your report down, but can't promise anything ...

    Quote Originally Posted by moore.bryan View Post
    thanks for the info... how exactly would i set-up moblock to use the tbq lists instead of bluetack? i tried simply replacing the bluetack with those from tbq in blocklists.list, but i get an error in mobloquer about not being able to find bluetack.

    Thanks for reporting this. This origins from a check if the update server is accessible at all, which is executed before the updating. So add to your /etc/default/moblock:
    Code:
    TESTHOST="iblocklist.com"
    Seems as if I have to make a minor update today to reflect these changes.

    EDIT: Done. I released a version (1.1-1) which uses tbg.iblocklist.com URLs and also has the new TESTHOST. Funnily, since today bluetack has a new server again.
    Last edited by jre; December 7th, 2008 at 10:22 PM.
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  4. #154
    Join Date
    Oct 2007
    Beans
    62

    Re: General MoBlock thread

    Ive installed moblock and i whitelisted my lan, but here is tyhe deal im useing cablevision as my isp and moblock keeps blocking that ip and also blocks microsoft (for msn in pidgin) and i was wondering if it was ok to whitelist the ip for my isp and the msn ip? because if i leave it it wont let me go on the internet but if i whitelist it it will let me go on the internet like websurfing ect. thanks

  5. #155
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: General MoBlock thread

    Quote Originally Posted by dbzkid View Post
    Ive installed moblock and i whitelisted my lan, but here is tyhe deal im useing cablevision as my isp and moblock keeps blocking that ip and also blocks microsoft (for msn in pidgin) and i was wondering if it was ok to whitelist the ip for my isp and the msn ip? because if i leave it it wont let me go on the internet but if i whitelist it it will let me go on the internet like websurfing ect. thanks
    It's OK to whitelist both Ips.

  6. #156
    Join Date
    Dec 2008
    Beans
    1

    Re: General MoBlock thread

    I'm having a slight issue getting adding the gpg key to the apt key ring.

    Code:
    --keyserver wwwkeys.eu.pgp.net --recv 9072870B
    gpg: requesting key 9072870B from hkp server wwwkeys.eu.pgp.net
    gpg: can't open `/home/bobo/.gnupg/pubring.gpg'
    gpg: keydb_get_keyblock failed: eof
    gpg: no writable keyring found: eof
    gpg: error reading `[stream]': general error
    gpg: Total number processed: 0
    If anyone could help me figure out what is causing this and a way to fix it that would be awesome and much appreciated.

  7. #157
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Quote Originally Posted by Bobomonkey View Post
    I'm having a slight issue getting adding the gpg key to the apt key ring.
    I'm not very common with this, but what command did you issue?
    This should work:
    Code:
    gpg --keyserver wwwkeys.eu.pgp.net --recv 9072870B
    gpg --export --armor 9072870B | sudo apt-key add -
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  8. #158
    Join Date
    Nov 2008
    Beans
    28

    Re: General MoBlock thread

    I'd like to post this here since this is the "General Moblock thread."

    The installation of moblock went fine up until when the package configuration pops up inside the terminal. I mean there is no other menus or buttons except this "<Ok>", how dyou get out from that??? Because if I do <ESC> the installation seems to backtrack and produces these errors:

    dpkg: error processing moblock-control (--configure):
    subprocess post-installation script returned error exit status 10
    ...
    ...
    Errors were encountered while processing:
    moblock-control
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover:
    ...
    dpkg: error processing moblock-control (--configure):
    subprocess post-installation script returned error exit status 10
    Errors were encountered while processing:
    moblock-control
    ...
    .. and then tries to recover, then pops up the package configuration window again. (but since I don't know any other exit commands, and the OK button seems isnt working..), I guess if only I could close down the package configuration window normally, maybe it won't produce any errors.
    Last edited by unf4b1x; December 18th, 2008 at 09:30 PM.

  9. #159
    Join Date
    Jan 2007
    Beans
    770

    Re: General MoBlock thread

    Just press the "OK".

    This is a so called "debconf" question. If your debconf interface doesn't support your mouse you have to use your keyboard: hit the "TAB" key until "OK" is highlighted and then press "RETURN".

    You may also do a "sudo dpkg-reconfigure debconf" and select "Gnome" as your interface. Then you can use your mouse for debconf questions.
    Please post your logfiles and output of commands wrapped in code tags:
    Code:
    [code]output[/code]
    Co-author of PeerGuardian Linux (pgl). Maintainer of the pgl package repositories for Debian and Ubuntu.

  10. #160
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: General MoBlock thread

    you might want to add a bit to the wiki page about portforwards, there's no mention of the WHITE_TCP_IN= option, which i needed to add to /etc/default/moblock to get my hosted webpages (ntop and webmin), ftpd and sshd working again, as well as torrent ports, which is the whole point of moblock anyway, right?

    Code:
    cat /etc/default/moblock
    # moblock.default - default configuration file for moblock-control
    
    # In this file you can put any configuration variable from moblock.conf
    # (/etc/moblock/moblock.conf). Values in moblock.conf will be overwritten by
    # values in this file (moblock.default).
    
    # Do a "moblock-control restart" when you have edited this file.
    WHITE_TCP_OUT="1:65535"
    WHITE_TCP_IN="20-22 3000 10000 20000:20009"
    WHITE_IP_IN="20x.x.x.x/29"
    WHITE_IP_OUT="20x.x.x.x/29"
    also, by default, moblock seems to assume your subnet mask is /24, and whitelists that as the local lan. not so much a problem if you're on a smaller subnet like my /29, but perhaps an issue if you're on a larger subnet like a /23 or /16. i guess that's an upstream bug

Page 16 of 65 FirstFirst ... 6141516171826 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •