Results 1 to 8 of 8

Thread: [SOLVED] Slow "System > quit" dialog

  1. #1
    Join Date
    Jan 2006
    Location
    Norway
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Cool [SOLVED] Slow "System > quit" dialog

    Title says it all. When i choose system > quit in the menus, the comp will freeze for roughly 30 seconds, and the dialog pops up. It only happens once, and all subsequent quit-dialogs pops up immediately.

    This is obviously quite irritating, and if anyone else have had the problem, please post so here, even if you don't have a solution.

    tl;dr: quit dialog makes the comp freeze, solution appreciated.

    Fairly hi-spec computer too, so it isn't because of the lack of resources.
    If global warming is caused by lack of pirates , all should be doing what they can to save the planet

  2. #2
    Join Date
    Jun 2006
    Location
    Solihull, UK
    Beans
    1,413

    Re: Slow "System > quit" dialog

    Have you made any customizations to your GNOME session that involve things like removing certain services or startup programs?

  3. #3
    Join Date
    Mar 2008
    Location
    Argentina
    Beans
    9

    Re: Slow "System > quit" dialog

    Enable POWER MANAGER under System->Preferences->Sessions. Then restart.

  4. #4
    Join Date
    Jun 2006
    Location
    Solihull, UK
    Beans
    1,413

    Re: Slow "System > quit" dialog

    That's what I was thinking

  5. #5
    Join Date
    Mar 2006
    Beans
    1,435
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Slow "System > quit" dialog

    I have the same problem, but it takes about a minute before anything happens..
    And that is why I prefer "sudo halt -h" for shutting down the computer, or Ctrl-Alt-Backspace, and "Shut Down" from there.

    Thanks for the suggestion. I will try to enable the power manager, Which I think I have disabled.
    _______________
    - anaconda

  6. #6
    Join Date
    Jun 2006
    Location
    Solihull, UK
    Beans
    1,413

    Re: Slow "System > quit" dialog

    I'm pretty sure disabling gnome-power-manager will have quite a noticeable effect. AFAIK, gnome-power-manager is a core component on your desktop, so you should leave it running anyway. When you click the log-out button, it tries to talk to g-p-m over DBUS to check power options so it knows what buttons to put in the dialog (suspend / hibernate etc). If it isn't running, it will take a long time

  7. #7
    Join Date
    Mar 2006
    Beans
    1,435
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Slow "System > quit" dialog

    THANK YOU ALL!!

    I thought that this problem was related to my USB-TV-card, which has caused all the previous versions of ubuntu to not be able to shutdown AT ALL if the TV-card was connected,
    So I didn't even try to seach solutions for shutdown problems anymore..

    Wow. now it works, AND Hardy even shuts down with my TV-card connected!!! Unbeliavable!!

    THANKS ;D
    Last edited by anaconda; May 22nd, 2008 at 08:13 PM.
    _______________
    - anaconda

  8. #8
    Join Date
    Jan 2006
    Location
    Norway
    Beans
    Hidden!
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Slow "System > quit" dialog

    Was the gnome-power-manager for me too. And here I thought I made my system more responsive by disabling session-startups
    If global warming is caused by lack of pirates , all should be doing what they can to save the planet

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •