Results 1 to 4 of 4

Thread: Bad network card performance

  1. #1
    Join Date
    Mar 2007
    Beans
    8

    Angry Bad network card performance

    I'm using a Belkin 802.11g Wireless card, and the connection keeps dropping in and out, seemingly as if the signal is poor.

    However, I have a dual boot machine, and annoyingly there seems to be no problem whatsoever getting a signal in windows XP.

    How is that even possible? I thought if it were a driver issue then it would not work all the time, not only some times. Can the driver affect the performance?

    I have recently upgraded to ubuntu 8, but i started having this problem a few weeks before the upgrade. I tend to use Windows now whenever I need to get online (like now).

    Any suggestions?

    Thanks.

  2. #2
    Join Date
    May 2005
    Location
    Lyon, France
    Beans
    916
    Distro
    Ubuntu Development Release

    Re: Bad network card performance

    if you are using a restricted driver from ubuntu, try using windows driver (with ndiswrapper) or vice-versa.

  3. #3
    Join Date
    Oct 2007
    Location
    Chennai, India
    Beans
    3,798
    Distro
    Ubuntu Development Release

    Re: Bad network card performance

    Quote Originally Posted by thedarkleaf View Post
    I'm using a Belkin 802.11g Wireless card, and the connection keeps dropping in and out, seemingly as if the signal is poor.
    Try turning off power saving on the wireless device:
    Code:
    sudo iwconfig wlan0 power off txpower fixed
    Replace wlan0 with your actual wireless interface.
    Cheers,PRShah
    Make your own: Ubuntu, Kubuntu, Xubuntu, Mythbuntu All-in-One Live DVD
    "I never make mistakes; I thought I did, once.. but I was wrong."

  4. #4
    Join Date
    Mar 2007
    Beans
    8

    Talking Re: Bad network card performance

    Thanks, I changed to using the windows driver with ndiswrapper, and since rebooting haven't been disconnected at all. If it starts to happen I'll post again, but if not we can assume all went well! Thanks!

    ps: i tried switching the power saving off as well, but my device apparenlty doesn't support that feature. Thanks for the idea though.

    Cheers!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •