I have a Dell E1505 running Ubuntu and have an older prism 2.5 PCMCIA card I want to use. The problem is the E1505 only has an ExpressCard slot. I was looking at some adapters that either connect to the USB port or ExpressCard slot. Does anyone know if these adapters have linux support. I saw some for 32-bit cards but none that are 16-bit that say they support Linux. Or if anyone has any other workaround would be helpful, Thanks.