Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Nice font rendering in 8.04 Hardy

  1. #1
    Join Date
    May 2007
    Beans
    7

    Lightbulb Nice font rendering in 8.04 Hardy

    It is pretty easy, all libraries as freetype, cairo, libxft are allready patched with all that LCD-cleartype-subpixel-autohint stuff. We need just turn it on, because they are disabled by default. Just adjust symlinks in /etc/fonts/conf.d to apropriate files in /etc/fonts/conf.avail - look at left pane in mc to see what should be symlinked.



    Here you can compare default rendering to MS Windows rednering, windows fonts doesn't look good, shapes and size are wrong.



    After symlinking correct settings they now apear very close to windows rendering.



    Another screenshot with font settings window as I like it.


  2. #2
    Join Date
    Jan 2007
    Location
    $here ? $here : $there
    Beans
    3,717
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nice font rendering in 8.04 Hardy

    Font settings are very subjective. I do think your fonts look nice but it's impossible to say that particular font settings are, "The finest font settings available to humanity". I like the inclusion of contrasting screenshots though. Like going to an optometrist, it's difficult to decide whether 1 or 2 is better without seeing them side by side.
    Don't try to make something "fast" until you are able to quantify "slow".

  3. #3

    Re: Nice font rendering in 8.04 Hardy

    hey i have been looking for this for a long time. can you explain it more clearly? How we should do do it?
    .

  4. #4
    Join Date
    Apr 2006
    Location
    Costa Rica
    Beans
    60
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Nice font rendering in 8.04 Hardy

    Quote Originally Posted by bekirserifoglu View Post
    can you explain it more clearly? How we should do do it?
    yes please!

  5. #5
    Join Date
    May 2007
    Beans
    7

    Re: Nice font rendering in 8.04 Hardy

    Ok, so more descriptive guide for beginers is here. It assumes you are logged in terminal as root, if not type sudo before each rm and ln commands. It makes also backup of /etc/fonts directory if something goes wrong.


    Code:
    root@hardy:~# cd /etc/fonts
    root@hardy:/etc/fonts# tar czf /tmp/etc-fonts-backup.tgz * 
    root@hardy:/etc/fonts# cd conf.d
    root@hardy:/etc/fonts/conf.d# rm 10-antialias.conf 10-hinting-medium.conf 10-no-sub-pixel.conf 70-no-bitmaps.conf
    root@hardy:/etc/fonts/conf.d# ln -s ../conf.avail/10-autohint.conf 10-autohint.conf
    root@hardy:/etc/fonts/conf.d# ln -s ../conf.avail/10-hinting-full.conf 10-hinting-full.conf
    root@hardy:/etc/fonts/conf.d# ln -s ../conf.avail/10-sub-pixel-rgb.conf 10-sub-pixel-rgb.conf
    root@hardy:/etc/fonts/conf.d# ln -s ../conf.avail/70-yes-bitmaps.conf 70-yes-bitmaps.conf
    Now just CTRL+ALT+Backspace or reboot, and go to System -> Preferences -> Appearance, click Fonts tab, click Details and set properties as you see on 4th screenshot. Now you should see changes.

  6. #6
    Join Date
    Jul 2006
    Location
    Here
    Beans
    9,689

    Re: Nice font rendering in 8.04 Hardy

    basically your doing manually what-> sudo dpkg-reconfigure fontconfig-config
    does.

    i choose:

    autohinter
    automatic
    yes

    in most cases you want "no" for bitmaps, but i'm using it for other languages, so i made a ~/.fonts.conf file to straighten out the crappy ms fonts.

    Code:
    <?xml version="1.0"?>
    <!DOCTYPE fontconfig SYSTEM "fonts.dtd">
    <fontconfig>
    
    <match target="pattern" >
     <test name="family" qual="any" >
     <string>Helvetica</string>
     </test>
     <edit mode="assign" name="family" >
     <string>Nimbus Sans</string>
     </edit>
    </match>
    
    <match target="pattern" >
     <test name="family" qual="any" >
     <string>Verdana</string>
     </test>
     <edit mode="assign" name="family" >
     <string>Nimbus Sans</string>
     </edit>
    </match>
    
    <match target="pattern" >
     <test name="family" qual="any" >
     <string>Arial</string>
     </test>
     <edit mode="assign" name="family" >
     <string>Nimbus Sans</string>
     </edit>
    </match>
    
    <match target="pattern" >
     <test name="family" qual="any" >
     <string>Lucida</string>
     </test>
     <edit mode="assign" name="family" >
     <string>Nimbus Sans</string>
     </edit>
    </match>
    
    <match target="pattern" >
     <test name="family" qual="any" >
     <string>Times</string>
     </test>
     <edit mode="assign" name="family" >
     <string>Nimbus Roman</string>
     </edit>
    </match>
    
    <match target="pattern" >
     <test name="family" qual="any" >
     <string>Courier</string>
     </test>
     <edit mode="assign" name="family" >
     <string>Nimbus Mono</string>
     </edit>
    </match>
    
    </fontconfig>
    Last edited by kerry_s; May 24th, 2008 at 11:35 AM.

  7. #7
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Nice font rendering in 8.04 Hardy

    Quote Originally Posted by kerry_s View Post
    basically your doing manually what-> sudo dpkg-reconfigure fontconfig-config
    does.
    i choose:
    autohinter
    automatic
    yes

    in most cases you want "no" for bitmaps, but i'm using it for other languages, so i made a ~/.fonts.conf file to straighten out the crappy ms fonts.
    ...
    Thanks for this. I wasn't aware of this handy utility. You said "crappy ms fonts". I'm guessing you mean the ms emulation fonts. Because for me in Windows I prefer their fonts over most of what I've seen in Linux. I tried to copy, for example, Opera font names from Windows to the equivilent Linux names. All to no avail. Maybe now this utility will come to my rescue. Ubuntu default fonts have at least the best of the bunch, but I prefer to fine tune. I thought all along it was Windows True Type fonts that were the issue.

  8. #8
    Join Date
    May 2008
    Beans
    64

    Re: Nice font rendering in 8.04 Hardy

    Sorry to revive an old post, but I'm having problems with autohinting. I have a thread posted in General, but it seems threads there go to the void within an hour. Posting here might be better.

    Your Sans looks incredibly awesome. But mine doesn't. I followed this howto perfectly, but my Sans looks like http://launchpadlibrarian.net/12505687/Screenshot.png (see bottom window) instead. Autohinting made Sans look bigger, and certain characters, such as an f and i right next to each other, are sized smaller than the rest of the font. Is there any way I can fix this? I found that second screenshot at https://bugs.edge.launchpad.net/ubun...or/+bug/199557.

    Any and all help is greatly appreciated.

  9. #9
    Join Date
    May 2007
    Beans
    7

    Re: Nice font rendering in 8.04 Hardy

    Quote Originally Posted by Twilight in Zero View Post
    Autohinting made Sans look bigger, and certain characters, such as an f and i right next to each other, are sized smaller than the rest of the font. Is there any way I can fix this?
    Mine font looks smaller, i have Sans 9 in Application font. Try with this size and compare with screenshots. Also DPI settings can change a lot, I use 96.

  10. #10
    Join Date
    May 2008
    Beans
    64

    Re: Nice font rendering in 8.04 Hardy

    Yeah, Sans 9 did it for me. I compared the appearance of my fonts to yours when I toggled it on, and everything looked right. Thank you.

    It's so weird though. With the bytecode hinter, there is little difference between Sans 9 and Sans 10, except for the apparent spacing in lists and such. But with the autohinter, the difference is dramatic.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •