Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: After intall doesn't boot ubuntu

  1. #11
    Join Date
    Jul 2007
    Location
    Saxony (Germany)
    Beans
    226
    Distro
    Ubuntu Karmic Koala (testing)

    Re: After intall doesn't boot ubuntu

    Quote Originally Posted by vlomasb View Post
    Code:
    activate
    timeout = 80
    default = linux
    boot = /dev/sda10
    
    image = /boot/vmlinux-2.6.22.5-31-ppc64
    ###Don't change this comment - YaST2 identifier: Original name: linux###
        label = opensuse
        append = " quiet sysrq=1 insmod=sym53c8xx insmod=ipr"
        initrd = /boot/initrd-2.6.22.5-31-ppc64
        root = /dev/disk/by-id/scsi-SATA_ST3160023AS_3JS167W4-part13
    
    other = /dev/sda9
        label = Macc
    
    image = /boot/vmlinux
        label = ubuntu
        initrd = /boot/initrd.img
        root = /dev/sda11
        append = nosplash
    And this is the yaboot.conf that was generated by ubuntu installation on ubuntu's partitions:

    Code:
    boot=/dev/sda10
    device=/disk@0:
    partition=11
    root=/dev/sda11
    timeout=100
    install=/usr/lib/yaboot/yaboot
    magicboot=/usr/lib/yaboot/ofboot
    enablecdboot
    macosx=/dev/sda9
    
    image=/boot/vmlinux
            label=Linux
            read-only
            initrd=/boot/initrd.img
            append="nosplash"
    
    image=/boot/vmlinux.old
            label=old
            read-only
            initrd=/boot/initrd.img.old
            append="quiet splash"
    IMHO your yaboot.conf looks fine. Maybe your ubuntu-root is broken. But if installation went fine on this without errors and you couldnt change anything yet because you wasnt able to boot into ubuntu then I have no idea wtf avoids ubuntu from starting up.

    For the problem with your lilo.conf look at the marked lines. It is obvious that ubuntu wont start without these parameters. The ubuntu section in your lilo.conf should look like this
    Code:
            image=/boot/vmlinux
            label=ubuntu
            read-only
            device=/disk@0:
            partition=11
            root = /dev/sda11
            initrd=/boot/initrd.img
            append="nosplash"
    I suggest to verify your of-path (/disk@0:11) once again. Yours is very unusual. Start into opensuse, open a terminal and execute
    # ofpath /dev/sda11
    once again.

    To check the filesystem on sda11 (for eliminating the possibility of a corrupt filesystem). Start into opensuse, open a terminal, unmount /dev/sda11
    # sudo umount /dev/sda11
    (if its mounted) and then execute
    # e2fsck -v -p -f /dev/sda11
    this will force a check of the filesystem in verbose mode, you will be asked for every change that has to be executed.

    Report about your progress. Maybe there is a way to eliminate your problems by using opensuse to repair your ubuntu system

  2. #12
    Join Date
    May 2008
    Beans
    9

    Re: After intall doesn't boot ubuntu

    I was doing some test but I don't have success.

    1) I installed Ubuntu 7.04 in /dev/sda11, because I thought Ubuntu 8.04 had a bug. When I reboot I got the image (1) I chose letter l for linux and I got the error.

    2) Using OpenFirmware (key alt + command + o +f) and then

    Code:
    >0 hda:10,yaboot
    I got the image (2). You can see the errors.

    3) I booted the Live CD Ubuntu 7.04 again and I could make a chroot to opensuse system. Then I executed

    Code:
    #lilo
    And when I reboot the previous version of lilo bootloader appeard. I ran opensuse, And I got this

    Code:
    # ofpathname /dev/sda11
    /ht@0,f2000000/pci@7/k2-sata-root@c/k2-sata@0/disk@0:11
    and this

    Code:
    # e2fsck -v -p -f /dev/sda11
    
     100834 inodes used (1.97%)
         95 non-contiguous inodes (0.1%)
            # of inodes with ind/dind/tind blocks: 4552/34/0
     689158 blocks used (6.73%)
          0 bad blocks
          1 large file
    
      76572 regular files
      10979 directories
        134 character device files
         26 block device files
          2 fifos
          0 links
      13112 symbolic links (12038 fast symbolic links)
          0 sockets
    --------
     100825 files
    such as you told me. It seems to be no problem with anything. I corrected lilo.conf version

    Code:
    image=/boot/vmlinux
            label=ubuntu
    #        read-only
    #        device=/disk@0:
    #        partition=11
    #        root = /dev/sda11
            root = /dev/disk/by-id/scsi-SATA_ST3160023AS_3JS167W4-part11
            initrd=/boot/initrd.img
            append="nosplash"
    I had to comment the line read-only, device and partition because I received this error when I executed # lilo on opensuse

    Code:
    # lilo
    ERROR: !!!!!!!!!! unkown option read-only !!!!!!!!!!!!!
    Code:
    # lilo
    ERROR: !!!!!!!!!! unkown option device !!!!!!!!!!!!!
    Once I could run lilo successfully and I rebooted I got the image (3)

    Well I am such as the beginning, with nothing; well I now know how to install opensuse in PPC how the hell opensuse for PPC use lilo and don't yaboot

    Thank you again
    Attached Images Attached Images
    • File Type: jpg 1.JPG (109.0 KB, 7 views)
    • File Type: jpg 2.JPG (142.1 KB, 7 views)
    • File Type: jpg 3.JPG (106.9 KB, 5 views)

  3. #13
    Join Date
    Jul 2007
    Location
    Saxony (Germany)
    Beans
    226
    Distro
    Ubuntu Karmic Koala (testing)

    Re: After intall doesn't boot ubuntu

    Quote Originally Posted by vlomasb View Post
    ofpathname /dev/sda11
    /ht@0,f2000000/pci@7/k2-sata-root@c/k2-sata@0/disk@0:11
    This looks like an ofpath I like

    This you have to add to your ubuntu yaboot.conf as
    Code:
    device=/ht@0,f2000000/pci@7/k2-sata-root@c/k2-sata@0/disk@0:
    The mistaakes with lilo.conf came frome false syntax. I thaght it has to be thw same as for yaboot, as I thought it will also use yaboot. My fault


    Try this first please...

    //edit: the first of your attached shots suggests that your ofpath entry isnt valid...
    Last edited by frog_pilot; June 8th, 2008 at 11:15 AM.

  4. #14
    Join Date
    May 2008
    Beans
    9

    Excellent news but also bad news

    Hi

    There are excellent news but also bad news.

    The excellent new is at least I could run ubuntu, since now I am writing this post with ubuntu. I did exactly that you told me. Add the line

    Code:
    device=/ht@0,f2000000/pci@7/k2-sata-root@c/k2-sata@0/disk@0:
    to yaboot.conf and I executed ybin -V and I got this:

    Code:
    ybin: Finding OpenFirmware device path to `/dev/sda10'...
    ybin: Finding OpenFirmware device path to `/dev/sda9'...
    ybin: Installing first stage bootstrap /usr/lib/yaboot/ofboot onto /dev/sda10...
    ybin: Installing primary bootstrap /usr/lib/yaboot/yaboot onto /dev/sda10...
    ybin: Installing /etc/yaboot.conf onto /dev/sda10...
    ybin: Setting attributes on ofboot...
    ybin: Setting attributes on yaboot...
    ybin: Setting attributes on yaboot.conf...
    ybin: Blessing /dev/sda10 with Holy Penguin Pee...
    ybin: Updating OpenFirmware boot-device variable in nvram...
    I rebooted the PPC and just MacOS boot suddenly without my decision.

    Then I pressed alt key, and then in the graphical menu I clicked on Linux button and just the same graphical menu appeared. I was disappointed but I remembered the famous OpenFirmware MAC, then alt + command + o + f I typed

    Code:
    0>boot hd:10,yaboot
    and then yaboot appeared I pressed tab key, show me Linux, old and Opensuse, I typed Linux and voila! Ubuntu ran.

    Then the bad news I have to follow the previous procedure to initialize ubuntu.

    My last questions is, what have I to do for Ubuntu on PPC system works normally?

    Once again, thank you.

  5. #15
    Join Date
    May 2008
    Beans
    9

    Smile Re: After intall doesn't boot ubuntu

    I forgot to say:

    By the way I am too happy!

  6. #16
    Join Date
    Jul 2007
    Location
    Saxony (Germany)
    Beans
    226
    Distro
    Ubuntu Karmic Koala (testing)

    Re: After intall doesn't boot ubuntu

    Quote Originally Posted by vlomasb View Post
    I rebooted the PPC and just MacOS boot suddenly without my decision.

    Then I pressed alt key, and then in the graphical menu I clicked on Linux button and just the same graphical menu appeared. I was disappointed but I remembered the famous OpenFirmware MAC, then alt + command + o + f I typed

    Code:
    0>boot hd:10,yaboot
    and then yaboot appeared I pressed tab key, show me Linux, old and Opensuse, I typed Linux and voila! Ubuntu ran.

    Then the bad news I have to follow the previous procedure to initialize ubuntu.

    My last questions is, what have I to do for Ubuntu on PPC system works normally?

    Once again, thank you.
    Do you mean that after the graphical openfirmware menu (the one with the buttons), if you press the linux(penguin)-button there appears exactly the same graphical openfirmware menu?

    There should appear the

    # l - Linux
    # x - OSX
    # c - cdrom

    menu. And the yaboot stage 2

    # boot:

    where you hit tab and then enter your wanted option (ubuntu).

    Now, having the right openfirmware-path for your startup-disk, step back to the first attempt to fix ubuntu...

    Change your ubuntu yaboot.conf with the now known device-entry. Make these changes permanent with
    # ybin
    and try starting again, ignoring your new opensuse install...



    Quote Originally Posted by vlomasb View Post
    My last questions is, what have I to do for Ubuntu on PPC system works normally?
    Usually it works normally on most ppc macs the efault yaboot.conf works fine and has detected the right openfirmware path. Sometimes you have to add a kernel parameter. What went wrong on your machine is a mystery...

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •