Page 6 of 24 FirstFirst ... 4567816 ... LastLast
Results 51 to 60 of 233

Thread: HOWTO: Install Rubyripper on Ubuntu

  1. #51
    Join Date
    Aug 2006
    Beans
    417
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Perhaps it had something to do with 64-bit - your instructions were straightforward and there wasn't really a way for me to get it wrong aside from a typo...(which didn't happen as I copied and pasted and checked spelling when it didn't work).

  2. #52
    Join Date
    Aug 2008
    Beans
    7

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Just got onto this ripper from another page which pointed to 0.5.3. I installed using the recipe with no problems. When I ran it though (Intrepid), it went into a loop hogging one core to 100%. I saw there was a newer version out so uninstalled via the recipe. Got this error:

    Code:
    ruby configure --update-lib                                                                               
    ./rr_lib.rb:19: undefined method `+' for nil:NilClass (NoMethodError)                                     
            from configure:37:in `require'                                                                    
            from configure:37                                                                                 
    make: *** [clean] Error 1
    Installed 0.5.4, and it now works ok. Looks good too, especially with all the hassles I had with another GUI ripper yesterday.

  3. #53
    Join Date
    Jun 2008
    Location
    East Coast
    Beans
    54
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    The tutorial worked perfectly, the first try.

    Thank you!

  4. #54
    Join Date
    Aug 2006
    Beans
    417
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Quote Originally Posted by BigAl-SA View Post
    Just got onto this ripper from another page which pointed to 0.5.3. I installed using the recipe with no problems. When I ran it though (Intrepid), it went into a loop hogging one core to 100%. I saw there was a newer version out so uninstalled via the recipe. Got this error:

    Code:
    ruby configure --update-lib                                                                               
    ./rr_lib.rb:19: undefined method `+' for nil:NilClass (NoMethodError)                                     
            from configure:37:in `require'                                                                    
            from configure:37                                                                                 
    make: *** [clean] Error 1
    Installed 0.5.4, and it now works ok. Looks good too, especially with all the hassles I had with another GUI ripper yesterday.
    Gee, looks awfully familiar. See my previous posts in this thread. We've both solved our problems, but out of interest, are you running 64 bit?

  5. #55
    Join Date
    Apr 2007
    Beans
    24

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Thanks to all of you who recommended getdeb - I was stumped with the exact same problem in compiling as above (on 32-bit, FYI) and getdeb method solved my woes.

    THANKS!!

  6. #56
    Join Date
    May 2005
    Beans
    352

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    I installed gettext and libgettext-ruby1.8 and the configure and make worked fine.

  7. #57
    Join Date
    Dec 2004
    Beans
    59

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Anyone else have a problem with the most recent version (0.5.4) stopping before ripping the last track of the cd?

  8. #58
    Join Date
    Jan 2009
    Location
    u.s.a.
    Beans
    1
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Thanks for the instructions. They worked fine for me on ubuntu 8.1 using ruby 0.5.4

  9. #59
    Join Date
    Jan 2006
    Location
    Lynchburg, VA (US)
    Beans
    278
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    0.5.5 appears to be out now. I haven't tried it yet, but I hope to soon.

    On another note, how could one go about requesting that rubyripper be added to the universe repository? I wouldn't think it would be hard. Who would we need to ask?
    Linux user since January 31st, 2006.
    two ways to live :: the choice we all face

  10. #60
    Join Date
    Nov 2006
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOWTO: Install Rubyripper 0.5.0 on Ubuntu 8.04

    Sorry that I haven't been updating this thread all that much - school has started and I am now using Arch Linux.
    Quote Originally Posted by VCSkier View Post
    0.5.5 appears to be out now. I haven't tried it yet, but I hope to soon.

    On another note, how could one go about requesting that rubyripper be added to the universe repository? I wouldn't think it would be hard. Who would we need to ask?
    Yes, Rubyripper 0.5.5 is out! I haven't updated the guide yet, as I no longer have an Ubuntu system. But if somebody wants to build it on an Ubuntu system and let us know how it works, please do so!

    As for adding Rubyripper to the Ubuntu repositories, I filed a bug report a while ago, but I'm not sure if there's anything else we can really do, other than either wait for the developers or package Rubyripper ourselves (which I don't know how to do, and don't really have the time/motivation to learn).
    Last edited by ghindo; May 28th, 2009 at 05:25 PM.
    Want a quality CD ripping program for Ubuntu? Check out my how-to: Installing Rubyripper on Ubuntu!

Page 6 of 24 FirstFirst ... 4567816 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •