Page 9 of 81 FirstFirst ... 78910111959 ... LastLast
Results 81 to 90 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

  1. #81
    Join Date
    Mar 2008
    Location
    Oxford
    Beans
    89
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Forlong,

    I apologize, I found what I was looking for. It has to do with right click on taskbar and add to panel,and you can customize from there,like adding icons for a specific application. But i did find out from your blog and on the forum how to get compiz running correctly. I had been trying for about 2 weeks to get it running correctly, after putting in a new graphics card.
    Thanks again, Retiree
    PS Keep up the good work !!!
    Learning curve's are like life's curves,you will learn one way or the other!

  2. #82
    Join Date
    Jun 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Code:
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.04
     Desktop environment:   GNOME
     Graphics chip:         ATI Technologies Inc RC410 [Radeon Xpress 200M]
     Driver in use:         radeon
     Rendering method:      AIGLX
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [ OK ]
    How can i enable extra visual effects to run compiz.

  3. #83
    Join Date
    Mar 2008
    Location
    Oxford
    Beans
    89
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    If you will go to the first page of this thread and start reading you will learn how to customize compiz. If you don't have compiz you need to go to synaptic package manager, (System, Administration, Synaptic Package Manager)
    and install it. Then go back to this thread and read Forlong's thread and pay close attention to his links,particularly his blog. That will probably help you more than I can explain it to you.Hope this helps.If you get stuck Forlong can help you.Search for compiz in package manager and install it.Cheers, Retiree

    PS
    It looks like you already have compiz installed and probably you need to read his blog. That helped me more than any thing.
    Last edited by retiree; June 10th, 2008 at 03:36 AM.
    Learning curve's are like life's curves,you will learn one way or the other!

  4. #84
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by Ajsplace View Post
    How can i enable extra visual effects to run compiz.
    Just go to System → Preferences → Appearance → Visual Effects and enable it there.

    Or do you mean how to customize it? Then go here: http://forlong.blogage.de/article/20...piz-Fusion-074


    @retiree: I'm glad that you found what you were looking for.

  5. #85
    Join Date
    Dec 2007
    Beans
    48
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Here it is...

    Output of glxinfo:
    Code:
    name of display: :0.0
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual
    
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    0x5c 32 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
    And of compiz-check:
    Code:
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.04
     Desktop environment:   KDE
     Graphics chip:         nVidia Corporation NV34M [GeForce FX Go5200 32M/64M] (rev a1)
     Driver in use:         nv
     Rendering method:      None
    
    Checking if it's possible to run Compiz on your system...  [SKIP]
    
     Checking for hardware/setup problems...           [SKIP]
    
    At least one check had to be skipped:
     Error: No rendering method in use (AIGLX, Xgl or Nvidia)
    I have installed the driver from Nvidia's website (173.14.05) by loging out then back in using Console Mode and executing the installer with the "sh" command and all seemed to go well. However, when I run compiz I get:

    Code:
    Checking for Xgl: not present.
    No whitelisted driver found
    aborting and using fallback: /usr/bin/kwin
    I've tried every suggestion I've seen in the forums so far. I even nuked KDE4 and went with 3 assuming it would be less buggy in this sense. Ideas?

  6. #86
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    The driver is obviously not properly installed. Why didn't you install it via System → Administration → Hardware Drivers?

  7. #87
    Join Date
    May 2008
    Beans
    110

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Hi Forlong - i run compiz great with dreamlinux, and mandriva live cd's but not with my installed ubuntu could this be a problem after glxinfo in terminal i get

    direct rendering: No

  8. #88
    Join Date
    Dec 2007
    Beans
    48
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Good question.

    I downloaded and installed the driver from Nvidia and simply followed their instructions. Being as there was a display with correct resolution after I assumed I had done well.

    Since my last post I have ran
    Code:
    sudo apt-get remove --purge nvidia*
    ended the session, ran
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    and restarted xserver. Sadly it seems I'm in the exact same place.

  9. #89
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Sorry, I don't know what the proper way to remove the manually-installed nvidia driver would be. You might want to start a separate thread for that.


    Quote Originally Posted by tunznath View Post
    Hi Forlong - i run compiz great with dreamlinux, and mandriva live cd's but not with my installed ubuntu could this be a problem after glxinfo in terminal i get

    direct rendering: No
    Maybe... why don't you post Compiz-Check's output, so we have more info?

  10. #90
    Join Date
    Oct 2007
    Location
    Jacksonville, Florida
    Beans
    19
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Gathering information about your system...

    Distribution: Ubuntu 8.04
    Desktop environment: GNOME
    Graphics chip: ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]
    Driver in use: radeon
    Rendering method: AIGLX

    Checking if it's possible to run Compiz on your system...

    Checking for texture_from_pixmap... [ OK ]
    Checking for non power of two support... [ OK ]
    Checking for composite extension... [ OK ]
    Checking for FBConfig... [ OK ]
    Checking for hardware/setup problems... [ OK ]

    ----------------------------------------------------------------------

    compiz command in terminal output:


    Checking for Xgl: not present.
    Detected PCI ID for VGA: 03:00.0 0300: 1002:7187 (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: present.
    Checking for non power of two support: present.
    Checking for Composite extension: present.
    Comparing resolution (1280x1024) to maximum 3D texture size (2048): Passed.
    Checking for nVidia: not present.
    Checking for FBConfig: present.
    Checking for Xgl: not present.
    /usr/bin/compiz.real (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
    /usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
    /usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

Page 9 of 81 FirstFirst ... 78910111959 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •