Page 7 of 81 FirstFirst ... 567891757 ... LastLast
Results 61 to 70 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

  1. #61
    Join Date
    Jun 2008
    Beans
    214

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Ok well i did this and got this output........

    ------------------------------------------------------------------------
    Gathering information about your system...

    Distribution: Ubuntu 8.04
    Desktop environment: GNOME
    Graphics chip: nVidia Corporation Geforce 9600 GT 512mb (rev a1)
    Driver in use: nv
    Rendering method: None

    Checking if it's possible to run Compiz on your system... [SKIP]

    Checking for hardware/setup problems... [SKIP]

    At least one check had to be skipped:
    Error: No rendering method in use (AIGLX, Xgl or Nvidia)

    ----------------------------------------------------------------------
    How do i render it so it works?

  2. #62
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by ryclegman View Post
    How do i render it so it works?
    You need to install the nvidia driver through System → Administration → Hardware Drivers

    Quote Originally Posted by Ajsplace View Post
    Code:
    fglrxinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
    Code:
    glxinfo: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
    There's obviously something seriously wrong with your driver.
    How did you install it?


    P.S. you don't need to "quote" the previous posts here, it's not a mailing list.

  3. #63
    Join Date
    Mar 2007
    Location
    New Port Richey, FL, USA
    Beans
    60
    Distro
    Ubuntu Studio 13.04 Raring Ringtail

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Here's my compiz-check output:

    Gathering information about your system...

    Distribution: Ubuntu 8.04
    Desktop environment: KDE
    Graphics chip: ATI Technologies Inc Radeon R100 QD [Radeon 7200]
    Driver in use: radeon
    Rendering method: Xgl

    Checking if it's possible to run Compiz on your system...

    Checking for texture_from_pixmap... [SKIP]
    Checking for non power of two support... [SKIP]
    Checking for composite extension... [ OK ]
    Checking for FBConfig... [SKIP]
    Checking for hardware/setup problems... [SKIP]

    Apparently my Radeon card is too old for the current fglrx driver. I don't see a hint of a driver installed when sudo lshw and lsmod makes no mention of fglrx or r200 but does show drm in a line with radeon. Would like to try the r200 driver haven't had success downloading it.

  4. #64
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    You don't need Xgl with the radeon driver.
    Remove it:
    Code:
    sudo apt-get remove xserver-xgl
    Then restart X and try again.


    And yes, the 7200 is not supported by fglrx.


    edit: was there no message, why the very last check had to be skipped?

  5. #65
    Join Date
    Jun 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Thanx alot Forlong. I will install the nvidia drivers. Can i just uninstall the other driver and start fresh. Can u tell me how to fix what ive done wrong and start over.

  6. #66
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Ajsplace, you have an ATI card, you can't install the nvidia drivers.

    How to remove the fglrx driver depends on how you installed it in the first place.

  7. #67
    Join Date
    Jun 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Oh ok, I was responding to message # 62 where it says that i need to install the nvidia drivers. Please bear with me. I just recently made the move over from windows.

    How can i just unistall the drivers and restart fresh? I installed the ati drivers by downloading directly from site and from the repository. Im kind of lost now lol. What should i do?

  8. #68
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by Ajsplace View Post
    Oh ok, I was responding to message # 62 where it says that i need to install the nvidia drivers.
    Oh, I see... I was responding to ryclegman there. Always have a look at the quote above the reply.
    Quote Originally Posted by Ajsplace View Post
    How can i just unistall the drivers and restart fresh? I installed the ati drivers by downloading directly from site and from the repository. Im kind of lost now lol. What should i do?
    Frankly, I'm not sure what's the best way to undo that.
    Consider starting a thread in a better fitting section of the forum about how to uninstall a manual fglrx installation.

  9. #69
    Join Date
    Jun 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I just unistalled the fglrx. What should i do now to get my desktop effects to start working.

  10. #70
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Please run Compiz-Check again and post the output here.

Page 7 of 81 FirstFirst ... 567891757 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •