Page 41 of 81 FirstFirst ... 31394041424351 ... LastLast
Results 401 to 410 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

  1. #401
    Join Date
    Jan 2008
    Beans
    3

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Code:
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  158 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  10
      Current serial number in output stream:  10

  2. #402
    Join Date
    Jan 2008
    Beans
    3

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I fixed my problem:

    After trying failed attempts to remove and install the ati drivers with apt-get I found a post where another Ubuntu-er was having problems with the hardware drivers manager and used envy to install the driver. This approach fixed my issues.

    Here is what I did:

    I installed envyng

    Code:
    sudo apt-get envyng-core

    And then ran envy in text mode:

    Code:
    envyng -t
    Which promts you with this:
    Code:
     +-----------------------------------------------------------+
     |    EnvyNG Menu                                            |
     |                                                           |
     |    1 - Install the NVIDIA driver                          |
     |                                                           |
     |    2 - Uninstall the NVIDIA driver                        |
     |                                                           |
     |    3 - Install the ATI driver                             |
     |                                                           |
     |    4 - Uninstall the ATI driver                           |
     |                                                           |
     |    5 - Restart the Xserver                                |
     |                                                           |
     |    6 - Restart your computer                              |
     |                                                           |
     |    7 - Exit                                               |
     |                                                           |
     |    NOTE: IF THE SCREEN TURNS BLACK, PLEASE TYPE ALT+F1    |
     +-----------------------------------------------------------+
    Please select one of the activities displayed above and press ENTER:
    Steps I took:

    1. I uninstalled my ATI driver [option 4].
    2. Restarted.
    3. Ran envy again and installed the ATI driver [option 3].
    4. Restarted. Problem solved.

  3. #403
    Join Date
    May 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Code:
    Code:
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.10
     Desktop environment:   GNOME
     Graphics chip:         VIA Technologies, Inc. K8M890CE/K8N890CE [Chrome 9] (rev 11)
     Driver in use:         vesa
     Rendering method:      AIGLX
    
    Checking if it's possible to run Compiz on your system...  [SKIP]
    
     Checking for hardware/setup problems...           [SKIP]
    
    At least one check had to be skipped:
     Error: vesa driver in use 
    
    Would you like to know more? (Y/n) y
    
     The vesa driver is not capable of running Compiz, you need to install
     the proper driver for your graphics card.
    Last edited by gvrayden; February 2nd, 2009 at 11:05 AM.

  4. #404
    Join Date
    May 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Now i installed the latest driver from here...

    http://packages.ubuntu.com/search?su...rds=openchrome

    But still i have the same output...

    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    EndSection
    This thing means Driver "openchrome" is not being used,rite ?

    what shud i do to solve this issue?

  5. #405
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Sorry, the drivers that come with Ubuntu are not capable of running Compiz on VIA hardware, because their drivers are closed source.
    There are some beta drivers here, that are said to work with Compiz but I don't know if you will be able to use any of them: http://linux.via.com.tw

  6. #406
    Join Date
    Dec 2008
    Location
    Evanston, IL
    Beans
    15
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I seem to be having the same troubles as PhysMeistro a few pages ago:

    Code:
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.10
     Desktop environment:   GNOME
     Graphics chip:         Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
     Driver in use:         intel
     Rendering method:      AIGLX
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [FAIL]
    
    There has been (at least) one error detected with your setup:
     Error: Software Rasterizer in use
    However, I'm running an Intel chip. Compiz worked fine for me before a presentation (see my post on that), and is now giving me errors. Any suggestions?

  7. #407
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Post your /etc/X11/xorg.conf (that's a file, just open it in your favourite text editor).

  8. #408
    Join Date
    Dec 2008
    Location
    Evanston, IL
    Beans
    15
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    	SubSection "Display"
    		Virtual	2304 800
    	EndSubSection
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    For some reason, I've also got 9 other xorg.conf.2009XXXXX configuration files. Most seem to be the exact same, although at least one is slightly different.

  9. #409
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Open the file like this:
    Code:
    gksu gedit /etc/X11/xorg.conf
    and remove this bit
    Code:
    	SubSection "Display"
    		Virtual	2304 800
    	EndSubSection
    Then save, and log out and back in. See if it helped.

  10. #410
    Join Date
    May 2008
    Beans
    8

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Thx for the reply Forlong...
    Now,wud i be able to use compiz if i get down to the 8.04 version ?

Page 41 of 81 FirstFirst ... 31394041424351 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •