Page 31 of 81 FirstFirst ... 21293031323341 ... LastLast
Results 301 to 310 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

  1. #301
    Join Date
    Feb 2005
    Location
    Milton Keynes, UK
    Beans
    231
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Cyril8727 - what does the glxinfo command give you (refer posts above)? I go to the same point as you, and glxinfo gave clear indications something was up with my OpenGL.

    Robert

  2. #302
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Also, what's the output of
    Code:
    compiz
    in a terminal?

  3. #303
    Join Date
    Aug 2008
    Beans
    18
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Hey Guys n Gals(?),

    Thanks for your help....I did manage to get some of the codes working - here are few things that I would like to add on for other Noobs like me:

    (1) Some desktops are not meant to support Compiz i.e modifying the files will make it work but then you might loose some efficiency from your desktop eg. things running slow!!
    (2) Sometimes having those cool effects is not really helpful as it does take some CPU usage to run and at times having less effects = better performance

    In my case I got most of the stuff rite (if not all) but then decided to just use ubuntu as my laptop in its original setting permits ----but that's just me
    Last edited by Viking007; November 27th, 2008 at 06:42 AM. Reason: Wrong Thread!!!

  4. #304
    Join Date
    Oct 2008
    Beans
    24

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    forlong, i fallow the tutorial and it seem i can install compiz,can you help me,please?i install ubuntu a few weeks ago.

    Distribution: Ubuntu 8.10
    Desktop environment: GNOME
    Graphics chip: ATI Technologies Inc RC410 [Radeon Xpress 200M]
    Driver in use: radeon
    Rendering method: AIGLX

    Checking if it's possible to run Compiz on your system...

    Checking for texture_from_pixmap... [ OK ]
    Checking for non power of two support... [ OK ]
    Checking for composite extension... [ OK ]
    Checking for FBConfig... [ OK ]
    Checking for hardware/setup problems... [ OK ]

    i have a asus laptop-x51rl
    Last edited by yuli_capone; November 27th, 2008 at 08:57 AM.

  5. #305
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    yuli_capone, what exactly is your problem?

  6. #306
    Join Date
    Oct 2008
    Beans
    24

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    i found more methods how to install the video driver,i tried a few but every time something goes wrong.
    i found some tutorials,and i don't know how to install corectly.

    http://forum.compiz-fusion.org/showthread.php?p=59366

    http://ubuntuforums.org/archive/index.php/t-678563.html

    http://sidrit.wordpress.com/2008/08/...u-hardy-heron/

    sorry for the language,i'm from romania

  7. #307
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    The current driver works fine with Compiz.

    If you want to install ATI's "official" (yet proprietary) driver, go to System → Administration → Hardware Drivers and "enable" it there.

  8. #308
    Join Date
    Oct 2008
    Beans
    24

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    thanks.it's works.now i install compiz,hope it will work.

  9. #309
    Join Date
    Oct 2008
    Location
    Commonwealth of Kentucky
    Beans
    29
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Updated my video card with Nvidia 3dForce FX5200 and after configuring ran Compiz-Check. It hangs at "Starting gtk-window-decorator".

    Here is complete bash:
    Code:
    user@user-desktop:~$ wget http://blogage.de/files/4359/download -O compiz-check
    --2008-11-27 10:27:06--  http://blogage.de/files/4359/download
    Resolving blogage.de... 78.46.34.206
    Connecting to blogage.de|78.46.34.206|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 27814 (27K) [application/octet-stream]
    Saving to: `compiz-check'
    
    100%[======================================>] 27,814      52.0K/s   in 0.5s    
    
    2008-11-27 10:27:07 (52.0 KB/s) - `compiz-check' saved [27814/27814]
    
    user@user-desktop:~$ chmod +x compiz-check
    user@user-desktop:~$ ./compiz-check
    
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.10
     Desktop environment:   GNOME
     Graphics chip:         nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
     Driver in use:         nvidia
     Rendering method:      Nvidia
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems...           [FAIL]
    
    There has been (at least) one error detected with your setup:
     Error: Another compositing manager in use. 
    
    Would you like to know more? (Y/n) y
    
     The default window manager of GNOME has its own compositing manager to
     provide basic desktop effects.
     If this one is in use, Compiz will not be able to run. 
    
    Do you want to disable GNOME's compositing manager? (Y/n) y
    user@user-desktop:~$ ./compiz-check
    
    Gathering information about your system...
    
     Distribution:          Ubuntu 8.10
     Desktop environment:   GNOME
     Graphics chip:         nVidia Corporation NV34 [GeForce FX 5200] (rev a1)
     Driver in use:         nvidia
     Rendering method:      Nvidia
    
    Checking if it's possible to run Compiz on your system...
    
     Checking for texture_from_pixmap...               [ OK ]
     Checking for non power of two support...          [ OK ]
     Checking for composite extension...               [ OK ]
     Checking for FBConfig...                          [ OK ]
     Checking for hardware/setup problems..../compiz-check: line 476: [: 8381: binary operator expected
               [ OK ]
    
    user@user-desktop:~$ compiz --replace
    Checking for Xgl: not present. 
    Detected PCI ID for VGA: 
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1024x768) to maximum 3D texture size (4096): Passed.
    Checking for Software Rasterizer: Not present. 
    Checking for nVidia: present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    Starting gtk-window-decorator
    It does appear to be working. I have the jiggly windows and reflective chrome now.

    Should I be concerned? What should I do about it?

    EDIT: Was too impatient. It moved forward one step (see below,) I'll let it steep for the rest of the day and see what happens.

    Code:
    Starting gtk-window-decorator
    /usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
    Let me know if I should still be concerned.
    Last edited by ciborium; November 27th, 2008 at 04:47 PM. Reason: Added info

  10. #310
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Looks absolutely fine to me.
    As for the "binary operator expected" error: I have no idea what could be causing this. Could you please run Compiz-Check again after the next time you rebooted and see if it's still there?

Page 31 of 81 FirstFirst ... 21293031323341 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •