Page 11 of 81 FirstFirst ... 9101112132161 ... LastLast
Results 101 to 110 of 810

Thread: Compiz-Check -- no more "Desktop effects could not be enabled"

  1. #101
    Join Date
    Jun 2008
    Beans
    Hidden!

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    An interesting thing is that when I startup from low graphics mode, I hear the sound of the Ubuntu startup, but when I startup, normally, I don't. Of course when I first installed Ubuntu two days ago it worked perfectly peachy...*sighs* (this part, and the desktop effects).

  2. #102
    Join Date
    Jun 2008
    Beans
    Hidden!

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I figured out what it was, thanks to your help! Somehow, I managed to get the xorg.conf to go back to its default settings, and while it was on that, my sound at the Ubuntu start-up, AND my desktop effects both worked! So I realized it was my screen rotation script causing the problem, and deleted it, and only added back my wacom driver. Now my pen works perfectly and I have my spiffy desktop effects--it's like I'm back to day one with perfect Ubuntu! Thank you so much! If it weren't for you I would have kept searching online for forever looking for an answer, rather than realizing the real problem .

    Again, thanks!!

    So my problem is "solved" now. Two problems, actually--so two birds killed with one stone?

  3. #103
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Awesome.
    I'm glad I could help, but the majority you found out yourself, so hurray to you!

    I feel sorry for the poor birdies, though

  4. #104
    Join Date
    Oct 2006
    Location
    United States
    Beans
    233
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    I ran the check and this is what I get.....

    Gathering information about your system...

    Distribution: Ubuntu 8.04
    Desktop environment: GNOME
    Graphics chip: nVidia Corporation GeForce 8400M GS (rev a1)
    Driver in use: nv
    Rendering method: None

    Checking if it's possible to run Compiz on your system... [SKIP]

    Checking for hardware/setup problems... [SKIP]

    At least one check had to be skipped:
    Error: No rendering method in use (AIGLX, Xgl or Nvidia)
    Does the rendering method need to be edited? If so, how would I go about doing that? Thanks!

  5. #105
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    You need to install/enable the nvidia driver through System → Administration → Hardware Drivers

  6. #106
    Join Date
    Oct 2006
    Location
    United States
    Beans
    233
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by Forlong View Post
    You need to install/enable the nvidia driver through System → Administration → Hardware Drivers
    The driver is already installed but I cannot enable it. I go through the steps, perform the required reboot and I get a white screen. The only option that I am aware of after that is to boot into recovery and repair X.
    Attached Images Attached Images

  7. #107
    Join Date
    Oct 2006
    Location
    United States
    Beans
    233
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    My xorg.conf does not list the graphics card. Al least I don't see it...

    HTML Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Synaptics Touchpad"
    	Driver		"synaptics"
    	Option		"SendCoreEvents"	"true"
    	Option		"Device"		"/dev/psaux"
    	Option		"Protocol"		"auto-dev"
    	Option		"HorizEdgeScroll"	"0"
    EndSection
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice	"Synaptics Touchpad"
    EndSection

  8. #108
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by ebozzz View Post
    The driver is already installed
    How did you install it?

  9. #109
    Join Date
    Jul 2007
    Beans
    16

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    mines out since i updated the X with the latest patch.
    i installed the nvidia drivers using the latest Nvidia drivers, not the repos because of my videocard is only supported with the latest drivers.


    my xorg.conf
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildmeister@builder63)  Mon May 19 00:34:28 PDT 2008
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
        RgbPath         "/usr/lib/X11/rgb"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "0"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "DELL 2001FP"
        HorizSync       31.0 - 80.0
        VertRefresh     56.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 9600 GT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

    and my compiz
    Code:
    Checking for Xgl: not present. 
    Detected PCI ID for VGA: 01:00.0 0300: 10de:0622 (rev a1) (prog-if 00 [VGA controller])
    Checking for texture_from_pixmap: not present. 
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: not present. 
    aborting and using fallback: /usr/bin/metacity 
    Window manager warning: "" found in configuration database is not a valid value for keybinding "toggle_shaded"

  10. #110
    Join Date
    Oct 2006
    Location
    United States
    Beans
    233
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Compiz-Check -- no more "Desktop effects could not be enabled"

    Quote Originally Posted by Forlong View Post
    How did you install it?
    How? System → Administration → Hardware Drivers...... I have also tried using EnvyNG to complete the install. Same results. After rebooting I get the white screen....

Page 11 of 81 FirstFirst ... 9101112132161 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •