View Poll Results: Do you think that gproftpd is useful ?

Voters
872. You may not vote on this poll
  • Yes, it's easy to use and really powerful

    473 54.24%
  • Yes, but i won't use it

    136 15.60%
  • No, the GUI has to be improved

    263 30.16%
Page 6 of 123 FirstFirst ... 456781656106 ... LastLast
Results 51 to 60 of 1225

Thread: HOWTO : Create a FTP server with user access (proftpd)

  1. #51
    Join Date
    Aug 2005
    Location
    Michigan, USA
    Beans
    53
    Distro
    Kubuntu Breezy 5.10

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Do you have a firewall?

  2. #52
    Join Date
    Dec 2005
    Beans
    23

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Quote Originally Posted by jbinc1
    Do you have a firewall?
    Yes, I do but it is ported open. Calls to the Apache server from outside go through.
    It's on the same machine.
    I'll mess with it more tomorrow.

  3. #53
    Join Date
    Dec 2005
    Beans
    23

    Re: HOWTO : Create a FTP server with user access (proftpd)

    I'm still not connecting from a windoze machine using the server's internet address. Using IE I put in the pw and it hangs on "Getting contents of folder".
    Times out with "An error occured on the server, make sure you have permission to access that folder". (I know thats a standard Win error format)
    I can connect fine using the 192.168 internal though.

    More ideas?

  4. #54
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Could you post your proftpd.conf, i'd like to see if there isn't something which block the LIST or CWD command, it could come from you configuration file or from wrong system rights in your ftp folder.

    Also if you use IE to connect to the ftp server don't forget to specify the port if you don't use port 21, i give you an example corresponding to the guide (which use the port 1980) : ftp:\\sauron@100.12.xx.xxx:1980

  5. #55
    Join Date
    Dec 2005
    Beans
    23

    Re: HOWTO : Create a FTP server with user access (proftpd)

    I am currently using port 21 because I haven't yet figured out to make a port change in my Netgear FVS318. It has a dropdown for service but no selection of ports.
    Still looking for it....
    Thank you Frodon!
    Here is my conf file:

    # To really apply changes reload proftpd after modifications.
    AllowOverwrite on
    AuthAliasOnly on

    # Choose here the user alias you want !!!!
    UserAlias steve userftp

    ServerName "Ubuntu"
    ServerType standalone
    DeferWelcome on

    UseReverseDNS off
    IdentLookups off

    MultilineRFC2228 on
    DefaultServer on
    ShowSymlinks off

    TimeoutNoTransfer 600
    TimeoutStalled 100
    TimeoutIdle 2200

    DisplayFirstChdir .message
    ListOptions "-l"

    RequireValidShell off

    TimeoutLogin 99

    RootLogin off

    # It's better for debug to create log files
    ExtendedLog /var/log/ftp.log
    TransferLog /var/log/xferlog
    SystemLog /var/log/syslog.log

    #DenyFilter \*.*/

    # I don't choose to use /etc/ftpusers file (set inside the users you want to ban, not useful for me)
    UseFtpUsers off

    # Allow to restart a download
    AllowStoreRestart on

    # Port 21 is the standard FTP port, so don't use it for security reasons (choose here the port you want)
    Port 21

    # To prevent DoS attacks, set the maximum number of child processes
    # to 30. If you need to allow more than 30 concurrent connections
    # at once, simply increase this value. Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances 8

    # Set the user and group that the server normally runs at.
    User nobody
    Group nogroup

    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask 022 022

    PersistentPasswd off

    MaxClients 8
    MaxClientsPerHost 8
    MaxClientsPerUser 8
    MaxHostsPerUser 8

    # Display a message after a successful login
    AccessGrantMsg "welcome !!!"
    # This message is displayed for each access good or not
    ServerIdent on "you're at home"

    # Set /home/FTP-shared directory as home directory
    DefaultRoot /home/FTP-shared

    # Lock all the users in home directory, ***** really important *****
    DefaultRoot ~

    MaxLoginAttempts 5

    #VALID LOGINS
    <Limit LOGIN>
    AllowUser userftp
    DenyALL
    </Limit>

    <Directory /home/FTP-shared>
    Umask 022 022
    AllowOverwrite off
    <Limit MKD STOR DELE XMKD RNRF RNTO RMD XRMD>
    DenyAll
    </Limit>
    </Directory>

    <Directory /home/FTP-shared/download/*>
    Umask 022 022
    AllowOverwrite off
    <Limit MKD STOR DELE XMKD RNEF RNTO RMD XRMD>
    DenyAll
    </Limit>
    </Directory>

    <Directory> /home/FTP-shared/upload/>
    Umask 022 022
    AllowOverwrite on
    <Limit READ RMD DELE>
    DenyAll
    </Limit>

    <Limit STOR CWD MKD>
    AllowAll
    </Limit>
    </Directory>

  6. #56
    Join Date
    Jan 2006
    Beans
    9
    Distro
    Ubuntu Breezy 5.10

    Unhappy Re: HOWTO : Create a FTP server with user access (proftpd)

    Having a bit of trouble with step 3 "sudo gedit /etc/proftpd.conf" on the first page.

    This file does not exist.

    What have I done wrong, thanks

    I did a search on this file (I think I did the search right) and it does not exist anyware on the system.

  7. #57
    Join Date
    Dec 2005
    Beans
    23

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Try it in a new terminal window.
    When doing a search, I don't remember if it is a hidden file (don't think so).
    Last edited by steve_250; January 10th, 2006 at 02:46 AM.

  8. #58
    Join Date
    Jan 2006
    Beans
    9
    Distro
    Ubuntu Breezy 5.10

    Red face Re: HOWTO : Create a FTP server with user access (proftpd)

    Quote Originally Posted by steve_250
    Try it in a new terminal window.
    When doing a search, I don't remember if it is a hidden file (don't think so).
    Didn't help when I don't read it carefully

    sudo apt-get install proftpd
    Reading package lists... Done
    Building dependency tree... Done
    E: Couldn't find package proftpd

    What did I do wrong?
    Do I have to add extra repositories?

    Thanks
    Last edited by BlueIce; January 10th, 2006 at 05:45 AM.

  9. #59
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Bluelce, indeed you shouldn't have all the repositories enabled. You could post you /etc/apt/source.list here if you wish otherwise you will find all needed informations about source.list here : http://www.ubuntuforums.org/showthread.php?t=92672.

    steve_250, your configuration sounds good for me, so i think the problem should be your Netgear FVS318 configuration, because all your FTP server configuration seems good.

  10. #60
    Join Date
    Aug 2005
    Location
    Michigan, USA
    Beans
    53
    Distro
    Kubuntu Breezy 5.10

    Re: HOWTO : Create a FTP server with user access (proftpd)

    steve_250

    Take a look at these links from frodon's HOWTO.

    Other stuff
    If you have a router you should read that, it describe the 2 commands to add in proftpd.conf and why.
    If you have a dynamic DNS have a look here, you can also use ddclient(maybe easier for newbies).
    Most of informations you're looking for are here
    To get more debug informations : http://www.proftpd.org/localsite/Use...ked/x1058.html
    You can specify a specific passive port range using PassivePorts command, it's very useful when you use a firewall in order to know which ports to allow.

Page 6 of 123 FirstFirst ... 456781656106 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •