View Poll Results: Do you think that gproftpd is useful ?

Voters
872. You may not vote on this poll
  • Yes, it's easy to use and really powerful

    473 54.24%
  • Yes, but i won't use it

    136 15.60%
  • No, the GUI has to be improved

    263 30.16%
Page 103 of 123 FirstFirst ... 35393101102103104105113 ... LastLast
Results 1,021 to 1,030 of 1225

Thread: HOWTO : Create a FTP server with user access (proftpd)

  1. #1021
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    sFTP is FTP in ssh tunnel so this has nothing to do with proftpd but with your ssh server configuration.

  2. #1022
    Join Date
    Nov 2007
    Location
    Sweden
    Beans
    2,182

    Re: HOWTO : Create a FTP server with user access (proftpd)

    I prefer pureftpd over this one any day.
    Operating system: Debian Wheezy 7.0.
    Computer: Celeron 2 ghz laptop, 2 GB RAM.
    Linux user since -99.

  3. #1023
    Join Date
    Jan 2009
    Beans
    58

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Oh, man, this is driving me crazy!
    I've been working on this for days, poring over this thread, and any related ones I could find.

    I have a router, with a dynamic IP. I've assigned it a name from dyndns.com (gaygoyle.homelinux.org), and set up the router to automatically update.

    I've set up the FTP user (ftp1) in "Users & Groups". I have the shell set to /bin/false.

    I have port 1980 forwarded, as well as ports 60000-65535. I made sure that I had the proper IP for the machine that the ports were being forwarded to.

    Also, I have the ftp directory (/home/ftp1) permissions set to 755.

    Still, when I try to log in, both with the DynDNS address and the IP number, I get "connection refused". I'm using gFTP for the client. I tried this website, too, and got a more verbose error:

    Code:
    * About to connect() to gargoyle.homelinux.org port 1980
    * Trying 98.237.xxx.xxx... connected
    * Connected to gargoyle.homelinux.org (98.237.xxx.xxx) port 1980
    < 500 FTP server shut down (Tue Jun 16 09:29:22 2009 , Current connections will be dropped: Tue Jun 16 09:19:22 2009) -- please try again later
    * This doesn't seem like a nice ftp-server response
    * Closing connection #0
    Here's my proftpd.conf:

    Code:
    AllowOverwrite on
    AuthAliasOnly on
    
    # Choose here the user alias you want !!!!
    UserAlias sauron ftp1
    
    ServerName          "ChezFrodon"
    ServerType          standalone
    DeferWelcome            on
    
    MultilineRFC2228 on
    DefaultServer           on
    ShowSymlinks            off
    
    TimeoutNoTransfer 600
    TimeoutStalled 100
    TimeoutIdle 2200
    
    DisplayFirstChdir               .message
    ListOptions                 "-l"
    
    RequireValidShell       off
    
    TimeoutLogin 20
    
    RootLogin           off
    
    # It's better for debug to create log files ;-)
    ExtendedLog             /var/log/ftp.log
    TransferLog             /var/log/xferlog
    SystemLog           /var/log/syslog.log
    
    #DenyFilter         \*.*/
    
    # I don't choose to use /etc/ftpusers file (set inside the users you want to ban, not useful for me)
    UseFtpUsers off
    
    # Allow to restart a download
    AllowStoreRestart       on
    
    # Port 21 is the standard FTP port, so you may prefer to use another port for security reasons (choose here the port you want)
    Port                1980
    
    # To prevent DoS attacks, set the maximum number of child processes
    # to 30.  If you need to allow more than 30 concurrent connections
    # at once, simply increase this value.  Note that this ONLY works
    # in standalone mode, in inetd mode you should use an inetd server
    # that allows you to limit maximum number of processes per service
    # (such as xinetd)
    MaxInstances 8
    
    # Set the user and group that the server normally runs at.
    User                  nobody
    Group                 nogroup
    
    # Umask 022 is a good standard umask to prevent new files and dirs
    # (second parm) from being group and world writable.
    Umask               022 022
    
    PersistentPasswd        off
    
    MaxClients 8
    MaxClientsPerHost 8
    MaxClientsPerUser 8
    MaxHostsPerUser 8
    
    # Display a message after a successful login
    AccessGrantMsg "welcome !!!"
    # This message is displayed for each access good or not
    ServerIdent                  on       "you're at home"
    
    # Set /home/FTP-shared directory as home directory
    DefaultRoot /home/ftp1
    
    # Lock all the users in home directory, ***** really important *****
    DefaultRoot ~
    
    MaxLoginAttempts    5
    
    #VALID LOGINS
    <Limit LOGIN>
    AllowUser ftp1
    DenyALL
    </Limit>
    
    <Directory /home/ftp1>
    Umask 022 022
    AllowOverwrite off
        <Limit MKD STOR DELE XMKD RNRF RNTO RMD XRMD>
        DenyAll
        </Limit>
    </Directory>
    
    <Directory /home/ftp1/download/*>
    Umask 022 022
    AllowOverwrite off
        <Limit MKD STOR DELE XMKD RNEF RNTO RMD XRMD>
        DenyAll
        </Limit>
    </Directory>
    
    <Directory /home/ftp1/upload/>
    Umask 022 022
    AllowOverwrite on
        <Limit READ RMD DELE>
            DenyAll
            </Limit>
    
            <Limit STOR CWD MKD>
            AllowAll
            </Limit>
    </Directory>
    
    MasqueradeAddress gargoyle.homelinux.org
    MasqueradeAddress 98.237.xxx.xxx
    
    UseReverseDNS off
    IdentLookups off

  4. #1024
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    First thing try to set first your server on port 21 as it is often easier on he firewal side. BTW, do you run any firewall on your computer ?
    Then to make it easier your can put AuthAliasOnly to off and then try to login directly with the username (i guess this won't really help but ...)

  5. #1025
    Join Date
    Jan 2009
    Beans
    58

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Quote Originally Posted by frodon View Post
    First thing try to set first your server on port 21 as it is often easier on he firewal side. BTW, do you run any firewall on your computer ?
    Then to make it easier your can put AuthAliasOnly to off and then try to login directly with the username (i guess this won't really help but ...)
    I tried it both ways, same error.
    I also tried logging in with just the IP address.

    How do I know if I have a firewall running?

  6. #1026
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    If you haven't set on thne you should not have any. Are you trying to log in from the computer that runs the server ?

    If not it is the thing to try to exclude any network config issue.

  7. #1027
    Join Date
    Jan 2009
    Beans
    58

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Quote Originally Posted by frodon View Post
    Are you trying to log in from the computer that runs the server ?
    Yes.

  8. #1028
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Remove your /etc/shutmsg file and try again (i mean restart the server with /etc/init.d/proftp restart). If it still doesn't work re-install proftpd.

  9. #1029
    Join Date
    Jan 2009
    Beans
    58

    Re: HOWTO : Create a FTP server with user access (proftpd)

    OK, this seems to be getting somewhere.
    Now, I get this error:
    Code:
    * About to connect() to gargoyle.homelinux.org port 21
    * Trying 98.237.xxx.xxx... connected
    * Connected to gargoyle.homelinux.org (98.237.xxx.xxx) port 21
    < 220 you're at home
    
    > USER ftp1
    < 331 Password required for ftp1
    
    > PASS *****
    < 530 Login incorrect.
    * Access denied: 530
    * Closing connection #0
    I uninstalled and re-installed proftpd, which changed nothing. I changed the password for ftp1 in the Users & Groups control panel, and the command line. Still getting this error.

  10. #1030
    Join Date
    Jun 2005
    Location
    France
    Beans
    7,100
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HOWTO : Create a FTP server with user access (proftpd)

    Perform a search in the thread with "530 error" as keyword and you should find the information you need.
    It is the most common error setting proftpd, nothing serious, either your password has not been set correctly either your are using wrong username (e.g. using user name when alias is expected).

Page 103 of 123 FirstFirst ... 35393101102103104105113 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •