Page 2 of 18 FirstFirst 123412 ... LastLast
Results 11 to 20 of 180

Thread: HOWTO: Surround sound in pulseaudio

  1. #11
    Join Date
    Apr 2005
    Location
    C A N A DA
    Beans
    268
    Distro
    Ubuntu

    Re: HOWTO: Surround sound in pulseaudio

    Hi sammydee, thanks for the great guide!

    few questions for you: how do you determine the audio card ID?
    I'm asking cause I have 2 sound cards. 1 for speakers and 1 for headset.
    Perhaps you can help me out with the setup I'm trying to configure:
    see this post: http://ubuntuforums.org/showpost.php...2&postcount=61
    now using nstamoul's paconfig tool I did manage to get get both sound cards recognized in the Pulse Manager.
    I have a 4.1 speaker setup too so I already added the same settings as you mentioned in your post.
    thanks
    Running: Ubuntu 10.10 & Windows 7 Pro
    Registered Linux User #373810
    Become a Registered Linux User Here.

  2. #12
    Join Date
    Jan 2006
    Location
    Bristol, UK
    Beans
    275
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Surround sound in pulseaudio

    Quote Originally Posted by MeURi View Post
    I edited my first post inserting my hardware information, but you had already replied, so I think you missed it... well, no problem

    Yes, I have an ICH4 chipset, and I'm using the onboard audio controller. I hoped to get it working Windows-like with PA... maybe it's just a matter of trial-and-error before getting it to work properly

    Under Windows I don't think I can swap channels, but I have to check; anyway, my 'problem' is posted here because I come from Windows (and still use it), if I tried Windows coming from Ubuntu, I'd probably say that Windows swaps my channels

    As far as I can use MPlayer to have a 'correct' output, I don't complain too much (since I notice channel swapping only with real 5.1 audio, not with upmixed stereo); but one question arises: if the channel swapping is a common problem, why doesn't it get corrected? No flaming purpose, here, I just wonder...

    Thanks for your replies

    Right, I have chatted with the bods on IRC and apparently I was right, you have to do it like this. This is what you had:

    Code:
    load-module module-alsa-sink device=hw:0,0 sink_name=AC97 channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe
    load-module module-remap-sink sink_name=RealtekALC650.Playback master=AC97 channels=6 master_channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe channel_map=front-left,front-right,front-center,lfe,rear-left,rear-right
    load-module module-alsa-source device=hw:0,0 source_name=RealtekALC650.Capture channels=2
    You must replace that with:

    Code:
    ## load sink
    load-module module-alsa-sink device=hw:0,0 sink_name=AC97 channels=6 channel_map=front-left,front-right,front-center,lfe,rear-left,rear-right
    ## load source
    load-module module-alsa-source device=hw:0,0 source_name=RealtekALC650.Capture channels=2
    and forget module-remap-sink completely, it isn't needed.

    This SHOULD work. Let me know if it does.

    Sam

  3. #13
    Join Date
    Jan 2006
    Location
    Bristol, UK
    Beans
    275
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Surround sound in pulseaudio

    By the way, I find I get the best results using totem-gstreamer rather than mplayer. You can test by opening the pulseaudio volume control and muting all the output channels of the stream, then unmuting one at a time to see if it comes out of the correct speaker.

    Sam

  4. #14
    Join Date
    Jan 2006
    Location
    Bristol, UK
    Beans
    275
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Surround sound in pulseaudio

    Quote Originally Posted by MemoryDump View Post
    Hi sammydee, thanks for the great guide!

    few questions for you: how do you determine the audio card ID?
    I'm asking cause I have 2 sound cards. 1 for speakers and 1 for headset.
    Perhaps you can help me out with the setup I'm trying to configure:
    see this post: http://ubuntuforums.org/showpost.php...2&postcount=61
    now using nstamoul's paconfig tool I did manage to get get both sound cards recognized in the Pulse Manager.
    I have a 4.1 speaker setup too so I already added the same settings as you mentioned in your post.
    thanks
    If you go to the pulseaudio manager (command: paman) you can see which sound cards are available and what id_number they have.

    Sam

  5. #15
    Join Date
    Mar 2008
    Location
    Vimercate (MI), Italy
    Beans
    126
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Surround sound in pulseaudio

    Thanks for your help, sammydee

    I've been busy these days, so I haven't tried much... I promise to test thoroughly my setup in these days

    Anyway, one thing for sure: Windows has no easy way to swap channels

    I'll let you know what I come up with
    2B OR (NOT 2B) That is the question. The answer is FF

  6. #16
    Join Date
    Mar 2008
    Location
    Vimercate (MI), Italy
    Beans
    126
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: HOWTO: Surround sound in pulseaudio

    Back on Ubuntu, and finally got my setup to work correctly

    Obviously, thanks to you

    I have to point out only one thing: in my default.pa, when manually loading sink and source, I had to specify device=hw:0, not device=hw:0,0, nor device_id=0, otherwise I got alsa_ctl complaining about extra parameters, or surround51 unavailable (launching PA from terminal)

    So, in the end, my default.pa looks like this
    Code:
    #!/usr/bin/pulseaudio -nF
    #
    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify it
    # under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software Foundation,
    # Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
    
    .nofail
    
    ### Load something into the sample cache
    #load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
    load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
    #load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
    #load-sample-lazy pulse-access /usr/share/sounds/generic.wav
    
    .fail
    
    ### Load audio drivers statically (it's probably better to not load
    ### these drivers manually, but instead use module-hal-detect --
    ### see below -- for doing this automatically)
    load-module module-alsa-sink device=hw:0 sink_name=RealtekALC650.Playback channels=6 channel_map=front-left,front-right,front-center,lfe,rear-left,rear-right
    load-module module-alsa-source device=hw:0 source_name=RealtekALC650.Capture channels=2
    #load-module module-oss device="/dev/dsp" sink_name=output source_name=input
    #load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
    #load-module module-null-sink
    #load-module module-pipe-sink
    
    ### Automatically load driver modules depending on the hardware available
    #.ifexists module-hal-detect.so
    #load-module module-hal-detect
    #.else
    ### Alternatively use the static hardware detection module (for systems that
    ### lack HAL support)
    #load-module module-detect
    #.endif
    
    ### Load several protocols
    .ifexists module-esound-protocol-unix.so
    load-module module-esound-protocol-unix
    .endif
    load-module module-native-protocol-unix
    
    ### Network access (may be configured with paprefs, so leave this commented
    ### here if you plan to use paprefs)
    #load-module module-esound-protocol-tcp
    #load-module module-native-protocol-tcp
    #load-module module-zeroconf-publish
    
    ### Load the RTP reciever module (also configured via paprefs, see above)
    #load-module module-rtp-recv
    
    ### Load the RTP sender module (also configured via paprefs, see above)
    #load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 description="RTP Multicast Sink"
    #load-module module-rtp-send source=rtp.monitor
    
    ### Automatically restore the volume of playback streams
    load-module module-volume-restore
    
    ### Automatically restore the default sink/source when changed by the user during runtime
    load-module module-default-device-restore
    
    ### Automatically move streams to the default sink if the sink they are
    ### connected to dies, similar for sources
    load-module module-rescue-streams
    
    ### Automatically suspend sinks/sources that become idle for too long
    load-module module-suspend-on-idle
    
    ### Load X11 bell module
    #load-module module-x11-bell sample=x11-bell
    
    ### Register ourselves in the X11 session manager
    # Deactivated by default, to avoid deadlock when PA is started as esd from gnome-session
    # Instead we load this via /etc/xdg/autostart/ and "pactl load-module" now
    # load-module module-x11-xsmp
    
    ### Load additional modules from GConf settings. This can be configured with the paprefs tool.
    ### Please keep in mind that the modules configured by paprefs might conflict with manually
    ### loaded modules.
    .ifexists module-gconf.so
    .nofail
    load-module module-gconf
    .fail
    .endif
    
    ### Publish connection data in the X11 root window
    .ifexists module-x11-publish.so
    .nofail
    load-module module-x11-publish
    .fail
    .endif
    
    ### Make some devices default
    #set-default-sink output
    #set-default-source input
    As a suggestion, you could insert the channel remapping thing in your first post

    Thanks again, sammydee
    2B OR (NOT 2B) That is the question. The answer is FF

  7. #17
    Join Date
    May 2008
    Location
    India
    Beans
    7
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Surround sound in pulseaudio

    Thanks a lot sammydee. I spent 3 days in searching how to configure the sound settings of my system so that my 4.1 speakers could work but got nothing. You have really done a great favour for everybody.
    Thank you very much.

  8. #18
    Join Date
    May 2008
    Beans
    25

    Re: HOWTO: Surround sound in pulseaudio

    The "Easy way" worked like a charm for me.
    Thanks

  9. #19
    Join Date
    Jan 2007
    Location
    Connecticut
    Beans
    1,641
    Distro
    Ubuntu Development Release

    Re: HOWTO: Surround sound in pulseaudio

    easy way worked for me as well!

    don't know if its actual 5.1 surround, or just the same 2 channels being shared throughout...but it is sound and it is coming from all 6 speakers!

    and for this abit an8sli's onboard CK804....that is a first!

  10. #20
    Join Date
    Jan 2006
    Location
    Bristol, UK
    Beans
    275
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: HOWTO: Surround sound in pulseaudio

    I'm glad I've been able to help so many people, this problem was driving me up the wall when I had it.

    Here is a sound file I just made that should test surround sound for you. All of the channels should say which channel they are, and the subwoofer should just boom at you. It's available on my webserver here.

    I'm surprised Ubuntu doesn't come with a proper multichannel test file to be honest.

    Sam

Page 2 of 18 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •