Results 1 to 9 of 9

Thread: Getting Samba to work

  1. #1
    Join Date
    May 2008
    Beans
    4

    Getting Samba to work

    I am trying to get Samba (server) set up on Ubuntu. I am using the directions found on:

    https://help.ubuntu.com/community/SettingUpSamba

    I installed the samba server (sudo apt-get install smbfs). That went fine.

    Then I went to the network settings. The instructions tell me to enter some stuff for both "host settings" and "windows networking". There are options available for host settings, but nothing appears under the general tab for "windows networking."

    Is there somewhere else I should be looking for those settings?

    Thanks,
    --Steve

  2. #2
    Join Date
    May 2008
    Beans
    4

    Re: Getting Samba to work

    BTW, this is ubuntu 8.04. I see that in earlier versions of Ubuntu the windows config was under system -> admin -> share folders. In 8.04, it apperas to be nowhere!

    Thanks,
    --Steve

  3. #3
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Getting Samba to work

    I just took a stab at this question in post # 6 of this thread.

    Hope it helps...

  4. #4
    Join Date
    Jan 2006
    Beans
    1,234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Getting Samba to work

    Code:
     sudo apt-get install system-config-samba
    System > Administration > Samba

  5. #5
    Join Date
    May 2008
    Beans
    4

    Re: Getting Samba to work

    Quote Originally Posted by cb951303 View Post
    Code:
     sudo apt-get install system-config-samba
    System > Administration > Samba
    Ok, I installed system-config-samba and ran the above command. However, it crashed! It created a window that said "spawning samba"; then it closed that window and alerted me to a system crash.

    ???

    --Steve

  6. #6
    Join Date
    Mar 2007
    Beans
    Hidden!
    Distro
    Xubuntu 9.10 Karmic Koala

    Re: Getting Samba to work

    There's a bug report on that in Launchpad here.

    This is pasted from a solution suggested there:
    In the Traceback,txt I see
    SystemError: could not open configuration file `/etc/libuser.conf': No such file or directory

    So, I did

    sudo touch /etc/libuser.conf

    and now the tool starts.........

  7. #7
    Join Date
    May 2008
    Beans
    4

    Re: Getting Samba to work

    Quote Originally Posted by jetsam View Post
    There's a bug report on that in Launchpad here.

    This is pasted from a solution suggested there:
    Ok, I got the samba config to run and set up a share. However! It is stilled not visible on my XP network browser.

    I took a look at the Samba server settings, and it is indeed using the correct workgroup ('mshome').

    Any ideas? (This is Ubuntu-via-VirtualBox, BTW).

    Thanks,
    --Steve

  8. #8
    Join Date
    Jan 2006
    Beans
    1,234
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Getting Samba to work

    you should add your user to the samba group

    also in samba manager make sure "visible" is checked for your shared directory

  9. #9
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Getting Samba to work

    This help at all?
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •