Page 6 of 6 FirstFirst ... 456
Results 51 to 60 of 60

Thread: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

  1. #51
    Join Date
    Aug 2009
    Beans
    1

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    According to a post over at https://answers.launchpad.net/ubuntu...question/62380 there might be a bug in Jaunty's (9.04) IPV6 code that is causing Xvnc to not launch GDM.

    After following this guide I was also experiencing the problem on 9.04 (64 bit version), whereby I could open a VNC session but just got the grey screen with an X cursor. Changing -query localhost in the server_args parameter of /etc/xinet.d/Xvnc to -query 127.0.0.1 as recommended in the referenced post did the trick for me.

    The full line that's working for me is:
    server_args = -inetd -query 127.0.0.1 -geometry 1024x768 -depth 16 -cc 3 -once -SecurityTypes=none -extension XFIXES

    Finding that fix is four hours of my life that I'll never get back - hope this helps you!

  2. #52
    Join Date
    Aug 2009
    Beans
    3

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Quote Originally Posted by azzopardim View Post
    Running Ubuntu 9.04 and I have the same problem of not seeing the gdm but only get the grey X11 screen. Tried the configuration mentioned for gm.conf and Xvnc. Can anybody help ?

    @ Azzopardim: If you DO get an X-server (gray with the old style mous-pointer) you might want to adding the following (for gnome) to the top of your xstartup file:

    Code:
    unset SESSION_MANAGER
    exec sh /etc/X11/xinit/xinitrc
    Note the sh, btw! However, I (as well as others) am experiencing theme-switching. The theme-chooser will very shortly change the theme, but when I stop using the chooser itself it refers back to the default icon/theme appearance. Anyone got an idea/link? EDIT: Apperantly this is a bug in 9.04
    Last edited by Crugster; August 13th, 2009 at 08:30 PM. Reason: Added the notion that its a known bug

  3. #53
    Join Date
    Mar 2009
    Beans
    12

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    tightvncserver problems with Ubuntu server 8.04

    Hi!

    Just wanted to add that tightvncserver has some sort of character encoding problem with 8.04 LTS. As stated earlier in this thread, use vnc4server instead.
    I.e., if your keyboard input is received as the wrong characters by your vnc server, you may have installed tightvncserver instead of vnc4server.
    E.g., if you hit the keys asdf and you see abhk or something similar, be sure to use the RealVNC variant of the VNC server, which is labelled vnc4server in most cases.
    This information would have saved me a lot of trouble, and I just wanted to make sure other users know about it.

    Aloha,
    -Jeff Mings

  4. #54
    Join Date
    Nov 2007
    Beans
    16

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    I got the grey screen as well. I fixed it by making the changes in /etc/gdm/gdm.conf-custom instead of /etc/gdm/gdm.conf

  5. #55
    Join Date
    Dec 2008
    Beans
    14

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    I'm running Ubuntu 9.10. I just ran into the "grey screen of X" for the first time. Until I ran update-manager this evening and accepted all its suggestions, my setup had been working fine.

    My best guess at a diagnosis is that the file named /usr/lib/gdm/gdmgreeter does not exist on my system. So if gdm goes looking for one, it will fail and a bare X screen is a likely consequence. After investigating the contents of /usr/lib/gdm, I directed gdm to use a greeter that does exist. This happens in the gdm configuration file. I don't know where the main one is kept ... but it is certainly not in /etc/gdm/gdm.conf. That file is not present in my nearly-default installation. However, I do have a file named /etc/gdm/custom.conf. I arranged it to contain just these four lines:
    Code:
    [xdmcp]
    Enable=true
    [daemon]
    RemoteGreeter=/usr/lib/gdm/gdm-simple-greeter
    (Earlier posts have recommended adding some settings under the [security] heading that actually reduce the system's security. I'm glad everything works without them!)

    For completeness/reference, here is what I have in /etc/xinetd.d/vnc. Another user suggested explicitly writing the numbers 127.0.0.1 instead of the name localhost. I tried this while groping around, but now I'm not certain whether it was this or the gdmgreeter symlink that solved my problem.
    Code:
    # Start a VNC connection with gdm login prompt: 1280x1024, 24bpp.
    service 1280x1024-24
    {
    	type		= UNLISTED
    	port		= 5901
    	socket_type     = stream
    	protocol        = tcp
    	wait            = no
    	user            = nobody
    	server          = /usr/bin/Xvnc
    	server_args     = -inetd -noreset -SecurityTypes None -once -extension XFIXES -fp /usr/share/fonts/X11/misc,/usr/share/fonts/X11/75dpi -co /usr/share/X11/rgb -geometry 1263x1024 -depth 24 -query 127.0.0.1
    }
    I'm not sure if my last step is truly needed, but I also added one line to mention this service in my file /etc/services:
    Code:
    1280x1024-24	5901/tcp			# VNC Service
    I hope this might help somebody else fighting the grey screen of X.
    Last edited by PhDLinux; January 17th, 2010 at 04:24 AM. Reason: Updated listing and description of /etc/gdm/custom.conf

  6. #56
    Join Date
    Jan 2010
    Beans
    1

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Quote Originally Posted by PhDLinux View Post
    Another user suggested explicitly writing the numbers 127.0.0.1 instead of the name localhost. I tried this while groping around, but now I'm not certain whether it was this or the gdmgreeter symlink that solved my problem.
    It was the localhost name that was the problem. I have just been fighting with this for the past 6 hours. I finally got it to work by changing localhost to 127.0.0.1. (Found it by accident when Xnest-ing in from a different machine would work when localhost-ing would not!) So for some reason the localhost name quit working. The error logs were full of errors like

    Code:
    Jan 17 18:11:18 MYCOMPUTER gdm-simple-slave[5161]: WARNING: Unable to connect to display ::1:9
    and /var/run/gdm was filling up with auth-for-gdm-xxxxxx directories.

    It looks like something in the recent updates was not allowing X communications without an explicit IP address. Anyone have any clue which update? (I hate X sometimes)

  7. #57
    Join Date
    Nov 2007
    Beans
    1

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 10.04 Desktop

    I need help, I am working in ubuntu 10.04,but there is no configure file on the dirctory /etc/gdm/gdm.conf,how can I do ? and I need more message about how to configure vnc4server on ubuntu10.04 ,such as vieweronly,alwaysshared,client login automaticly, how can I write this option to the configure file, I means I dont know "value"and "values" exactly, thanks for help me !

  8. #58
    Join Date
    Jun 2006
    Beans
    303

    Question Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Hmmm... this almost works. By "almost" I mean the remote desktop appears briefly, then causes my vnc client (RealVNC 4.1) to close immediately.

    Any idea what could be the reason and how to fix this?

    If this could be of any relevance, I looked at my remote server logs and founds this:

    Quote Originally Posted by /var/log/daemon.log
    Nov 11 15:17:04 myubuntu xinetd[6730]: warning: can't get client address: Transport endpoint is not connected
    and:
    Quote Originally Posted by /var/log/gdm/:0.log
    (==) Log file: "/var/log/Xorg.0.log", Time: Thu Nov 11 15:31:57 2010
    (==) Using config file: "/etc/X11/xorg.conf"
    (II) Module "ramdac" already built-in
    expected keysym, got XF86KbdLightOnOff: line 70 of pc
    expected keysym, got XF86KbdBrightnessDown: line 71 of pc
    expected keysym, got XF86KbdBrightnessUp: line 72 of pc
    expected keysym, got XF86KbdLightOnOff: line 70 of pc
    expected keysym, got XF86KbdBrightnessDown: line 71 of pc
    expected keysym, got XF86KbdBrightnessUp: line 72 of pc
    SetGrabKeysState - disabled
    SetGrabKeysState - enabled
    Thanks.
    Ubuntu 6.06.1 LTS (Dapper Drake) running on:
    > ASUS P4P800-E Deluxe (Promise 1+0 Stripe/RAID0)
    Ubuntu 8.04 (Hardy Heron) running on:
    > Lenovo 3000 N100 (type 0768, model 36U)

  9. #59
    Join Date
    Jun 2006
    Beans
    303

    Lightbulb Re: HOWTO: Setup vncserver + gdm on Ubuntu 8.04 Desktop

    Quote Originally Posted by xp_newbie View Post
    Hmmm... this almost works. By "almost" I mean the remote desktop appears briefly, then causes my vnc client (RealVNC 4.1) to close immediately.

    Any idea what could be the reason and how to fix this?
    I fixed it.

    All I did was replace the line:
    Code:
    server_args = -inetd :1 -query localhost -geometry 1920x1080 -depth 24 -once -DisconnectClients=0 -NeverShared passwordFile=/root/.vncpasswd
    With:
    Code:
    server_args = -inetd -query localhost -geometry 1920x1080  -depth 24 -cc 3 -once -SecurityTypes=none -extension XFIXES
    Frankly, I don't really understand why this works because I don't have the time right now to delve into this. It just works (with the annoying side-effect of starting a new Gnome desktop session for every VNC run, when I really need only one)
    Ubuntu 6.06.1 LTS (Dapper Drake) running on:
    > ASUS P4P800-E Deluxe (Promise 1+0 Stripe/RAID0)
    Ubuntu 8.04 (Hardy Heron) running on:
    > Lenovo 3000 N100 (type 0768, model 36U)

  10. #60
    Join Date
    Jul 2009
    Beans
    46

    Re: HOWTO: Setup vncserver + gdm on Ubuntu 10.04 Desktop

    using Ubuntu 10.04 the GDM config file is not there, anyone know where it is or how to set this up correctly?

Page 6 of 6 FirstFirst ... 456

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •