Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Numlock keypad broke after upgrade

  1. #1
    Join Date
    Aug 2006
    Location
    Kitchener, Ontario
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Numlock keypad broke after upgrade

    I upgraded my wifes computer yesterday to ubuntu 8.04, now after the upgrade the numlock keypad stopped working, the light would toggle, but that would still not help in getting it to type. I tried a few different layouts in System -> Preferences -> Keyboard, generic 104 i would have thought would work. The keyboard does work in terminal if you Ctrl-Alt-F1 for example, so it is a gnome thing!?!, i tried to do a dpkg-reconfigure xserver-org but that didn't help

    I also tried copying my old xorg.conf file in to place but also didn't change.

    It is PS2 keyboard hp KB-0316

    Thanks

  2. #2
    Join Date
    Aug 2006
    Location
    Kitchener, Ontario
    Beans
    14
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    SOLVED - Numlock keypad broke after upgrade

    During the upgrade an assistive feature was turned on

    System -> Preferences -> Assistive Technologies -> Keyboard Accessibility -> Mouse Keys, uncheck Allow to control the pointer using the keyboard.

    Hope this can help someone else in the future.

  3. #3
    Join Date
    Oct 2005
    Beans
    5

    Re: Numlock keypad broke after upgrade

    I'm on 8.10 on a laptop, and a few days ago my external usb keyboard started always being in numlock mode when I log into ghome. Two major problems:

    1. It's a compact keyboard with the numeric keypad superimposed on the alphanumeric/regular keypad. So when numlock is on I can't use uiopjkl;m or /

    2. I can't seem to turn off numlock using the keyboard. There's a numlock button, but it doesn't seem to do anything.

    I managed to get the external keyboard back into non-numlock mode by toggling the numlock key on the laptop builtin keyboard, and maybe unplugging and replugging the external keyboard.

    Today it was even more screwed up, with the superimposed numeric keys now controlling the mouse. Googling got me to your suggestion, which got me back to numeric superimposed keys :P I have no idea why this works, but I was able to get back normal keys by checking

    System->Preferences->Keyboard->Layout->Other Options->Use keyboard LED to show alternative layout->Numlock LED shows alternative layout

    and that fix persists across logouts.

    Note: The problem only starts *after* U log into gnome. On the gdm login screen numlock is always off.

  4. #4
    Join Date
    May 2006
    Location
    Southern California
    Beans
    867
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: SOLVED - Numlock keypad broke after upgrade

    Quote Originally Posted by bluedog800 View Post
    During the upgrade an assistive feature was turned on

    System -> Preferences -> Assistive Technologies -> Keyboard Accessibility -> Mouse Keys, uncheck Allow to control the pointer using the keyboard.

    Hope this can help someone else in the future.
    It did, Thanks!
    (Master be/fe) ASUS P5KPL IPC, E5400, KVR800D2N6K2/2G, 8500GT, (2)PVR-150, A180, ATSC-115, U10.04, MythTV 0.23-fixes.

  5. #5
    Join Date
    Sep 2006
    Beans
    1,152
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: SOLVED - Numlock keypad broke after upgrade

    Hello,

    Quote Originally Posted by bluedog800 View Post
    During the upgrade an assistive feature was turned on

    System -> Preferences -> Assistive Technologies -> Keyboard Accessibility -> Mouse Keys, uncheck Allow to control the pointer using the keyboard.

    Hope this can help someone else in the future.
    Thank's a lot!

    Regards!

  6. #6
    Join Date
    Nov 2004
    Location
    Castlemaine, Australia
    Beans
    19
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: SOLVED - Numlock keypad broke after upgrade

    Quote Originally Posted by bluedog800 View Post
    During the upgrade an assistive feature was turned on

    System -> Preferences -> Assistive Technologies -> Keyboard Accessibility -> Mouse Keys, uncheck Allow to control the pointer using the keyboard.

    Hope this can help someone else in the future.
    This has been driving me CRAZY. Thanks heaps. I haven't logged on here for 18 months, but did to give a big thanks

  7. #7
    Join Date
    May 2006
    Location
    Southern California
    Beans
    867
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: SOLVED - Numlock keypad broke after upgrade

    Coincidence, that this thread comes around again.
    Nums just stopped working on this box. It's been up 4 days, and they worked fine until tonight.
    How/why/what sort of magic causes Mouse Keys bla to become checked on a machine I use every day for a year?
    (Master be/fe) ASUS P5KPL IPC, E5400, KVR800D2N6K2/2G, 8500GT, (2)PVR-150, A180, ATSC-115, U10.04, MythTV 0.23-fixes.

  8. #8
    Join Date
    Jun 2010
    Beans
    2

    Re: Numlock keypad broke after upgrade

    Hello,

    If its your laptop keyboard key that has broken , you don't need to worry that you'll need a whole new keyboard.

    I got my laptop keys replaced by this company at Ebay. They gave me 5 key sets at a very reasonable price. And they have installation video's which makes it really easy to fix the keys
    http://www.laptopkey.com

  9. #9
    Join Date
    Dec 2005
    Beans
    30
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: SOLVED - Numlock keypad broke after upgrade

    I had the same problem.

    Thanks!

  10. #10
    Join Date
    Sep 2007
    Location
    Virginia, USA
    Beans
    12

    Re: Numlock keypad broke after upgrade

    Thanks, I picked up the same problem when upgrading to 10.4.

    I can see the point of defaulting to mouse keys for those who need that kind of assistance, but a brief on-screen note about this and how to change it back during/after the install or upgrade would be appreciated.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •