Results 1 to 6 of 6

Thread: [SOLVED] Hardy doesn't find the swap area

  1. #1
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,186
    Distro
    Ubuntu

    [SOLVED] Hardy doesn't find the swap area

    Hi, I don't know really where to post this. Perhaps not an installation problem. I didn't find anything similar in the forums. Anyway:

    Hardy does not 'see' the swap area in my laptop Toshiba A50 (see specs below). When I type
    Code:
    top
    It says at the 5th line: Swap 0k total, 0k used, 0k free, 296780k cached
    I would expect something as 1400000k of total swap, as I have a swap partition about 1.4 Gb. It seems to be Hardy-specific, as the expected size of swap is displayed ok in Gutsy on the same computer (I have dual boot xp-gutsy-hardy).

    Nevertheless, the swap partition is there, as seen with "fdisk -l". By the way, my hd setup is:
    primaries ntfs(xp), fat32(mydata)
    extended --> ext3(gutsy), ext3(hardy), swap

    I found this problem by hazard, as it didn't lead to any issue, because the system didn't need to swap so far. But it's a potential problem anyway.

    Any help would be thankfully appreciated
    _________________
    TOSHIBA laptop SA50-110 / Pentium M (0.09) 1596MHz / 1.1 Cache =64K, 19704 MB/s / 1.2 cache=2048K, 8674 MB/s / Memory=1007Mb 1039Mb/s
    Chipset: Intel i855GM/GME/F SB 99MHz Mobile platform / Settings: RAM=165MHz (DDR330) / CAS=2.5-3-3-7
    What's even more important than free software? - OPEN FORMATS.

  2. #2
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Hardy doesn't find the swap area

    Edit etc/fstab and add a line to mount /swap at boot.

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  3. #3
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,186
    Distro
    Ubuntu

    Re: Hardy doesn't find the swap area

    Thanks for your prompt answer
    This is my current etc/fstab:

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/sda5
    UUID=ed568681-153a-4feb-ad80-c4075d76d3ce / ext3 relatime,errors=remount-ro 0 1
    # /dev/sda7
    UUID=24e4500c-4577-4d60-8ab3-33cf062a36f1 none swap sw 0 0
    /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
    I would say that the required line is already there, isn't it?
    What's even more important than free software? - OPEN FORMATS.

  4. #4
    Join Date
    Mar 2007
    Location
    Here & Now
    Beans
    16,549
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Hardy doesn't find the swap area

    Check your UUID's with:
    blkid

    Dr. Fernando Duran Dollenz
    Libertad 584
    6824871

  5. #5
    Join Date
    Jan 2008
    Location
    Spain
    Beans
    1,186
    Distro
    Ubuntu

    Re: Hardy doesn't find the swap area

    Ho ho, the blkid command shows this (among others):

    /dev/sda7: TYPE="swap" UUID="d3de1f51-7a24-4f80-97cb-552671126ff2"
    This UUID is different from the one in etc/fstab. I can't figure out how this can happen. Anyway, I have to edit fstab to change this UUID, right? And, have I to create some directory in /media as well? (I think I don't, but asking just in case...)
    What's even more important than free software? - OPEN FORMATS.

  6. #6
    Join Date
    Apr 2008
    Location
    Southern California, USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Hardy doesn't find the swap area

    Quote Originally Posted by JC Cheloven View Post
    Ho ho, the blkid command shows this (among others):



    This UUID is different from the one in etc/fstab. I can't figure out how this can happen. Anyway, I have to edit fstab to change this UUID, right? And, have I to create some directory in /media as well? (I think I don't, but asking just in case...)
    You maybe resized or reformat your hard drive, perhaps. Yes, try changing fstab to relect what blkid shows. If that doesn't work, you can use either gparted(if installed) to remove and reinstall swap or delete swap and type mkswap /dev/sdax , swapon /dev/sdax

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •